summaryrefslogtreecommitdiff
path: root/sci-mathematics/singular
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /sci-mathematics/singular
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'sci-mathematics/singular')
-rw-r--r--sci-mathematics/singular/Manifest2
-rw-r--r--sci-mathematics/singular/singular-4.2.1.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/sci-mathematics/singular/Manifest b/sci-mathematics/singular/Manifest
index 09e146dc18c6..836101987736 100644
--- a/sci-mathematics/singular/Manifest
+++ b/sci-mathematics/singular/Manifest
@@ -6,6 +6,8 @@ AUX singular-4.2.0-gfan_linking.patch 1849 BLAKE2B 11a4ed33cab5265a3b5650270511f
AUX singular-4.2.0-no-static.patch 2644 BLAKE2B 466705130179efe13cd4bdccb09e0bc2a5a0efaf36536009054235f6a44af932c359cee366eef860235739c480fea84e9ca48947597d2c3aaf2e26bdb3fada88 SHA512 53dd7045d717f62817b0fd03963a8cf2ba4e88387b89e854a1cc6a2817bf975fd7e16852e948b64182d049b8c184459d4e071bbb5f8c6ca5998c4c1b964deef5
DIST singular-4.2.0p1.tar.gz 14155171 BLAKE2B 444553f87d7ca8d6a62e4519c9857a6892757e92285df7c3b686913a9b51c9ae8d802c41382b0b2b6e37dc2dc496d4a10f262c98407470219cdce131e8baf127 SHA512 2ecd8940c9e8d70a93dbdb4df6da313c00151e5cb959f8eed5856e8df99089b5a03e514fbcdc70903c77df8b59fa7ef9f3b134f1de510b795fa6ea0341089bd8
DIST singular-4.2.0p3.tar.gz 16641923 BLAKE2B 4dd7e1a42c71bbba625e171aee656580b443656f50458909ffae1af81b1413d5330aa032656032ea365225eb088491fe2a48997895e37bc89eea5f17b8fbebb8 SHA512 b9833389b648ec4ba2bd09253f00254b9ae3dc61313fc81c9003b283fc413caab4274e55750de1c342ef24a8fc0ce817643cd31eabbb2999de7f5017dfa1411f
+DIST singular-4.2.1.tar.gz 16643430 BLAKE2B 2cfc33bd59a5e8756c7ce022ad2b38477a0d7a6747b3c4fd4b1b168cfd179ace52121506cda2c4d5f318abca72231c74f649ede349b17b5f138083428d9da766 SHA512 48bebbe9c886ee56bb2f7bdd9e356bd33e357a2d707c976b8496200f422a2ba25d7c9bba22a261574428abf73a8b6b111d35236fca647e32619659059e861916
EBUILD singular-4.2.0_p1.ebuild 2258 BLAKE2B d74e8ad0c98142364ff097e5e2d8585d01ba863021178d9c5206507c2318e71c0484bf620d77bae4927722395ef9b785d6e00be0d7d7bbd91086d71a2f54e143 SHA512 a9339d04e4beb91f440caede447bd565bf1576cab72b93e44ae39ce9be6ef26e294713b39526baa8c5ff68c867cbcddb9e87c42f19c27ca6e82786e4a5b2bf12
EBUILD singular-4.2.0_p3-r1.ebuild 2428 BLAKE2B af72aae39de23df410fe1d6dfe475c3179f6355fffe1775d4d408bec6fe80aa37022e6a9838a45014488666b56cfaa627f1fc1d007d360fbbe6987f4b3ead197 SHA512 0921b4991019b449054fb7c7c60a9bd39ec6434a19321b79f63470f2e15889945f24bc15f48e12ba16a24ff23c368a73b0b062d0150104d39aa715511766bc55
+EBUILD singular-4.2.1.ebuild 2564 BLAKE2B 8f849b934c52c6e367d70953e0f38c0043a3b0f35075858f3a19d0533e443c9fadab50ccad40d6b3ab8e8812b8b3cb2fe0b36ec9751f11e945ac2728cfc74640 SHA512 69979a38eb3e7c5b590c891595f91465cb3a2140825e0600626390aaa0f6e0a55f4a55a717938bf1923b3a8cb35df361c14a2c944101fba55274ef6cab3d6e45
MISC metadata.xml 275 BLAKE2B aaeef273b6352edaadf69ef76545573fbe0d22a6062f9567bcb34b1fdea4e2fb140b9aa0b4d8f44a3c3e31108f34eb555dded6f5808fac84fd29a83ef184da88 SHA512 e7e449f8bf039a1fc4707c0b12706d27b237fb3e7bee5e457bc79e032a04d7b9eb2901059b007350cc3617689638b76f97fbbd672e2d0101e2071448642415a7
diff --git a/sci-mathematics/singular/singular-4.2.1.ebuild b/sci-mathematics/singular/singular-4.2.1.ebuild
new file mode 100644
index 000000000000..0f3497acf49d
--- /dev/null
+++ b/sci-mathematics/singular/singular-4.2.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools elisp-common flag-o-matic
+
+MY_PN=Singular
+MY_PV=$(ver_rs 3 '')
+# Consistency is different...
+MY_DIR2=$(ver_cut 1-3 ${PV})
+MY_DIR=$(ver_rs 1- '-' ${MY_DIR2})
+
+DESCRIPTION="Computer algebra system for polynomial computations"
+HOMEPAGE="https://www.singular.uni-kl.de/ https://github.com/Singular/Sources"
+SRC_URI="ftp://jim.mathematik.uni-kl.de/pub/Math/${MY_PN}/SOURCES/${MY_DIR}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux"
+IUSE="emacs examples +readline static-libs"
+
+RDEPEND="dev-libs/gmp:0
+ dev-libs/ntl:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+ sci-mathematics/flint
+ sci-libs/cddlib
+ dev-lang/perl
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}"
+
+SITEFILE=60${PN}-gentoo.el
+
+S="${WORKDIR}/${PN}-${MY_DIR2}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2.0-doc_install-v2.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Needed to avoid segfaults in the test suite until
+ #
+ # https://github.com/Singular/Singular/issues/1105
+ #
+ # makes its way into a release.
+ append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
+
+ econf \
+ --with-gmp \
+ --with-ntl \
+ --with-flint \
+ --enable-gfanlib \
+ --disable-debug \
+ --disable-doc \
+ --enable-factory \
+ --enable-libfac \
+ --disable-polymake \
+ --with-libparse \
+ --disable-optimizationflags \
+ --without-python \
+ --without-pythonmodule \
+ --disable-python \
+ --disable-python-module \
+ --disable-python_module \
+ --disable-pyobject-module \
+ $(use_enable static-libs static) \
+ $(use_enable emacs) \
+ $(use_with readline)
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ pushd "${S}"/emacs
+ elisp-compile *.el || die "elisp-compile failed"
+ popd
+ fi
+}
+
+src_install() {
+ # Do not compress singular's info file (singular.hlp)
+ # some consumer of that file do not know how to deal with compression
+ docompress -x /usr/share/info
+
+ default
+
+ dosym Singular /usr/bin/"${PN}"
+
+ # purge .la file
+ find "${ED}" -name '*.la' -delete || die
+}
+
+src_test() {
+ # SINGULAR_PROCS_DIR need to be set to "" otherwise plugins from
+ # an already installed version of singular may be used and cause segfault
+ # See https://github.com/Singular/Sources/issues/980
+ SINGULAR_PROCS_DIR="" emake check
+}
+
+pkg_postinst() {
+ einfo "Additional functionality can be enabled by installing"
+ einfo "sci-mathematics/4ti2"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}