summaryrefslogtreecommitdiff
path: root/sci-mathematics/singular
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-05 03:35:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-05 03:35:56 +0100
commit9ce4c0d3ec7daef46290a34cf0b02ae0d5b4f2f2 (patch)
tree5ad737c6cd21990a310b972f927f43980c2d304b /sci-mathematics/singular
parent64ae9c18e99cfcf94f587b8adc9bf9aae3f6d1fb (diff)
gentoo auto-resync : 05:06:2023 - 03:35:56
Diffstat (limited to 'sci-mathematics/singular')
-rw-r--r--sci-mathematics/singular/Manifest2
-rw-r--r--sci-mathematics/singular/singular-4.3.2_p1.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/sci-mathematics/singular/Manifest b/sci-mathematics/singular/Manifest
index 885674a40ebb..65b6be7f322f 100644
--- a/sci-mathematics/singular/Manifest
+++ b/sci-mathematics/singular/Manifest
@@ -1,6 +1,8 @@
AUX 60singular-gentoo.el 298 BLAKE2B 5b42e2083037e2ff2ace5597ddebfb079920e09ed91d1a359e058fc654c6778456174d6cee9242f7fcaf81bf1464f47f43604b9e4eb298f051c6a4daba4630ca SHA512 4c17a25d91c085e12f26441fcde858e61bf191bd7d9dcf63ff5b5a1dce1d63e3f7c4f78ce8afa4f2359ad4ba6eb51f3e224ae6c502b18f5f7a76738534337431
DIST singular-4.3.1p1.tar.gz 15090370 BLAKE2B d4e40378b3892b98b1f78c3928c8a40484336ea25ea4dcd4b3a1e5f651281d2cdb06d92c9cc64427ce76e91c5bf4eaa1c3b643df174a24c188823ae808817ad9 SHA512 d27d8e042ea085e49aed6a0697056c36e78e62ea0b9d17751cdf4c556cf4f6efce3b34b411c77aef97c6d90675bea11c97651eb7009634cb8a9b630ec820a06e
DIST singular-4.3.1p3.tar.gz 14991986 BLAKE2B 0ae2585a362839914d3a134bfe637f6faa34d95f58937f2adcca0c5a35e3218eb36554bae8187f5bb3a423dcac445c836e9bfff2d0d1a19d4e14a4452b84d839 SHA512 f092683f4a92158d82a2e694f284662c6285bac5faaa7d5e5695a84a220012fb8a733b4bbc52820def3037e1596ea4c2ab3846f58a3a3fb19e01bf7595790462
+DIST singular-4.3.2p1.tar.gz 15013729 BLAKE2B 00276f2417cd9e2b71afcae66c2aeb7f9d4f434f5a90deeee56dded66e6d5e0020ab0b06b6561e41f5b196262993732ffeb9196f59315f1b6a081b0029fc99a1 SHA512 451054a0bf33b9d1c94a63f0946e1eb7b3e7b92bc025b6aa4f64e65183aeebd6354bac5f87f6e8b35cb713b30e97af5c66f92f02683144bb426f5e3a828db616
EBUILD singular-4.3.1_p1.ebuild 2294 BLAKE2B 1147387c35f31d8bef97c67ec8d4596952494c85d8dd0c427981c7d491200fb3eb02658f3f63fde4e8323e1cc0f9ccbb467ae73ba17bbba12a05831b12f35348 SHA512 2d0c8047da3d2940f7ada1f68f314b7499a497dce09d7166f866f62bd67ab315df7bca5e90af07f897839ceb288651dd6be347a1ecceaa8ce6177f9a30df72d9
EBUILD singular-4.3.1_p3.ebuild 2300 BLAKE2B 8335c3d556cb98834fa9f8f9a5287954b62444a30f3d6e4c5602b425f03d2646fe8fafe922bf41a0e978104e6cf424e4c5afbaf9263758a38b2e7931398a4362 SHA512 2beceeec3f73e1ef4fe470642d170eb4a0dce7d737dfb9453ca7cb1ab0283ab9199cb01a490487580ebb9a4f57f74ccc7c3742ddae6fe776396dee92ab648d3f
+EBUILD singular-4.3.2_p1.ebuild 2376 BLAKE2B 720c51a9a7958b48627f917a7b2eeef12cf6c6b30fd2d3e06ed68178f1872c856cd9d148b55192dc9ee7077864b21315c9f071d17323dc091f631399a7000ed8 SHA512 b996be342bca09aa4019e36b3c2d4f7c2732944f55597464f94d4980fa2cc10727b9c43b47dc2f0ddc9e4d1ef57c782735e5949cd02ba0653e8db33b3dab3fc7
MISC metadata.xml 862 BLAKE2B a6e991149cb925158806177b1b4a76da2b747b3273b395c14455993a99f4cf83de141980303a068b9068983b8adf4da884b81e80546a3d2dd162f188dc759385 SHA512 9e40cf7b3841bcf8289f24903e392df2a812b6d815f71da41d95a81bb89f493ab1afcef749ef47960ba683dc3433d2c4488015990806dde0b560ffe3bb6ca545
diff --git a/sci-mathematics/singular/singular-4.3.2_p1.ebuild b/sci-mathematics/singular/singular-4.3.2_p1.ebuild
new file mode 100644
index 000000000000..82abd43c1f8e
--- /dev/null
+++ b/sci-mathematics/singular/singular-4.3.2_p1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+MY_PN=Singular
+MY_PV=$(ver_rs 3 '')
+# Consistency is different...
+MY_DIR2=$(ver_cut 1-3 ${PV})
+MY_DIR=$(ver_rs 1- '-' ${MY_DIR2})
+
+DESCRIPTION="Computer algebra system for polynomial computations"
+HOMEPAGE="https://www.singular.uni-kl.de/ https://github.com/Singular/Singular"
+SRC_URI="https://www.singular.uni-kl.de/ftp/pub/Math/${MY_PN}/SOURCES/${MY_DIR}/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_DIR2}"
+
+LICENSE="BSD GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~x86-linux"
+IUSE="emacs examples polymake +readline static-libs"
+
+# The interactive help uses "info" from sys-apps/texinfo.
+RDEPEND="
+ dev-lang/perl
+ dev-libs/gmp:0
+ dev-libs/ntl:=
+ sci-libs/cddlib
+ sci-mathematics/flint
+ sys-apps/texinfo
+ emacs? ( >=app-editors/emacs-23.1:* )
+ polymake? ( sci-mathematics/polymake )
+ readline? ( sys-libs/readline )
+"
+DEPEND="${RDEPEND}"
+
+SITEFILE=60${PN}-gentoo.el
+
+src_configure() {
+ local myconf=(
+ --disable-debug
+ --disable-doc
+ --disable-optimizationflags
+ --disable-pyobject-module
+ --disable-python
+ --disable-python-module
+ --disable-python_module
+ --enable-factory
+ --enable-gfanlib
+ --enable-libfac
+ --with-flint
+ --with-gmp
+ --with-libparse
+ --with-ntl
+ --without-python
+ --without-pythonmodule
+ $(use_enable emacs)
+ $(use_enable polymake polymake-module)
+ $(use_enable static-libs static)
+ $(use_with readline)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ pushd "${S}"/emacs
+ elisp-compile *.el || die "elisp-compile failed"
+ popd
+ fi
+}
+
+src_install() {
+ # Do not compress singular's info file (singular.hlp)
+ # some consumer of that file do not know how to deal with compression
+ docompress -x /usr/share/info
+
+ default
+
+ dosym Singular /usr/bin/"${PN}"
+
+ # purge .la file
+ find "${ED}" -name '*.la' -delete || die
+}
+
+src_test() {
+ # SINGULAR_PROCS_DIR need to be set to "" otherwise plugins from
+ # an already installed version of singular may be used and cause segfault
+ # See https://github.com/Singular/Sources/issues/980
+ SINGULAR_PROCS_DIR="" emake check
+}
+
+pkg_postinst() {
+ einfo "Additional functionality can be enabled by installing"
+ einfo "sci-mathematics/4ti2"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}