summaryrefslogtreecommitdiff
path: root/sci-mathematics/singular
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-07 05:04:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-07 05:04:01 +0000
commit6d726a68303b41e83884990ab17576771cfbebd1 (patch)
treec1ffed1db4317568960433f42547d39715f85729 /sci-mathematics/singular
parent47526302041193977c698ae4309d87e3870b43bf (diff)
gentoo auto-resync : 07:12:2023 - 05:04:01
Diffstat (limited to 'sci-mathematics/singular')
-rw-r--r--sci-mathematics/singular/Manifest2
-rw-r--r--sci-mathematics/singular/singular-4.3.2_p10.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/sci-mathematics/singular/Manifest b/sci-mathematics/singular/Manifest
index a2e101c753bd..560d5634c1f6 100644
--- a/sci-mathematics/singular/Manifest
+++ b/sci-mathematics/singular/Manifest
@@ -1,4 +1,6 @@
AUX 60singular-gentoo.el 298 BLAKE2B 5b42e2083037e2ff2ace5597ddebfb079920e09ed91d1a359e058fc654c6778456174d6cee9242f7fcaf81bf1464f47f43604b9e4eb298f051c6a4daba4630ca SHA512 4c17a25d91c085e12f26441fcde858e61bf191bd7d9dcf63ff5b5a1dce1d63e3f7c4f78ce8afa4f2359ad4ba6eb51f3e224ae6c502b18f5f7a76738534337431
DIST singular-4.3.2p1.tar.gz 15013729 BLAKE2B 00276f2417cd9e2b71afcae66c2aeb7f9d4f434f5a90deeee56dded66e6d5e0020ab0b06b6561e41f5b196262993732ffeb9196f59315f1b6a081b0029fc99a1 SHA512 451054a0bf33b9d1c94a63f0946e1eb7b3e7b92bc025b6aa4f64e65183aeebd6354bac5f87f6e8b35cb713b30e97af5c66f92f02683144bb426f5e3a828db616
+DIST singular-4.3.2p10.tar.gz 20848377 BLAKE2B 2487eb40c70dca516eca94585c59be0ebfeb43edce87dd16a2874bbefbe502fadcfda1164922ab7738a257e59f9e6b6535b7447702d325b36f1358ed5048c7dd SHA512 9b914e8db2c4936184594200b07d37fc952a1399c3accb1ed30ec4a4b450afd3e3c174343e1169520d0d1ed6ac2e6d261fbbb731082e07b7caced4b5790f295e
EBUILD singular-4.3.2_p1.ebuild 2551 BLAKE2B 65116423b404e74eb298d63eaa7c7c738b0017c602d0888505c5eba006b79025eaf0bd8f0d40139e61d90eb0ffa2849756dee441345b877d804a642d608f92af SHA512 29cd552c1bdbc76c1b299a51c7168a818f18c3871ba1c0f9763ab6f5a91a6b072e1c6ae43392f30e2b67e43d4b15e72efc304459aabb133c613b7bfad8a80e27
+EBUILD singular-4.3.2_p10.ebuild 2488 BLAKE2B 29ba96337f7ccce8a8a548d5121182b07297f5e2ccd8d699fabb11190638d676f6f5410cccd3dae88d09400362e6b5684f776d33f1b43e4e24310d964dd70a10 SHA512 1ffc3af3cf1078392f6f6e4a0617c6df2e5319caad34924ceedb081f5c0a2a7310f5f4c97df396964a1d115987e3e92606de42c06059d52248ea9569740208c7
MISC metadata.xml 862 BLAKE2B a6e991149cb925158806177b1b4a76da2b747b3273b395c14455993a99f4cf83de141980303a068b9068983b8adf4da884b81e80546a3d2dd162f188dc759385 SHA512 9e40cf7b3841bcf8289f24903e392df2a812b6d815f71da41d95a81bb89f493ab1afcef749ef47960ba683dc3433d2c4488015990806dde0b560ffe3bb6ca545
diff --git a/sci-mathematics/singular/singular-4.3.2_p10.ebuild b/sci-mathematics/singular/singular-4.3.2_p10.ebuild
new file mode 100644
index 000000000000..996cbc4ae5e1
--- /dev/null
+++ b/sci-mathematics/singular/singular-4.3.2_p10.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+MY_PN=Singular
+MY_PV=$(ver_rs 3 '')
+# Consistency is different...
+MY_DIR2=$(ver_cut 1-3 ${PV})
+MY_DIR=$(ver_rs 1- '-' ${MY_DIR2})
+
+DESCRIPTION="Computer algebra system for polynomial computations"
+HOMEPAGE="https://www.singular.uni-kl.de/ https://github.com/Singular/Singular"
+SRC_URI="https://www.singular.uni-kl.de/ftp/pub/Math/${MY_PN}/SOURCES/${MY_DIR}/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_DIR2}"
+
+# Most files say "version 2 or version 3 of the License," which is not
+# quite GPL-2+, and is why we have listed GPL-2 below. But AFAIK there
+# are no GPL-2-only files.
+LICENSE="BSD GPL-2 GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~x86-linux"
+IUSE="emacs examples polymake +readline"
+
+# The interactive help uses "info" from sys-apps/texinfo.
+RDEPEND="
+ dev-lang/perl
+ dev-libs/gmp:0
+ dev-libs/ntl:=
+ sci-libs/cddlib
+ sci-mathematics/flint
+ sys-apps/texinfo
+ emacs? ( app-editors/emacs:* )
+ polymake? ( sci-mathematics/polymake )
+ readline? ( sys-libs/readline )
+"
+DEPEND="${RDEPEND}"
+
+SITEFILE=60${PN}-gentoo.el
+
+src_configure() {
+ local myconf=(
+ --disable-debug
+ --disable-doc
+ --disable-optimizationflags
+ --disable-pyobject-module
+ --disable-python
+ --disable-python-module
+ --disable-python_module
+ --enable-factory
+ --enable-gfanlib
+ --enable-libfac
+ --with-flint
+ --with-gmp
+ --with-libparse
+ --with-ntl
+ --without-python
+ --without-pythonmodule
+ $(use_enable emacs)
+ $(use_enable polymake polymake-module)
+ $(use_with readline)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ pushd "${S}"/emacs
+ elisp-compile *.el || die "elisp-compile failed"
+ popd
+ fi
+}
+
+src_install() {
+ # Do not compress singular's info file (singular.hlp)
+ # some consumer of that file do not know how to deal with compression
+ docompress -x /usr/share/info
+
+ default
+
+ dosym Singular /usr/bin/"${PN}"
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+src_test() {
+ # SINGULAR_PROCS_DIR need to be set to "" otherwise plugins from
+ # an already installed version of singular may be used and cause segfault
+ # See https://github.com/Singular/Sources/issues/980
+ SINGULAR_PROCS_DIR="" emake check
+}
+
+pkg_postinst() {
+ einfo "Additional functionality can be enabled by installing"
+ einfo "sci-mathematics/4ti2"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}