summaryrefslogtreecommitdiff
path: root/sci-mathematics/singular/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /sci-mathematics/singular/files
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'sci-mathematics/singular/files')
-rw-r--r--sci-mathematics/singular/files/singular-4.0.3-gfan_linking.patch13
-rw-r--r--sci-mathematics/singular/files/singular-4.1.3-doc_install.patch62
-rw-r--r--sci-mathematics/singular/files/singular-4.2.0-no-static.patch69
3 files changed, 144 insertions, 0 deletions
diff --git a/sci-mathematics/singular/files/singular-4.0.3-gfan_linking.patch b/sci-mathematics/singular/files/singular-4.0.3-gfan_linking.patch
new file mode 100644
index 000000000000..f228d980ffcf
--- /dev/null
+++ b/sci-mathematics/singular/files/singular-4.0.3-gfan_linking.patch
@@ -0,0 +1,13 @@
+diff --git a/gfanlib/Makefile.am b/gfanlib/Makefile.am
+index 2039af0..a1b7dce 100644
+--- a/gfanlib/Makefile.am
++++ b/gfanlib/Makefile.am
+@@ -20,6 +20,8 @@ libgfan_la_SOURCES = $(SOURCES)
+ libgfan_includedir =$(includedir)/gfanlib
+ libgfan_include_HEADERS = config.h gfanlib_mixedvolume.h gfanlib_polymakefile.h gfanlib_symmetry.h gfanlib_vector.h gfanlib_z.h _config.h gfanlib.h gfanlib_paralleltraverser.h gfanlib_q.h gfanlib_traversal.h gfanlib_zcone.h gfanlib_circuittableint.h gfanlib_matrix.h gfanlib_polyhedralfan.h gfanlib_symmetriccomplex.h gfanlib_tropicalhomotopy.h gfanlib_zfan.h
+
++libgfan_la_LIBADD = $(CDDGMPLDFLAGS)
++
+ DISTCLEANFILES = config.h
+
+ moduledir = $(libexecdir)/singular/MOD
diff --git a/sci-mathematics/singular/files/singular-4.1.3-doc_install.patch b/sci-mathematics/singular/files/singular-4.1.3-doc_install.patch
new file mode 100644
index 000000000000..10e831bea701
--- /dev/null
+++ b/sci-mathematics/singular/files/singular-4.1.3-doc_install.patch
@@ -0,0 +1,62 @@
+diff --git a/Makefile.am b/Makefile.am
+index c21b6ba..ea61758 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -14,10 +14,11 @@ dist-hook:
+
+ install-data-local:
+ if test -e $(srcdir)/doc/doc.tbz2; then\
+- (cat ${top_srcdir}/doc/doc.tbz2| (cd $(DESTDIR)$(datadir)/singular; tar jxf -));\
+ mkdir $(DESTDIR)$(datadir)/info;\
+- mkdir $(DESTDIR)$(datadir)/doc;\
+- mv $(DESTDIR)$(datadir)/singular/singular.hlp $(DESTDIR)$(datadir)/info/.;\
++ mkdir -p $(DESTDIR)$(docdir);\
++ (cat ${top_srcdir}/doc/doc.tbz2| (cd $(DESTDIR)$(docdir); tar -jx --no-same-owner -f -));\
++ mv $(DESTDIR)$(docdir)/singular.hlp $(DESTDIR)$(datadir)/info/.;\
++ @INSTALL_DATA@ doc/singular.idx $(DESTDIR)$(datadir)/singular/.;\
+ fi
+
+ uninstall-local:
+diff --git a/configure.ac b/configure.ac
+index 2d53a55..d43b5fe 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -248,6 +248,11 @@ AX_NORMALIZE_PATH([config_datadir],['/'])
+ AC_DEFINE_UNQUOTED([DATA_DIR],"$config_datadir",[datadir])
+ AC_SUBST(DATA_DIR, "$config_datadir")
+
++AX_RECURSIVE_EVAL([[$]docdir], [config_docdir])
++AX_NORMALIZE_PATH([config_docdir],['/'])
++AC_DEFINE_UNQUOTED([DOC_DIR],"$config_docdir",[docdir])
++AC_SUBST(DOC_DIR, "$config_docdir")
++
+ SING_SHOW_FLAGS([Compiler/linker flags: ])
+
+
+diff --git a/resources/configure.ac b/resources/configure.ac
+index cf6720f..ac5f2d0 100644
+--- a/resources/configure.ac
++++ b/resources/configure.ac
+@@ -72,5 +72,9 @@ AX_RECURSIVE_EVAL([[$]datadir], [config_datadir])
+ AX_NORMALIZE_PATH([config_datadir],['/'])
+ AC_DEFINE_UNQUOTED([DATA_DIR],"$config_datadir",[datadir])
+
++AX_RECURSIVE_EVAL([[$]htmldir], [config_htmldir])
++AX_NORMALIZE_PATH([config_htmldir],['/'])
++AC_DEFINE_UNQUOTED([HTML_DIR],"$config_datadir",[htmldir])
++
+ AC_CONFIG_FILES([singular_resources.pc Makefile])
+ AC_OUTPUT
+diff --git a/resources/feResource.cc b/resources/feResource.cc
+index 3d75bc9..7e4fc8c 100644
+--- a/resources/feResource.cc
++++ b/resources/feResource.cc
+@@ -85,7 +85,7 @@ VAR feResourceConfig_s feResourceConfigs[] =
+ {"DefaultDir",'d', feResDir, "SINGULAR_DEFAULT_DIR", SINGULAR_DEFAULT_DIR, (char *)""},
+ {"InfoFile", 'i', feResFile, "SINGULAR_INFO_FILE", "%D/info/singular.hlp", (char *)""},
+ {"IdxFile", 'x', feResFile, "SINGULAR_IDX_FILE", "%D/singular/singular.idx", (char *)""},
+- {"HtmlDir", 'h', feResDir, "SINGULAR_HTML_DIR", "%D/singular/html", (char *)""},
++ {"HtmlDir", 'h', feResDir, "SINGULAR_HTML_DIR", HTML_DIR, (char *)""},
+ {"ManualUrl", 'u', feResUrl, "SINGULAR_URL", "https://www.singular.uni-kl.de/Manual/", (char *)""},
+ {"ExDir", 'm', feResDir, "SINGULAR_EXAMPLES_DIR","%r/examples", (char *)""},
+ {"Path", 'p', feResPath, NULL, "%b;%P;$PATH", (char *)""},
diff --git a/sci-mathematics/singular/files/singular-4.2.0-no-static.patch b/sci-mathematics/singular/files/singular-4.2.0-no-static.patch
new file mode 100644
index 000000000000..5509c58bd6b6
--- /dev/null
+++ b/sci-mathematics/singular/files/singular-4.2.0-no-static.patch
@@ -0,0 +1,69 @@
+From ef9d66230f9697caaa77dbfc275650412d0d9c0d Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Mon, 22 Mar 2021 09:02:58 -0400
+Subject: [PATCH 1/1] Singular/Makefile.am: drop -static linker flags.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+There are a few hard-coded "-static" flags in the Makefile.am for
+Singular that are causing weird problems for shared builds. The
+visible symptom on Gentoo was a few insecure rpaths being stripped
+from the "Singular" executable, but François Bissey was able to track
+down the root cause, namely the "-static" that is causing libtool to
+act weird.
+
+In retrospect, this problem was also reported on Stack Overflow at,
+
+ https://stackoverflow.com/questions/17905121
+
+The Gentoo bug is,
+
+ https://bugs.gentoo.org/712004
+
+If we experience no problems with this patch, it will be sent upstream.
+---
+ Singular/Makefile.am | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/Singular/Makefile.am b/Singular/Makefile.am
+index 7fe43bffb..1e440765d 100644
+--- a/Singular/Makefile.am
++++ b/Singular/Makefile.am
+@@ -153,7 +153,7 @@ Singular_SOURCES = tesths.cc fegetopt.c fegetopt.h utils.cc utils.h
+
+ Singular_LDADD = libSingular.la ${OMALLOC_LIBS} ${BUILTIN_FLAGS}
+
+-Singular_LDFLAGS = -static ${AM_LDFLAGS} ${BUILTIN_FLAGS}
++Singular_LDFLAGS = ${AM_LDFLAGS} ${BUILTIN_FLAGS}
+
+ Singulard_SOURCES = tesths.cc fegetopt.c fegetopt.h utils.cc utils.h
+
+@@ -166,7 +166,6 @@ dist_script_SCRIPTS = singularsurf singularsurf_jupyter singularsurf_win surfex
+
+ #### ESingular
+ ESingular_CPPFLAGS = ${AM_CPPFLAGS} -DESINGULAR -DPROTO
+-# ESingular_LDFLAGS = -static ${AM_LDFLAGS}
+ ESingular_LDADD = ${top_builddir}/libpolys/reporter/libreporter.la \
+ ${top_builddir}/libpolys/misc/libmisc.la ${OMALLOC_LIBS} \
+ ${top_builddir}/resources/libsingular_resources.la
+@@ -176,7 +175,6 @@ ESingular_SOURCES = emacs.cc fegetopt.c fegetopt.h feOptES.inc feOpt.cc
+
+ #### same for TSingular
+ TSingular_CPPFLAGS = ${AM_CPPFLAGS} -DTSINGULAR -DPROTO
+-# TSingular_LDFLAGS = -static ${AM_LDFLAGS}
+ TSingular_LDADD = ${top_builddir}/libpolys/reporter/libreporter.la \
+ ${top_builddir}/libpolys/misc/libmisc.la ${OMALLOC_LIBS} \
+ ${top_builddir}/resources/libsingular_resources.la
+@@ -191,7 +189,7 @@ libparse_CPPFLAGS = ${AM_CPPFLAGS} -DSTANDALONE_PARSER
+ libparse_SOURCES = libparse.cc fegetopt.c fegetopt.h utils.cc utils.h
+
+ libparse_LDADD =
+-libparse_LDFLAGS = -static ${AM_LDFLAGS}
++libparse_LDFLAGS = ${AM_LDFLAGS}
+
+ #########################################################
+ # the Singular library (*.lib files)
+--
+2.26.2
+