summaryrefslogtreecommitdiff
path: root/sci-mathematics/rw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /sci-mathematics/rw
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'sci-mathematics/rw')
-rw-r--r--sci-mathematics/rw/Manifest1
-rw-r--r--sci-mathematics/rw/rw-0.8-r3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/rw/Manifest b/sci-mathematics/rw/Manifest
index 86b3e0904e57..37073adb4728 100644
--- a/sci-mathematics/rw/Manifest
+++ b/sci-mathematics/rw/Manifest
@@ -1,3 +1,4 @@
DIST rw-0.8.tar.gz 217215 BLAKE2B e6f379ce7cde0fafb0c6e234e8958018c0682ad47e60da3755a891b7eee4c910e84556252a333a12fe0cf2eac88863a272cb8fa6d2cfa4c9f1e93bd88bc6a2d2 SHA512 609d46fd3c76e2eb1724cc3e3ff9354d13b3c15ce23b96bef9f73f02b490e1d8713146230db079fcc87f45f5acc0e04130dac04e27589836e20891c63219f3ec
EBUILD rw-0.8-r2.ebuild 995 BLAKE2B f9b78b421a24cedc9a347f63b22e5b33d8cf115121724705207fae590c303d1956b2001f91e3735332b748ef189fafeb42d04f6844a66881790152babc76cfb5 SHA512 2fd5999820443b7d755814af961b1e1c862749180ffc6c3815be15cdc3790c036a2de5c4e4a02d5bf316c7cb1e0b6b024c86484a0a6022b831ba91ba73554660
+EBUILD rw-0.8-r3.ebuild 1125 BLAKE2B aa92fd85cde10922d0979d0503d0a4ff4e51372f15e5a5a17299d96938fdc010c5206302dbbacf5662b1536c1c8b990dae0512e00daef1eb4897d762d5d2f394 SHA512 20c39b004d9d25ebc34a35a9907f3173e554923a78eaaee3da2be0c8a991aa6099f758fb465731b43c35abd18296e2c05d974d1680c2735c5f43b29cbb08e9bb
MISC metadata.xml 1128 BLAKE2B 30c263e8a47107c0c5d9a7ee5377a5deaa6260767734361b85eca07f5c1a88d8f2375f2c5d20a28cd1241fcf70a2dfcff16a7fc2886977dfd9f25b5388aa73bb SHA512 34ec83d5cf7d7ed12ef6c58291a6a1b8323d580121e8b489dadc569f09b184e6952cefd934da504542a7a4cbe5c59a781ff703dec21c7ee4010f31153144328c
diff --git a/sci-mathematics/rw/rw-0.8-r3.ebuild b/sci-mathematics/rw/rw-0.8-r3.ebuild
new file mode 100644
index 000000000000..6bbd3085010b
--- /dev/null
+++ b/sci-mathematics/rw/rw-0.8-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Compute rank-width decompositions of graphs"
+HOMEPAGE="https://sourceforge.net/projects/rankwidth/"
+SRC_URI="https://downloads.sourceforge.net/project/rankwidth/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+# We have a file collision (librw.so) with xpaint, bug 560210.
+RDEPEND="!media-gfx/xpaint"
+
+src_prepare() {
+ # The upstream tarball for v0.8 contains SYMLINKS to ar-lib,
+ # compile, install-sh, ltmain.sh, etc. And those symlinks don't
+ # always point to a working location for us, so we have to
+ # (re)generate actual files for that stuff. Bug 696986.
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # The executable depends on igraph, which has gone off the rails
+ # upstream and has copy/pasted ~10 libraries into its src/ directory.
+ econf --disable-executable --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete \
+ || die 'failed to delete libtool archives'
+}