summaryrefslogtreecommitdiff
path: root/sci-mathematics/rw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-mathematics/rw
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-mathematics/rw')
-rw-r--r--sci-mathematics/rw/Manifest2
-rw-r--r--sci-mathematics/rw/rw-0.9.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/rw/Manifest b/sci-mathematics/rw/Manifest
index 4527deb5a5db..32765389f26c 100644
--- a/sci-mathematics/rw/Manifest
+++ b/sci-mathematics/rw/Manifest
@@ -1,3 +1,5 @@
DIST rw-0.8.tar.gz 217215 BLAKE2B e6f379ce7cde0fafb0c6e234e8958018c0682ad47e60da3755a891b7eee4c910e84556252a333a12fe0cf2eac88863a272cb8fa6d2cfa4c9f1e93bd88bc6a2d2 SHA512 609d46fd3c76e2eb1724cc3e3ff9354d13b3c15ce23b96bef9f73f02b490e1d8713146230db079fcc87f45f5acc0e04130dac04e27589836e20891c63219f3ec
+DIST rw-0.9.tar.gz 340385 BLAKE2B 2eba540146094eea7adb26874ed6f7982e46a863c786bf6f4a55af2d1d3167641e10c324f2b0e0e366bb8f83503b5da5fb02447abf46ae955da78ac8fe6149b6 SHA512 f4f1910506cbdb557ca50bac6f63cfca3271a5df8d13c67d2d9bba79b9cdb03196a679e6091554175decbee0871888de71bed5746662c9a75418f0f5dd9bd609
EBUILD rw-0.8-r3.ebuild 1112 BLAKE2B 620c546ad9687c361b5092e7e27604332d7b9a119ac29b1ecab7fa2a295cb400ffebb174983e3466522cf2911e2998dbb76ef4619d165a66a643ab3274e76042 SHA512 b9f2e9d3a04ef177f00ec01c061ba8e2177483392ab81eada207f01efc11dec9aa8fcf2c1e599ebc768aa8638e32d1a1f4795f395188484089d875771ea87cfd
+EBUILD rw-0.9.ebuild 810 BLAKE2B 46a02e8c61f514e12f7199b4f9f6e39d66533ad416423edbd1c4b65fe9989f12230b5204865f27825015d700a975ca3394dd7b9795f13060bc5fbf6f4609cfab SHA512 c98ca1e619f5a79423647ed03f8deaeab64f49744a52136ecc1af666a33ab415a6c7a8162157066cc6c47ed9565ed8fb8b52005ec1660b6de3d77bf7a546ff56
MISC metadata.xml 1128 BLAKE2B 30c263e8a47107c0c5d9a7ee5377a5deaa6260767734361b85eca07f5c1a88d8f2375f2c5d20a28cd1241fcf70a2dfcff16a7fc2886977dfd9f25b5388aa73bb SHA512 34ec83d5cf7d7ed12ef6c58291a6a1b8323d580121e8b489dadc569f09b184e6952cefd934da504542a7a4cbe5c59a781ff703dec21c7ee4010f31153144328c
diff --git a/sci-mathematics/rw/rw-0.9.ebuild b/sci-mathematics/rw/rw-0.9.ebuild
new file mode 100644
index 000000000000..17031e1789f4
--- /dev/null
+++ b/sci-mathematics/rw/rw-0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Compute rank-width decompositions of graphs"
+HOMEPAGE="https://sourceforge.net/projects/rankwidth/"
+SRC_URI="https://downloads.sourceforge.net/project/rankwidth/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+# We have a file collision (librw.so) with xpaint, bug 560210.
+RDEPEND="!media-gfx/xpaint"
+
+src_configure() {
+ # The executable depends on igraph, which has gone off the rails
+ # upstream and has copy/pasted ~10 libraries into its src/ directory.
+ econf --disable-executable --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete \
+ || die 'failed to delete libtool archives'
+}