summaryrefslogtreecommitdiff
path: root/sci-mathematics/rngstreams
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sci-mathematics/rngstreams
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sci-mathematics/rngstreams')
-rw-r--r--sci-mathematics/rngstreams/Manifest2
-rw-r--r--sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild32
2 files changed, 23 insertions, 11 deletions
diff --git a/sci-mathematics/rngstreams/Manifest b/sci-mathematics/rngstreams/Manifest
index 6788a76b4b44..5b28e72116f0 100644
--- a/sci-mathematics/rngstreams/Manifest
+++ b/sci-mathematics/rngstreams/Manifest
@@ -1,3 +1,3 @@
DIST rngstreams-1.0.1.tar.gz 502458 BLAKE2B 119f4bc9ceb34487176c2ad02b6be16b50c6300c0512b05fb2376d02ddd59f17d62fa9e3e190093534614a90daace84701c628962284228be787950a534ec24e SHA512 665c27e72a4e1bdc59864f340208d42fc899c1c9429aafe1c7c3f8778dee0bb87ec9da26976a925197e07931bc1c2864dde0cb3fc08996155f775b7e44f9d7f4
-EBUILD rngstreams-1.0.1.ebuild 586 BLAKE2B 17fd08ac0d033c247d616c6489a68fbe6886cff0cfed2ebc48971023dc4553ce4ae447520e9d45507b9c5689ebadbe97ac495135c0893535937d13056b4eab3f SHA512 e60cf7643db00587579f89bd9694231d4840ca4c2f00c52c30617f28dbcee21b341540dfac938130d687fef6c2e4726061989646c59d2b2a675f475f329395a1
+EBUILD rngstreams-1.0.1.ebuild 794 BLAKE2B 0c2c031df94a8216536196d5a1f1b7b176859782818cbf3633faa3f7cfd5d8ab04a5f68283f3c7267f0bab046f667652eb03c2611c19d7451716fec1f850bae8 SHA512 b99c3a9b98c80f949d848debfdfd42c0f892bcc9a0997b18b0901ef7cffee929f0996c5b0c96fee71688678283b9b7493536766ffce90e67a4fd82e1aff0d3a6
MISC metadata.xml 601 BLAKE2B 5ab0eb6e81c32b128237ba780e3b8170557ca55b170abe6bace9d7f6ea7ad9dd7df0f23e4ad45ac84a2ca899c5e62f1b6c0b89ed171667ddc0938e9b3e4a1825 SHA512 866f6fa26bcdf67b429ea2268f6f7b7101f04ff2666603984b9bdb0551a794925877eee42846826edd2045502c7111cb85e9dc9abde149572d9aac14b6df13d6
diff --git a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
index 2ea39b2a42f1..cf74c8bf763f 100644
--- a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
+++ b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
@@ -1,24 +1,36 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools-utils
+inherit out-of-source
DESCRIPTION="Multiple independent streams of pseudo-random numbers"
HOMEPAGE="http://statmath.wu.ac.at/software/RngStreams/"
-SRC_URI="${HOMEPAGE}${P}.tar.gz"
+SRC_URI="http://statmath.wu.ac.at/software/RngStreams/${P}.tar.gz"
LICENSE="GPL-3"
-SLOT=0
+SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
+
+my_src_configure() {
+ econf --enable-shared --disable-static
+}
+
+my_src_install_all() {
+ if use doc; then
+ HTML_DOCS=( doc/rngstreams.html/. )
+ dodoc doc/${PN}.pdf
+ fi
+ einstalldocs
-src_install() {
- autotools-utils_src_install
- use doc && dohtml -r doc/rngstreams.html/* && dodoc doc/${PN}.pdf
if use examples; then
- rm examples/Makefile*
+ rm examples/Makefile* || die
dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}