summaryrefslogtreecommitdiff
path: root/sci-mathematics/rkward/rkward-0.7.0b.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /sci-mathematics/rkward/rkward-0.7.0b.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'sci-mathematics/rkward/rkward-0.7.0b.ebuild')
-rw-r--r--sci-mathematics/rkward/rkward-0.7.0b.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/rkward/rkward-0.7.0b.ebuild b/sci-mathematics/rkward/rkward-0.7.0b.ebuild
new file mode 100644
index 000000000000..4c651729fa1d
--- /dev/null
+++ b/sci-mathematics/rkward/rkward-0.7.0b.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="IDE for the R-project"
+HOMEPAGE="https://rkward.kde.org/"
+SRC_URI="mirror://kde/stable/${PN}/${PV/b}/src/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+BDEPEND="
+ sys-devel/gettext
+"
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdewebkit)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript)
+ >=dev-qt/qtwebkit-5.212.0_pre20180120:5
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-lang/R
+"
+RDEPEND="${DEPEND}
+ virtual/libintl
+ !sci-mathematics/rkward:4
+"