summaryrefslogtreecommitdiff
path: root/sci-mathematics/psmt2-frontend
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /sci-mathematics/psmt2-frontend
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'sci-mathematics/psmt2-frontend')
-rw-r--r--sci-mathematics/psmt2-frontend/Manifest4
-rw-r--r--sci-mathematics/psmt2-frontend/files/psmt2-frontend-0.2-gentoo.patch22
-rw-r--r--sci-mathematics/psmt2-frontend/metadata.xml12
-rw-r--r--sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild25
4 files changed, 63 insertions, 0 deletions
diff --git a/sci-mathematics/psmt2-frontend/Manifest b/sci-mathematics/psmt2-frontend/Manifest
new file mode 100644
index 000000000000..0c4582c4a099
--- /dev/null
+++ b/sci-mathematics/psmt2-frontend/Manifest
@@ -0,0 +1,4 @@
+AUX psmt2-frontend-0.2-gentoo.patch 607 BLAKE2B 4d3a967d9c694e74b1e33426d73f41e97be37510241291339e4d7c4e677ef247cc9dd28728df4fcdb6a0819aa8d1ccb6233d65cb206cbf78dcf9004af7744a7b SHA512 6ec9c1c89ceb023b57820f083722b4c4a693a27c38fcc63a9bf6403853c716a398f055a8db579e683a03f2ca8ccfcd9235796ce1f44867d47805279f6a0a8700
+DIST psmt2-frontend-0.2.tar.gz 26976 BLAKE2B 2b45ceb8d824f5b11455ad0026064b6329b6c6e6173c091b36dc42e8c1dd36924d12d9296db3dcfe748a84fdc37a1a530f3ef485bec904c19a0e6aa8034149f9 SHA512 c29802f4265a1cbdb05ee9154ce2c156136af258bc7283dd0fb1d1b2ce162b671553cab96484036d898e3ff7c26ab133f5c2e1ca88e9e48660b2faa139fd1f41
+EBUILD psmt2-frontend-0.2.ebuild 583 BLAKE2B 2fe5e7f7340ed763b2ef98042ac9b7365fb951bb031abe8758f4134a36469473b1d179650f21e79cf6c87f1d263f992cf188f278f605fcd04eac3d6daab12944 SHA512 38ab7dc0d8b7ce581363617f5a9eee3ba9b8f2e1d103909a17359bb194ba87882e222969b70df92ee85fe4b5ebd2266c1c33ef9be2866b9fa4eddf0961002dfd
+MISC metadata.xml 413 BLAKE2B 0f866e4371235aae4d041e7bd1ad4011e680ab501c764559d9d52fae48a2ace5825230a0b2fa8c411e9ae0d55d474fe63250de1bb9983acf328d6a4c2412802c SHA512 1a6fa4ac4c2615a491861c78d8fa5680c4de8fef1caa034601a8ffd75e0c714109d45af96c16348dc27bb3848863c18a28720a2e960219237eea4d3154cb17f3
diff --git a/sci-mathematics/psmt2-frontend/files/psmt2-frontend-0.2-gentoo.patch b/sci-mathematics/psmt2-frontend/files/psmt2-frontend-0.2-gentoo.patch
new file mode 100644
index 000000000000..74fbed08bf6b
--- /dev/null
+++ b/sci-mathematics/psmt2-frontend/files/psmt2-frontend-0.2-gentoo.patch
@@ -0,0 +1,22 @@
+--- a/Makefile.in 2019-07-20 19:20:06.818740706 +0200
++++ b/Makefile.in 2019-07-20 19:21:33.437581073 +0200
+@@ -18,7 +18,7 @@
+ libdir=@libdir@
+ # exec_prefix=@exec_prefix@
+ # BINDIR=$(DESTDIR)@bindir@
+-LIBDIR=$(prefix)$(libdir)
++LIBDIR=$(libdir)
+ # DATADIR=$(DESTDIR)@datadir@/psmt2-frontend
+
+ # where to install the man page
+@@ -119,8 +119,8 @@
+ ##############
+
+ install: all META
+- mkdir -p $(DESTDIR)$(LIBDIR)
+- OCAMLFIND_DESTDIR=$(DESTDIR)$(LIBDIR) \
++ mkdir -p $(DESTDIR)$(OCAMLLIB)
++ OCAMLFIND_DESTDIR=$(DESTDIR)$(OCAMLLIB) \
+ ocamlfind install psmt2-frontend src/$(LIBNAME).* src/*.mli META
+
+
diff --git a/sci-mathematics/psmt2-frontend/metadata.xml b/sci-mathematics/psmt2-frontend/metadata.xml
new file mode 100644
index 000000000000..53441a5497e7
--- /dev/null
+++ b/sci-mathematics/psmt2-frontend/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ A library to parse and type-check a conservative extension of the
+ SMT-LIB 2 standard with prenex polymorphism.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild b/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild
new file mode 100644
index 000000000000..4e0ada140fe7
--- /dev/null
+++ b/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit findlib autotools
+
+DESCRIPTION="Library to parse and type-check an extension of the SMT-LIB 2 standard"
+HOMEPAGE="https://github.com/OCamlPro-Coquera/psmt2-frontend"
+SRC_URI="https://github.com/OCamlPro-Coquera/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-ml/menhir-20181006"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}