summaryrefslogtreecommitdiff
path: root/sci-mathematics/primesieve
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
commitb46782805d0eed36ce9685f7e9abf25671f24d7d (patch)
tree4b7992f7355b710c35a7c4bfff9b57eb64e4c8b5 /sci-mathematics/primesieve
parentd4d7098dcb2f9dd257109bbcb55fd40beda1b78d (diff)
gentoo auto-resync : 21:12:2022 - 01:52:55
Diffstat (limited to 'sci-mathematics/primesieve')
-rw-r--r--sci-mathematics/primesieve/Manifest2
-rw-r--r--sci-mathematics/primesieve/primesieve-11.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
index 6805e3fc3b50..b223a9fed609 100644
--- a/sci-mathematics/primesieve/Manifest
+++ b/sci-mathematics/primesieve/Manifest
@@ -1,3 +1,5 @@
+DIST primesieve-11.0.tar.gz 125086 BLAKE2B ac425b6435bc95efbfc3d7458b59719af390508db811e0a993a606397166771cfcb9c0269249341fb6f678aafa8bae4a89e7a914176f61a608e6ccdfd0cab22b SHA512 1be9ff9d07068cab1ca69315010238ab15e5ba3b674bd45e9a0e11d20418810ece05a8df3853796118193468ac2ac6e24391f82d6db9581658ce59ddabb5b7fc
DIST primesieve-8.0.tar.gz 119635 BLAKE2B e769cfe35752e809cf1611b3a9034bc79d16311c73d5065880cbec9c8179a2149ee9a3a6e277466691c44adf07781e1c7f9aa53f140714c4c9d408b24df17848 SHA512 213785c89868f224091fe76a74b98a896c374a7a96e2bdb44b07f4c6288bd50e22d9a563382fb512e71a1ad366d8b94e74fcc8b5f58bb94c85b4d435fbb6a571
+EBUILD primesieve-11.0.ebuild 1038 BLAKE2B f55a8f7a3f6bd3fb77be1043b3ef2c646d9ee3af362ba680dd464c09af828efc8ca9558edaf119853a7d40466b9c6d412e28ea88f51f0f666bb0c6597f764f39 SHA512 0ec2f17b790c6cfa07d422ed10f0a52b786d49cdfa1ea89e8e54b68aec02025d84f864b2137da2d5a02fea490904d8ce7787121cfd2f3b4dccd44fdf5b250bdb
EBUILD primesieve-8.0.ebuild 1037 BLAKE2B d562e362f0053b2b1e87a947d238f2e47c0e53254cac2ac9e8be0cebfb4707c76be66388b62af55ae2a56ab23c9f58051c692a64f306178accb5176c386233b7 SHA512 269e6cc602f2f72187319b0523383abe8cba15fb26a8d56432489b21e6b03cbaf340573a5cfeffc4faa2287f3729991491e86e7433e38ab94c7dc08e05df97cd
MISC metadata.xml 672 BLAKE2B e580c88061b6dcece5a34fde2cd13ce8c55264f3bac16fe3af6374df92d6280993452ebeea3d8446d9f8afcf7c1cb6927405c40e82a1c01a153d5060c77392fd SHA512 8ad3dd50c172ad3333d30a01b0e7ddb8f0f96b7666b61a0c6a1644e92abc49fa75f4f54c4c88eb72c2c8c7104d5e720d852bc7319fbc1a9569fcc5de85529b02
diff --git a/sci-mathematics/primesieve/primesieve-11.0.ebuild b/sci-mathematics/primesieve/primesieve-11.0.ebuild
new file mode 100644
index 000000000000..44fb41efb869
--- /dev/null
+++ b/sci-mathematics/primesieve/primesieve-11.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="CLI and library for quickly generating prime numbers"
+HOMEPAGE="https://github.com/kimwalisch/primesieve"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/11" # subslot is first component of libprimesieve.so version
+KEYWORDS="~amd64"
+IUSE="doc +executable test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen app-text/texlive media-gfx/graphviz )"
+DEPEND=""
+RDEPEND=""
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/ALGORITHMS.md
+ doc/CPP_API.md
+ doc/C_API.md
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOC="$(usex doc)"
+ -DBUILD_PRIMESIEVE="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ if use doc; then
+ DOCS+=(
+ "${BUILD_DIR}/doc/html"
+ "${BUILD_DIR}/doc/latex/refman.pdf"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_build doc
+}