summaryrefslogtreecommitdiff
path: root/sci-mathematics/primesieve
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 20:10:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 20:10:31 +0100
commit944b3df0f275eea0fd7808913d72a0b280df0c33 (patch)
treeec33697fafd5ce7028b7619baef7a6d27bb74362 /sci-mathematics/primesieve
parent7e17b5aabc330abb894f2b90bef0e3fcbcd180d2 (diff)
gentoo auto-resync : 06:08:2022 - 20:10:30
Diffstat (limited to 'sci-mathematics/primesieve')
-rw-r--r--sci-mathematics/primesieve/Manifest4
-rw-r--r--sci-mathematics/primesieve/primesieve-7.7.ebuild50
-rw-r--r--sci-mathematics/primesieve/primesieve-7.9.ebuild2
3 files changed, 2 insertions, 54 deletions
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
index ace9355fbf0b..064b4b8a3e3a 100644
--- a/sci-mathematics/primesieve/Manifest
+++ b/sci-mathematics/primesieve/Manifest
@@ -1,5 +1,3 @@
-DIST primesieve-7.7.tar.gz 101558 BLAKE2B cfaa91ddcf661e265d403f8a93461fe297ac48db843b096d0dd7828c4e3d11cdba60cb102197248359c79950fe2ac66c8e9295ab17b0d6bd0eed5a6260c7d115 SHA512 bbcc141a12afdf54386d2408e067b1c6af2dd9b5c9f44d71290269ddefc7c46ba6794064cde6728c8356724553cb6bc2e765bf18c24a18b6d5d1f472d2c6e6dd
DIST primesieve-7.9.tar.gz 111361 BLAKE2B 8e227bd04a89dd5e8ea5dc5e79afa1c5254216863086fd6c3712fb45767ee7e5e23e72d166ada17295e56479e0c0e1ae7f215b72e124e5234a79fb20f340cb3f SHA512 fcfc3445e5becd555b66743f6d73dd4a0cbb48b1d4a3d0d22043261f1861e0631bdeb8702b1f942110f8b327a01173b231accd1f7595600308709832bbbafc06
-EBUILD primesieve-7.7.ebuild 1046 BLAKE2B 503fcab0c41dd30a22ad076b8e6404d24ca37a4c765a8059ffdbc91a48bfb87ff646779327a447b5cfbd96e1f5a9d88d50fda2ee0a1bf82ad4e12516d699f460 SHA512 e6038d77db1f87bc5c413a6e2c1a7ba689ec9920a579befcced2575379b808c0a60262b8ce2d130936e3d8a04df8d0fa6ee66ca2c74ea65f02fb53de37d704f3
-EBUILD primesieve-7.9.ebuild 1047 BLAKE2B 314c50fba490ce902b2fb4471068fb78db55ee04195565e40cf11452bd41332a908553965cb1ccebeed9fcee56b33d93060482f37cd106117b2315c2d61dc7f1 SHA512 0aa1eed9f2376c0f2e35744b983f7638e95ee9dc74ea92aa783c780cb30923c0f97330cb9ac90b92a29415e0a9ff9ee661ff05a8998a2144671df5256bbc52aa
+EBUILD primesieve-7.9.ebuild 1046 BLAKE2B 503fcab0c41dd30a22ad076b8e6404d24ca37a4c765a8059ffdbc91a48bfb87ff646779327a447b5cfbd96e1f5a9d88d50fda2ee0a1bf82ad4e12516d699f460 SHA512 e6038d77db1f87bc5c413a6e2c1a7ba689ec9920a579befcced2575379b808c0a60262b8ce2d130936e3d8a04df8d0fa6ee66ca2c74ea65f02fb53de37d704f3
MISC metadata.xml 672 BLAKE2B e580c88061b6dcece5a34fde2cd13ce8c55264f3bac16fe3af6374df92d6280993452ebeea3d8446d9f8afcf7c1cb6927405c40e82a1c01a153d5060c77392fd SHA512 8ad3dd50c172ad3333d30a01b0e7ddb8f0f96b7666b61a0c6a1644e92abc49fa75f4f54c4c88eb72c2c8c7104d5e720d852bc7319fbc1a9569fcc5de85529b02
diff --git a/sci-mathematics/primesieve/primesieve-7.7.ebuild b/sci-mathematics/primesieve/primesieve-7.7.ebuild
deleted file mode 100644
index 65d0b3d3e93a..000000000000
--- a/sci-mathematics/primesieve/primesieve-7.7.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="CLI and library for quickly generating prime numbers"
-HOMEPAGE="https://github.com/kimwalisch/primesieve"
-SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-SLOT="0/9" # subslot is first component of libprimesieve.so version
-KEYWORDS="amd64"
-IUSE="doc +executable test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="doc? ( app-doc/doxygen app-text/texlive media-gfx/graphviz )"
-DEPEND=""
-RDEPEND=""
-
-DOCS=(
- ChangeLog
- README.md
- doc/ALGORITHMS.md
- doc/CPP_Examples.md
- doc/C_Examples.md
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOC="$(usex doc)"
- -DBUILD_PRIMESIEVE="$(usex executable)"
- -DBUILD_STATIC_LIBS="OFF"
- -DBUILD_TESTS="$(usex test)"
- )
-
- if use doc; then
- DOCS+=(
- "${BUILD_DIR}/doc/html"
- "${BUILD_DIR}/doc/latex/refman.pdf"
- )
- fi
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use doc && cmake_build doc
-}
diff --git a/sci-mathematics/primesieve/primesieve-7.9.ebuild b/sci-mathematics/primesieve/primesieve-7.9.ebuild
index 7502f3600271..65d0b3d3e93a 100644
--- a/sci-mathematics/primesieve/primesieve-7.9.ebuild
+++ b/sci-mathematics/primesieve/primesieve-7.9.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://github.com/kimwalisch/primesieve"
SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0/9" # subslot is first component of libprimesieve.so version
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="doc +executable test"
RESTRICT="!test? ( test )"