summaryrefslogtreecommitdiff
path: root/sci-mathematics/primesieve
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-21 02:01:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-21 02:01:39 +0100
commit3518f21ee7106f4268edf4404299dda157795e3c (patch)
tree66e26d8d7c87fe200d97584ffb8550404e22d665 /sci-mathematics/primesieve
parentf48011012cdabc60f67e96296bc600f2c3f20ce8 (diff)
gentoo auto-resync : 21:10:2022 - 02:01:39
Diffstat (limited to 'sci-mathematics/primesieve')
-rw-r--r--sci-mathematics/primesieve/Manifest4
-rw-r--r--sci-mathematics/primesieve/primesieve-7.9.ebuild50
-rw-r--r--sci-mathematics/primesieve/primesieve-8.0.ebuild2
3 files changed, 2 insertions, 54 deletions
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
index c054bd9f431e..6805e3fc3b50 100644
--- a/sci-mathematics/primesieve/Manifest
+++ b/sci-mathematics/primesieve/Manifest
@@ -1,5 +1,3 @@
-DIST primesieve-7.9.tar.gz 111361 BLAKE2B 8e227bd04a89dd5e8ea5dc5e79afa1c5254216863086fd6c3712fb45767ee7e5e23e72d166ada17295e56479e0c0e1ae7f215b72e124e5234a79fb20f340cb3f SHA512 fcfc3445e5becd555b66743f6d73dd4a0cbb48b1d4a3d0d22043261f1861e0631bdeb8702b1f942110f8b327a01173b231accd1f7595600308709832bbbafc06
DIST primesieve-8.0.tar.gz 119635 BLAKE2B e769cfe35752e809cf1611b3a9034bc79d16311c73d5065880cbec9c8179a2149ee9a3a6e277466691c44adf07781e1c7f9aa53f140714c4c9d408b24df17848 SHA512 213785c89868f224091fe76a74b98a896c374a7a96e2bdb44b07f4c6288bd50e22d9a563382fb512e71a1ad366d8b94e74fcc8b5f58bb94c85b4d435fbb6a571
-EBUILD primesieve-7.9.ebuild 1046 BLAKE2B 503fcab0c41dd30a22ad076b8e6404d24ca37a4c765a8059ffdbc91a48bfb87ff646779327a447b5cfbd96e1f5a9d88d50fda2ee0a1bf82ad4e12516d699f460 SHA512 e6038d77db1f87bc5c413a6e2c1a7ba689ec9920a579befcced2575379b808c0a60262b8ce2d130936e3d8a04df8d0fa6ee66ca2c74ea65f02fb53de37d704f3
-EBUILD primesieve-8.0.ebuild 1038 BLAKE2B cf69bac79d45fb78796f45e58b11b93aced2344b747127c00bf1074979c013008e1da9f825611be18f989d0632746ab8e43d5e5ad37c5dd211345aa3f9171762 SHA512 59c900367e37bd08c2e0de5a89a660861539f0e28082254fff61cd0f045b6d742c2b834f847694adb4cb99790cf703fa30e4afcd21c9edfd23e7a23307adb032
+EBUILD primesieve-8.0.ebuild 1037 BLAKE2B d562e362f0053b2b1e87a947d238f2e47c0e53254cac2ac9e8be0cebfb4707c76be66388b62af55ae2a56ab23c9f58051c692a64f306178accb5176c386233b7 SHA512 269e6cc602f2f72187319b0523383abe8cba15fb26a8d56432489b21e6b03cbaf340573a5cfeffc4faa2287f3729991491e86e7433e38ab94c7dc08e05df97cd
MISC metadata.xml 672 BLAKE2B e580c88061b6dcece5a34fde2cd13ce8c55264f3bac16fe3af6374df92d6280993452ebeea3d8446d9f8afcf7c1cb6927405c40e82a1c01a153d5060c77392fd SHA512 8ad3dd50c172ad3333d30a01b0e7ddb8f0f96b7666b61a0c6a1644e92abc49fa75f4f54c4c88eb72c2c8c7104d5e720d852bc7319fbc1a9569fcc5de85529b02
diff --git a/sci-mathematics/primesieve/primesieve-7.9.ebuild b/sci-mathematics/primesieve/primesieve-7.9.ebuild
deleted file mode 100644
index 65d0b3d3e93a..000000000000
--- a/sci-mathematics/primesieve/primesieve-7.9.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="CLI and library for quickly generating prime numbers"
-HOMEPAGE="https://github.com/kimwalisch/primesieve"
-SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-SLOT="0/9" # subslot is first component of libprimesieve.so version
-KEYWORDS="amd64"
-IUSE="doc +executable test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="doc? ( app-doc/doxygen app-text/texlive media-gfx/graphviz )"
-DEPEND=""
-RDEPEND=""
-
-DOCS=(
- ChangeLog
- README.md
- doc/ALGORITHMS.md
- doc/CPP_Examples.md
- doc/C_Examples.md
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOC="$(usex doc)"
- -DBUILD_PRIMESIEVE="$(usex executable)"
- -DBUILD_STATIC_LIBS="OFF"
- -DBUILD_TESTS="$(usex test)"
- )
-
- if use doc; then
- DOCS+=(
- "${BUILD_DIR}/doc/html"
- "${BUILD_DIR}/doc/latex/refman.pdf"
- )
- fi
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use doc && cmake_build doc
-}
diff --git a/sci-mathematics/primesieve/primesieve-8.0.ebuild b/sci-mathematics/primesieve/primesieve-8.0.ebuild
index 9a6ef5573027..70bfdd3e99f2 100644
--- a/sci-mathematics/primesieve/primesieve-8.0.ebuild
+++ b/sci-mathematics/primesieve/primesieve-8.0.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://github.com/kimwalisch/primesieve"
SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0/10" # subslot is first component of libprimesieve.so version
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="doc +executable test"
RESTRICT="!test? ( test )"