summaryrefslogtreecommitdiff
path: root/sci-mathematics/primesieve
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /sci-mathematics/primesieve
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'sci-mathematics/primesieve')
-rw-r--r--sci-mathematics/primesieve/Manifest3
-rw-r--r--sci-mathematics/primesieve/metadata.xml24
-rw-r--r--sci-mathematics/primesieve/primesieve-7.7.ebuild50
3 files changed, 77 insertions, 0 deletions
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
new file mode 100644
index 000000000000..dd47d10bcb26
--- /dev/null
+++ b/sci-mathematics/primesieve/Manifest
@@ -0,0 +1,3 @@
+DIST primesieve-7.7.tar.gz 101558 BLAKE2B cfaa91ddcf661e265d403f8a93461fe297ac48db843b096d0dd7828c4e3d11cdba60cb102197248359c79950fe2ac66c8e9295ab17b0d6bd0eed5a6260c7d115 SHA512 bbcc141a12afdf54386d2408e067b1c6af2dd9b5c9f44d71290269ddefc7c46ba6794064cde6728c8356724553cb6bc2e765bf18c24a18b6d5d1f472d2c6e6dd
+EBUILD primesieve-7.7.ebuild 1048 BLAKE2B bf12c35f6e722cb0f7dec8d3a141135668cbd460f59d9048dbd142b046ba85a0bb0d3bebd6f7063131bd299904da74285aa17839c4a9965e91efd56fab1abeb7 SHA512 71964a60f46c34240acbf715c5a023118d0a5fb79d5c47423ec60724d6d229c3c68d5b44306a24eb31f31f9a42d05b3a60c4e77856be49d27d62ac579b16eacc
+MISC metadata.xml 671 BLAKE2B 66f6291e855c6ae971e436b1499e66295c5dd8ed8ae2f82f2383c7379abba2e1a42697bef34acb264b7ee962df6fd71f5d3231ae59deb7c48dd73cd5842a6ccd SHA512 0bc2a3ef693ee89e59046541754f7fb08be9c96fe94b5679254e43d9f89391c0a65271eb82c5c9163a6b80843f7477d56ab4911bafe57ec8c61179f9dde59277
diff --git a/sci-mathematics/primesieve/metadata.xml b/sci-mathematics/primesieve/metadata.xml
new file mode 100644
index 000000000000..e2285b80a8b4
--- /dev/null
+++ b/sci-mathematics/primesieve/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <use>
+ <flag name="executable">Build the primesieve CLI executable</flag>
+ </use>
+
+ <upstream>
+ <remote-id type="github">kimwalisch/primesieve</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/primesieve/primesieve-7.7.ebuild b/sci-mathematics/primesieve/primesieve-7.7.ebuild
new file mode 100644
index 000000000000..5d26f8b6a858
--- /dev/null
+++ b/sci-mathematics/primesieve/primesieve-7.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="CLI and library for quickly generating prime numbers."
+HOMEPAGE="https://github.com/kimwalisch/primesieve"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/9" # subslot is first component of libprimesieve.so version
+KEYWORDS="~amd64"
+IUSE="doc +executable test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen app-text/texlive media-gfx/graphviz )"
+DEPEND=""
+RDEPEND=""
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/ALGORITHMS.md
+ doc/CPP_Examples.md
+ doc/C_Examples.md
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOC="$(usex doc)"
+ -DBUILD_PRIMESIEVE="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ if use doc; then
+ DOCS+=(
+ "${BUILD_DIR}/doc/html"
+ "${BUILD_DIR}/doc/latex/refman.pdf"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_build doc
+}