summaryrefslogtreecommitdiff
path: root/sci-mathematics/primecount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /sci-mathematics/primecount
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'sci-mathematics/primecount')
-rw-r--r--sci-mathematics/primecount/Manifest3
-rw-r--r--sci-mathematics/primecount/metadata.xml24
-rw-r--r--sci-mathematics/primecount/primecount-7.2.ebuild48
3 files changed, 75 insertions, 0 deletions
diff --git a/sci-mathematics/primecount/Manifest b/sci-mathematics/primecount/Manifest
new file mode 100644
index 000000000000..bdc617c4b895
--- /dev/null
+++ b/sci-mathematics/primecount/Manifest
@@ -0,0 +1,3 @@
+DIST primecount-7.2.tar.gz 340799 BLAKE2B 5ce3661e322be363e2fe79de1dd134b5c3009269cbb10d36dc69bee4c23c9f41d2117b3ed7aa4c5f852e494832573c84a8d9c37cbe92cf80a5024bdec9b22c69 SHA512 df14929012434eddfab94410ba9165642094327f8abd139a6a1ba87e508bba56df91cb0dc9411e873e90a9aa4aa3ba4007396c930d593f5954be8c715fa26e84
+EBUILD primecount-7.2.ebuild 1095 BLAKE2B 94949133a99b3977d6c4fb8c1b788bddc32facf6de3c5986622461788773688bab38336a0464dd16b8623b533aa2e9907564b9e28fb6a6279ba40c134cd00fbf SHA512 099f3065274d951b11606b02408d9cf87ea68994bf451edf23f79150bd13d83ecdf9449efbe16f149ed4265c6265e255e1a14b608641f4f5114eb70a15a0ddaf
+MISC metadata.xml 673 BLAKE2B dcb9633d5529d3c78afaf761812f38a370496a861e5391190f9c2059bde94ca6628b5d751eeab4c0832bebeec421825019671d0a9a815e269691922b23f3ce2b SHA512 fdbebd019bfd1d06e505900b2061b6a8597f62b2b979f337c07c7bd9084181004183595e05e9381800c02981ec584fef3454a5c98ceeeb76009887f5acb9dfb7
diff --git a/sci-mathematics/primecount/metadata.xml b/sci-mathematics/primecount/metadata.xml
new file mode 100644
index 000000000000..524d8bf2ac66
--- /dev/null
+++ b/sci-mathematics/primecount/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <use>
+ <flag name="executable">Build the primecount CLI executable</flag>
+ </use>
+
+ <upstream>
+ <remote-id type="github">kimwalisch/primecount</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/primecount/primecount-7.2.ebuild b/sci-mathematics/primecount/primecount-7.2.ebuild
new file mode 100644
index 000000000000..1e394a48459e
--- /dev/null
+++ b/sci-mathematics/primecount/primecount-7.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Highly optimized CLI and library to count primes"
+HOMEPAGE="https://github.com/kimwalisch/primecount"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/7" # subslot is first component of libprimecount.so version
+KEYWORDS="~amd64"
+IUSE="+executable openmp test"
+RESTRICT="!test? ( test )"
+
+DEPEND="sci-mathematics/primesieve:="
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/Credits.md
+ doc/Easy-Special-Leaves.md
+ doc/Hard-Special-Leaves.md
+ doc/Records.md
+ doc/References.md
+ doc/alpha-factor-dr.pdf
+ doc/alpha-factor-gourdon.pdf
+ doc/alpha-factor-lmo.pdf
+ doc/libprimecount.md
+)
+
+pkg_pretend() {
+ use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_LIBPRIMESIEVE="OFF"
+ -DBUILD_PRIMECOUNT="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ -DWITH_OPENMP="$(usex openmp)"
+ )
+
+ cmake_src_configure
+}