summaryrefslogtreecommitdiff
path: root/sci-mathematics/planarity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /sci-mathematics/planarity
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'sci-mathematics/planarity')
-rw-r--r--sci-mathematics/planarity/Manifest2
-rw-r--r--sci-mathematics/planarity/planarity-3.0.1.0.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/sci-mathematics/planarity/Manifest b/sci-mathematics/planarity/Manifest
index b1f2a5a7ac7a..e794a247f9f1 100644
--- a/sci-mathematics/planarity/Manifest
+++ b/sci-mathematics/planarity/Manifest
@@ -1,4 +1,6 @@
AUX planarity-3.0.0.5-extern.patch 591 BLAKE2B e8c6c75fdb587f10d38023daec5806ae0930dd4c4be1a74fa11fdd2d837a5b5904948a01601702a5de160725dd60214e0de2aa014f20e41dc957e0c4b24f36f4 SHA512 6fb06c58f853ddaa2fe308a8104db4fee1d6021f4ece9f3f6438ba667e65167f248ac6b3b674e997380f2c874447deda1b7be6dbec2f2c66c188ae5cc8c09bc1
DIST planarity-3.0.0.5.tar.gz 492644 BLAKE2B d183bc07cab7246b62cc7340956206e3f6c5999aa92b223e7665ebd8ae1bc0c354011c078ea4f42d2e45efa2ae5e83e082e4c8d80e3391a4f20be1020ebf8188 SHA512 dfeb7e024e1f5758e5abbd854c4ca963b4f5d45433b2c5eb00ce85c154b5407ebccd1ace0db167488dee757db2c23367101a2aa568941a3664bac9058ea24328
+DIST planarity-3.0.1.0.tar.gz 442280 BLAKE2B c71f8770e92efd8b322d5c5d3f9a3a2917891ae39e41b3f76ac36d74e5e197f18dcfac82d802fb80eeeaac99bcfa5f1a91408f1cf82c7a289321ede7fc97fc04 SHA512 0ad6d7edbd31f29c9b39cc8c7918a9976e5849cf2ca9eefbb260478666ea8d0bac21647e939994ceef7d294436dd12a403520690da14407d45ef25267300282d
EBUILD planarity-3.0.0.5.ebuild 965 BLAKE2B 22f69cf8ce923ef032264bfe35c95ef969b2e6efa0d59214d9e4c7b7a2305e9f4b02543ae6f76c3301d2efe591caf8755be99d6f2377e90b6a7b634b8667846b SHA512 0d61d50250dc39bef0013e9a1e9b838afd0c9edc166d6e419dc6932b50475ebaf2262cd8afaace8e0fe081aa621e4eff3b476bd3b4c14f8c2a9ca9aec1492cef
+EBUILD planarity-3.0.1.0.ebuild 577 BLAKE2B 8007512dcedb209670c8ffa8a56c4b83bd6b1809f0db485ac51d6b6aa0ac965d160f87aa0dffcc8463d273c4c88fa276fff07ad724ad1fb36247fddd5229ff4c SHA512 24dd0821c2b704d422b2518734219f5d3c287f21cdd9104b8de6315f37d69e78f71d0ae8227e188205bdbe5de85c9ea385422cd5ff68e10c2e679d08685c1af3
MISC metadata.xml 808 BLAKE2B a7d1440f9b42358a4550ed751fd52daeba5dd83a694051bbc283de4925e1eacb8a4908a721cb04df2ff29f8c53ee5ca7f6c45850e3d41fec670724b956024627 SHA512 5cb5e8abe1447ac578a1ae0353f3e10bea3d4a0393ce61a99c1fa35b2bcb3b03e6c807d8ecf0fb6f25245db645e5054bd2b273a6d36a5018fd980862f3d20611
diff --git a/sci-mathematics/planarity/planarity-3.0.1.0.ebuild b/sci-mathematics/planarity/planarity-3.0.1.0.ebuild
new file mode 100644
index 000000000000..ff50336d2e9e
--- /dev/null
+++ b/sci-mathematics/planarity/planarity-3.0.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The edge addition planarity suite of graph algorithms"
+HOMEPAGE="https://github.com/graph-algorithms/edge-addition-planarity-suite/"
+
+SRC_URI="https://github.com/graph-algorithms/edge-addition-planarity-suite/releases/download/Version_${PV}/${P}.tar.gz"
+IUSE="static-libs"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}