summaryrefslogtreecommitdiff
path: root/sci-mathematics/picosat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-06 09:09:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-06 09:09:23 +0000
commit1fe7aef6facf013a94eac853717f4da4d5d3c5b3 (patch)
tree78504cbc51fdbf8ae4827c383f075559cf162fa8 /sci-mathematics/picosat
parent7bf9e3db263e64d6cbc306440a7f3c44e551bb13 (diff)
gentoo auto-resync : 06:12:2022 - 09:09:23
Diffstat (limited to 'sci-mathematics/picosat')
-rw-r--r--sci-mathematics/picosat/Manifest4
-rw-r--r--sci-mathematics/picosat/files/picosat-965-makefile.in.patch13
-rw-r--r--sci-mathematics/picosat/metadata.xml9
-rw-r--r--sci-mathematics/picosat/picosat-965.ebuild38
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-mathematics/picosat/Manifest b/sci-mathematics/picosat/Manifest
new file mode 100644
index 000000000000..d2426840a5b1
--- /dev/null
+++ b/sci-mathematics/picosat/Manifest
@@ -0,0 +1,4 @@
+AUX picosat-965-makefile.in.patch 364 BLAKE2B fd6d9ade8e918dd8c9a16ced81a8f47a6ba2b64c7b262a385b0637092beaac4adcc0886506b49c5b21131a550f332b170bc4cc456696d99b7404aa8c11d37018 SHA512 950bddde2363c5b0e36c2333201fbfee54229674f9051f3c4f45023f4364a3bdca3cdaf6b083eed7c9a59c4de0ab92c0eb748092c6cba4c9dba5da6146d6b90f
+DIST picosat-965.tar.gz 64386 BLAKE2B 913b08a72c0b15065353c2ee1ff8fe5a9c0f7a2a8653d80f4cdcee8fdcf69eed7621e28f4259a9d0fb506fefb8eccfd293f06aa7c1b3ea3f6cc31eb319a30532 SHA512 b5372962a0079d70641fd76c431b4ab5042c2f3015179762e447634f220cf0744eea786ee40b00035a342f3ead482061ebe1a9e3726bd06e7adf8e0ac0c5eabf
+EBUILD picosat-965.ebuild 756 BLAKE2B e9f78bc57ecb6098b4adf42604c953d7ceff70d50c5cb6c2050efc6c7bed971f831c48a037b79411d501b9d6c63b6f12020b63ae0968b7cc219261b128bf9d47 SHA512 a567120a954bd949c3550bf765187624b6403befef00f5d1b4fa98a45b1f51f7159d2c8d1e366d38898651cec0600e5759e43988a5365eb70b4363bb87336199
+MISC metadata.xml 277 BLAKE2B 3d5dbdb3275e5d5623299c686ddb7ce896215621e87d688814bc03d383eeec180594639627ed7b8ac903fba49120507407c9e53813401c797c67a2da8330ef02 SHA512 f7b11642db7488b1cc11d3a5602fc18985a0e050502a332ed6850e123c51d3cad21790c09e032454c7590b61d4718cd91bde453c1ec00baaedea90ee9f57882c
diff --git a/sci-mathematics/picosat/files/picosat-965-makefile.in.patch b/sci-mathematics/picosat/files/picosat-965-makefile.in.patch
new file mode 100644
index 000000000000..bc0c501c9223
--- /dev/null
+++ b/sci-mathematics/picosat/files/picosat-965-makefile.in.patch
@@ -0,0 +1,13 @@
+--- a/makefile.in
++++ b/makefile.in
+@@ -49,8 +49,8 @@ config.h: makefile VERSION mkconfig.sh # and actually picosat.c
+ rm -f $@; ./mkconfig.sh > $@
+
+ libpicosat.a: picosat.o version.o
+- ar rc $@ picosat.o version.o
+- ranlib $@
++ $(AR) rc $@ picosat.o version.o
++ $(RANLIB) $@
+
+ SONAME=-Xlinker -soname -Xlinker libpicosat.so
+ libpicosat.so: picosat.o version.o
diff --git a/sci-mathematics/picosat/metadata.xml b/sci-mathematics/picosat/metadata.xml
new file mode 100644
index 000000000000..bfe27bd4a945
--- /dev/null
+++ b/sci-mathematics/picosat/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-mathematics/picosat/picosat-965.ebuild b/sci-mathematics/picosat/picosat-965.ebuild
new file mode 100644
index 000000000000..9803703a619b
--- /dev/null
+++ b/sci-mathematics/picosat/picosat-965.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="SAT solver with proof and core support"
+HOMEPAGE="http://fmv.jku.at/picosat/"
+SRC_URI="http://fmv.jku.at/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.in.patch )
+
+src_configure() {
+ CC="$(tc-getCC)" sh ./configure.sh --shared --trace || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -fPIC"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe picomus picomcs picosat picogcnf
+
+ insinto /usr/share
+ newins VERSION picosat.version
+
+ dolib.so libpicosat.so
+ doheader picosat.h
+
+ dodoc NEWS README
+}