summaryrefslogtreecommitdiff
path: root/sci-mathematics/pari
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-mathematics/pari
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-mathematics/pari')
-rw-r--r--sci-mathematics/pari/Manifest2
-rw-r--r--sci-mathematics/pari/pari-2.13.0.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/sci-mathematics/pari/Manifest b/sci-mathematics/pari/Manifest
index d0365faad5c1..67c6766fb24c 100644
--- a/sci-mathematics/pari/Manifest
+++ b/sci-mathematics/pari/Manifest
@@ -5,5 +5,7 @@ AUX pari-2.9.4-fltk-detection.patch 572 BLAKE2B 1c2e1fa6e52521c7865c3fd011824c83
AUX pari-2.9.4-ppc.patch 363 BLAKE2B 135e76972e4121362666a25e3da236c4a5b7cffa058bbc25b59ca19ea20ccb0665327f70701adca5239cb936d513976e3ba7b5cda915a3f77c7b2eb28e75eaa0 SHA512 aaf5960010e56722f11234079a20ee7a7f8819dc084e1f6567fd11ad2820e3ae47617608f312941c2f373b5312a8c09c9cd51bfa44e263ffe1e8062c9fd9877d
AUX pari-2.9.4-strip.patch 323 BLAKE2B 85a2b56f5501b4dafc0bffe48249c1662d6f96e81f8e8260ad52ecf84f053efef2ee6d6be6a6fda47886c372eb338d8bbf4443910df79a0d4e168b2666228c37 SHA512 50624ead82da41819ccfadfbdb746fb6ff414196ae2576c5d6a86e83c67355740b0e6e901a2860cab202db15adb1b00e346aabba338ab303230bc6aee8d33076
DIST pari-2.11.4.tar.gz 4445000 BLAKE2B e910783186eeb71e74a369681c113b77271abd7f87d7a9f366aea83f36ab984f02e312cd451fad7ee6efb2fa285780e8fa78540bb1fd4b135a62d265176c80e0 SHA512 1312f452244cd1d814a1e43e108378c956669b614845f21199b7039fe6462881168983d4badb8a80bb1bac202cd82d92788a2b4f3c23d16f993cae6e251c4fe1
+DIST pari-2.13.0.tar.gz 4758091 BLAKE2B 21a008fbca9af60c7298daf2db5c596cf881fbf4748899f417e317b2e2c0a951d152ffdab061a5f7da73db65345134a90d91e57069d9f0d0ac6eb2ad470a7a98 SHA512 671bed101be0ba0eef2c4aa4d9580477f2492f2cd354f04773df00c2fa1456d1d6d8e568d617675dc4adce3e6d1f8cbaafae45452891ceb10eba60cd669b529f
EBUILD pari-2.11.4.ebuild 3294 BLAKE2B 8656b6ec3b21763250c075f024c27786756a693c4ba365aa216547134734f91103c5ad38a03cf1ee0ee34c6564823d3f8deb2f75b1c3dd35aed1bf33ced1ee2b SHA512 fcc513c16a48d2d8cdc4b47f7f5d8799fe59b03fe593379b8c4b5f4ab60d9d5d6f6bd75de09cfccbd5a04783b36ef7ad93ccbfd0c8a57d0cca29ceb69db4cb07
+EBUILD pari-2.13.0.ebuild 3391 BLAKE2B 98ea133d0afa58bf2a2327d139a73567900fc52d93b98f579e34df1a879157f9559fcf2f4885401b9b50cc7555910b7dcdff9801e62650a5097de3d805e2570e SHA512 74235c32b2eb4731d62f603427aa1c031f8205a765173ae4814973b204c2a17ce343eaae4df912880497def8af75096d8cfbf7f9f9e853969819f6248aa863d2
MISC metadata.xml 1734 BLAKE2B ffb61a9e3818ed778cd30e0b41279413fec1e624aef0c490e71f501b9797703bbd24413b180b588896d6d74af988e6102f58a04fc1c645f2b876ac2731a399c1 SHA512 b5caa3c3b98405d89681fb25c97dabb3302e971c68fda94e337b10dfc14761963ea548b4689ccb4ac59661425a85a53ea0d424b6acb35a475f42ef145ce9060e
diff --git a/sci-mathematics/pari/pari-2.13.0.ebuild b/sci-mathematics/pari/pari-2.13.0.ebuild
new file mode 100644
index 000000000000..af9b5c717ca8
--- /dev/null
+++ b/sci-mathematics/pari/pari-2.13.0.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Computer-aided number theory C library and tools"
+HOMEPAGE="https://pari.math.u-bordeaux.fr/"
+SRC_URI="https://pari.math.u-bordeaux.fr/pub/${PN}/unix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+# The subslot is the value of $soname_num obtained from
+# upstream's config/version script.
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="data doc fltk gmp test threads X"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( virtual/latex-base )"
+DEPEND="
+ sys-libs/readline:0=
+ data? ( sci-mathematics/pari-data )
+ doc? ( X? ( x11-misc/xdg-utils ) )
+ fltk? ( x11-libs/fltk:1= )
+ gmp? ( dev-libs/gmp:0= )
+ X? ( x11-libs/libX11:0= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-2.9.4-strip.patch
+ "${FILESDIR}/${PN}"-2.9.4-ppc.patch
+ "${FILESDIR}/${PN}"-2.11.2-no-automagic.patch
+ "${FILESDIR}/${PN}"-2.9.4-fltk-detection.patch
+ "${FILESDIR}/${PN}"-2.11.2-Makefile-LDFLAGS.patch
+ "${FILESDIR}/${PN}"-2.11.2-Makefile-docinstall.patch
+)
+
+src_prepare() {
+ default
+
+ # move doc dir to a gentoo doc dir and replace acroread by xdg-open
+ sed -i \
+ -e "s:\$d = \$0:\$d = '${EPREFIX}/usr/share/doc/${PF}':" \
+ -e 's:"acroread":"xdg-open":' \
+ doc/gphelp.in || die "Failed to fix doc dir"
+}
+
+src_configure() {
+ tc-export CC CXX
+
+ # Workaraound to "asm operand has impossible constraints" as
+ # suggested in bug #499996.
+ use x86 && append-cflags $(test-flags-CC -fno-stack-check)
+
+ # need to force optimization here, as it breaks without
+ if is-flag -O0; then
+ replace-flags -O0 -O2
+ elif ! is-flag -O?; then
+ append-flags -O2
+ fi
+
+ # sysdatadir installs a pari.cfg stuff which is informative only.
+ # It is supposed to be for "architecture-dependent" data.
+ # It needs to be easily discoverable for downstream packages such as gp2c.
+ # We set LD to "" so that it is set to the value of the compiler used
+ # which is how a normal end user is expected to configure it. pari's build
+ # system do not cope very well with a naked linker, it is expecting a
+ # compiler driver. See https://bugs.gentoo.org/722090
+ LD="" ./Configure \
+ --prefix="${EPREFIX}"/usr \
+ --datadir="${EPREFIX}/usr/share/${PN}" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --sysdatadir="${EPREFIX}"/usr/share/pari \
+ --mandir="${EPREFIX}"/usr/share/man/man1 \
+ --with-readline="${EPREFIX}"/usr \
+ --with-readline-lib="${EPREFIX}/usr/$(get_libdir)" \
+ --with-ncurses-lib="${EPREFIX}/usr/$(get_libdir)" \
+ $(use_with fltk) \
+ $(use_with gmp) \
+ --without-qt \
+ $(usex threads "--mt=pthread" "" "" "") \
+ || die "./Configure failed"
+}
+
+src_compile() {
+ local mymake=""
+ use hppa && \
+ mymake=DLLD\="${EPREFIX}"/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
+
+ emake ${mymake} gp
+
+ if use doc; then
+ # To prevent sandbox violations by metafont
+ VARTEXFONTS="${T}/fonts" emake docpdf
+ fi
+}
+
+src_test() {
+ # Welcome to the jungle, where the tests fail if you make your
+ # terminal bigger.
+ emake COLUMNS=80 test-all
+}
+
+src_install() {
+ DOCS=( AUTHORS CHANGES* COMPAT NEW README* )
+ default
+
+ if use doc; then
+ docompress -x "/usr/share/doc/${PF}"
+ emake \
+ DESTDIR="${D}" \
+ EXDIR="${ED}/usr/share/doc/${PF}/examples" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install-doc
+ fi
+}