summaryrefslogtreecommitdiff
path: root/sci-mathematics/pari
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-27 10:33:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-27 10:33:45 +0100
commita12f416baa722b8bda57c0d527fb28b3d06b2aeb (patch)
tree00347496d39521fc572cc53fbd17037fbe73ca06 /sci-mathematics/pari
parentef27446dc21d9fb7ee400987661cb759f6a6ee85 (diff)
gentoo auto-resync : 27:07:2023 - 10:33:45
Diffstat (limited to 'sci-mathematics/pari')
-rw-r--r--sci-mathematics/pari/Manifest2
-rw-r--r--sci-mathematics/pari/pari-2.15.4.ebuild132
2 files changed, 134 insertions, 0 deletions
diff --git a/sci-mathematics/pari/Manifest b/sci-mathematics/pari/Manifest
index e01e7ed9b89a..42ae28943e74 100644
--- a/sci-mathematics/pari/Manifest
+++ b/sci-mathematics/pari/Manifest
@@ -2,5 +2,7 @@ AUX pari-2.11.2-no-automagic.patch 2349 BLAKE2B 6c2cdda84342109bad0cbfb3d5188eed
AUX pari-2.9.4-fltk-detection.patch 572 BLAKE2B 1c2e1fa6e52521c7865c3fd011824c83fa92623903dd1e056bda29c6735eb01013e7937f66d6ffff42d0de83f7ed104c7f933d232ee37be7c4351788e76f8daa SHA512 2ec0d8035a87b693ee6a4dfa913f0b24eed20bb4db7f8cd1a47db444310d33d19e6651d475c635be747e79a02df2705e42f6f7032b60dc763583cf9fa8633b29
AUX pari-2.9.4-ppc.patch 363 BLAKE2B 135e76972e4121362666a25e3da236c4a5b7cffa058bbc25b59ca19ea20ccb0665327f70701adca5239cb936d513976e3ba7b5cda915a3f77c7b2eb28e75eaa0 SHA512 aaf5960010e56722f11234079a20ee7a7f8819dc084e1f6567fd11ad2820e3ae47617608f312941c2f373b5312a8c09c9cd51bfa44e263ffe1e8062c9fd9877d
DIST pari-2.15.3.tar.gz 5178288 BLAKE2B d9cc11526360e9fc7688e0a3195a85302d6bf95039051c9419aa18c5bf91eff837d64d9acabb0a51a6e15a3614a5cab4acbf0a502dba5417982514f27721d47d SHA512 9e127850759bac0c0a9b32c6660a55018ec6c6781aaa14c42667f26655444f55c08e100fe186aec8ad1f574d883d76888b13fbafb65d1f4741e2018b78ff307b
+DIST pari-2.15.4.tar.gz 5183685 BLAKE2B 2e20b6dc073ce69bc098dd849e6ab43cb38b05d30ff5f72a31272cd24ef01aa515d4e2a4948264ca89169a6980cd9d76f86c7fbb9aad5be604680569950d9c25 SHA512 2b9f0c1fe7198406df8e6ceb3fcdc8bfb75f5c7ebfb963f023a1eebfff0bcc26e3b690941e188d6b9f8dfb6cddf4ce4c00f2cc320ebe47d42ae7596c774ed6cc
EBUILD pari-2.15.3.ebuild 4004 BLAKE2B 9a024a99f7059e85f77282fb799f75ae525b7167b982aa2fa1e5f32c4a05a4c7f37b0eb81a24036d4cbaf0e45c8ed6d68b7106b652a53b64330a15368ff8072d SHA512 9aba44c7d0af9b6c6ddca06e5f6336cfeba02ceadc8723a68cc971209ec13802ebb1addf41864505d64a870975a9f404682c71f06e3fc83af91f3a44e0190214
+EBUILD pari-2.15.4.ebuild 3969 BLAKE2B 9e1c0cd9a59fc09b2983d73a910d2f86d927dd1649958b4c3f14e878546c0582488a7027d1484c19eb78e233203a6b222c02f18c837945e7cf370d7aee0373a4 SHA512 f65090ed242a3c218f1a13c9696e33c630949e21cda096ea521ae5c1a76215bd23c8ddbb28f73c9288ae80d02fac5093c2b14c8f745db1eb82be9b8922e97412
MISC metadata.xml 1770 BLAKE2B d730330ac80159a9e46a7c892049d00e28bfe9e4d4c61616c033ccaf526cfef6f95a03bac803bf70c59760e1833e35fce5bc535038aadc8db68dca878c7bde78 SHA512 387a8eb845634e8568a3e98f44f9b92bd7819870ebb6cb57b28e96c0df022b4436074fa526771f5e6793ce59c010c0c0437abb63f03ec9890bca3c301afcf9ee
diff --git a/sci-mathematics/pari/pari-2.15.4.ebuild b/sci-mathematics/pari/pari-2.15.4.ebuild
new file mode 100644
index 000000000000..4869bbe3d995
--- /dev/null
+++ b/sci-mathematics/pari/pari-2.15.4.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Computer-aided number theory C library and tools"
+HOMEPAGE="https://pari.math.u-bordeaux.fr/"
+SRC_URI="https://pari.math.u-bordeaux.fr/pub/${PN}/unix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+# The subslot is the value of $soname_num obtained from
+# upstream's config/version script.
+SLOT="0/8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="data doc examples fltk gmp test threads X"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )
+"
+DEPEND="
+ sys-libs/readline:0=
+ data? ( sci-mathematics/pari-data )
+ doc? ( X? ( x11-misc/xdg-utils ) )
+ fltk? ( x11-libs/fltk:1= )
+ gmp? ( dev-libs/gmp:0= )
+ X? ( x11-libs/libX11:0= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-2.9.4-fltk-detection.patch
+ "${FILESDIR}/${PN}"-2.11.2-no-automagic.patch
+)
+
+src_prepare() {
+ default
+
+ # move doc dir to a gentoo doc dir and replace acroread by xdg-open
+ sed -i \
+ -e "s:\$d = \$0:\$d = '${EPREFIX}/usr/share/doc/${PF}':" \
+ -e 's:"acroread":"xdg-open":' \
+ doc/gphelp.in || die "Failed to fix doc dir"
+
+ # These tests fail when LaTeX is not installed (which we don't
+ # require without USE=doc), most likely due to output formatting
+ # issues but I haven't deleted my LaTeX installation to check.
+ # There's no real upstream support for enabling/disabling the LaTeX
+ # docs, so this is probably the correctest way to skip these tests.
+ if ! use doc; then
+ rm src/test/{in,32}/help || die
+ fi
+}
+
+src_configure() {
+ tc-export CC CXX PKG_CONFIG
+
+ # Workaraound to "asm operand has impossible constraints" as
+ # suggested in bug #499996.
+ use x86 && append-cflags $(test-flags-CC -fno-stack-check)
+
+ # sysdatadir installs a pari.cfg stuff which is informative only.
+ # It is supposed to be for "architecture-dependent" data. It needs
+ # to be easily discoverable for downstream packages such as gp2c.
+ # We set LD="" and DLLD="$CC" so that the "shared library linker"
+ # always gets set to the value of the compiler used. Pari's build
+ # system does not cope very well with a naked linker, it is
+ # expecting a compiler driver. See bugs 722090 and 871117.
+ # DLLDFLAGS, on the other hand, is used exactly like LDFLAGS would
+ # be in a less-weird build system.
+ LD="" DLLD="$(tc-getCC)" DLLDFLAGS="${LDFLAGS}" ./Configure \
+ --prefix="${EPREFIX}"/usr \
+ --datadir="${EPREFIX}/usr/share/${PN}" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --sysdatadir="${EPREFIX}"/usr/share/pari \
+ --mandir="${EPREFIX}"/usr/share/man/man1 \
+ --with-readline="${EPREFIX}"/usr \
+ --with-readline-lib="${EPREFIX}/usr/$(get_libdir)" \
+ --with-ncurses-lib="${EPREFIX}/usr/$(get_libdir)" \
+ $(use_with fltk) \
+ $(use_with gmp) \
+ --without-qt \
+ $(usex threads "--mt=pthread" "" "" "") \
+ || die "./Configure failed"
+}
+
+src_compile() {
+ emake gp
+
+ if use doc; then
+ # To prevent sandbox violations by metafont
+ VARTEXFONTS="${T}/fonts" emake docpdf
+ fi
+}
+
+src_test() {
+ # Welcome to the jungle, where the tests fail if you make your
+ # terminal bigger.
+ emake COLUMNS=80 test-all
+}
+
+src_install() {
+ DOCS=( AUTHORS CHANGES* COMPAT NEW README* )
+
+ # Install examples to a junk location by default because "make
+ # install-nodata" includes the examples with it. Only if the user
+ # has USE=examples set do we provide the correct directory.
+ local exdir="${T}"
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ exdir="${ED}/usr/share/doc/${PF}/examples"
+ fi
+
+ # Use "true" in place of "strip" to sabotage the unconditional
+ # binary stripping.
+ emake DESTDIR="${D}" \
+ EXDIR="${exdir}" \
+ STRIP="true" \
+ install-nodata install-data
+ einstalldocs
+
+ if use doc; then
+ docompress -x "/usr/share/doc/${PF}"
+ emake \
+ DESTDIR="${D}" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install-docpdf install-doctex
+ fi
+}