summaryrefslogtreecommitdiff
path: root/sci-mathematics/p9m4/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-mathematics/p9m4/files
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-mathematics/p9m4/files')
-rw-r--r--sci-mathematics/p9m4/files/p9m4-v05-package.patch67
-rw-r--r--sci-mathematics/p9m4/files/p9m4-v05-python2.6.patch44
-rw-r--r--sci-mathematics/p9m4/files/p9m4-v05-use-inst-paths.patch42
3 files changed, 0 insertions, 153 deletions
diff --git a/sci-mathematics/p9m4/files/p9m4-v05-package.patch b/sci-mathematics/p9m4/files/p9m4-v05-package.patch
deleted file mode 100644
index 9ca737ce2ffe..000000000000
--- a/sci-mathematics/p9m4/files/p9m4-v05-package.patch
+++ /dev/null
@@ -1,67 +0,0 @@
---- p9m4-v05-orig/setup.py 2007-11-17 09:31:26.000000000 +1100
-+++ p9m4-v05/setup.py 2012-07-02 23:48:21.753760992 +1000
-@@ -26,23 +26,24 @@
-
- from setuptools import setup
-
--APP = ['prover9-mace4.py']
--DATA_FILES = ['platforms.py',
-- 'utilities.py',
-- 'wx_utilities.py',
-- 'files.py',
-- 'options.py',
-- 'partition_input.py',
-- 'my_setup.py',
-- 'control.py',
-- 'Images',
-- 'Samples',
-- 'bin-mac']
--OPTIONS = {'argv_emulation': True, 'iconfile': '/Users/mccune/gui/v4/p9.icns'}
-+OPTIONS = {'argv_emulation': True, 'iconfile': '/usr/share/p9m4/Images/p9.ico'}
-
- setup(
-- app=APP,
-- data_files=DATA_FILES,
-- options={'py2app': OPTIONS},
-- setup_requires=['py2app'],
-+ name='p9m4',
-+ version='05',
-+ scripts=['prover9-mace4.py'],
-+ package_dir = {'p9m4': 'p9m4'},
-+ py_modules=['p9m4.platforms',
-+ 'p9m4.utilities',
-+ 'p9m4.wx_utilities',
-+ 'p9m4.files',
-+ 'p9m4.options',
-+ 'p9m4.partition_input',
-+ 'p9m4.my_setup',
-+ 'p9m4.control'],
-+ # remove py2app
-+ # https://bugs.gentoo.org/show_bug.cgi?id=423555
-+ # sci-mathematics/p9m4-05: tries to use network during install
-+ # options={'py2app': OPTIONS},
-+ # setup_requires=['py2app'],
- )
---- p9m4-v05-orig/prover9-mace4.py 2007-12-08 03:27:13.000000000 +1100
-+++ p9m4-v05/prover9-mace4.py 2012-01-08 18:12:09.970620044 +1100
-@@ -27,13 +27,13 @@
-
- # local imports
-
--import partition_input
--import utilities
--from files import *
--from platforms import *
--from wx_utilities import *
--from my_setup import *
--from control import *
-+import p9m4.partition_input
-+import p9m4.utilities
-+from p9m4.files import *
-+from p9m4.platforms import *
-+from p9m4.wx_utilities import *
-+from p9m4.my_setup import *
-+from p9m4.control import *
-
- Program_name = 'Prover9-Mace4'
- Program_version = '0.5'
diff --git a/sci-mathematics/p9m4/files/p9m4-v05-python2.6.patch b/sci-mathematics/p9m4/files/p9m4-v05-python2.6.patch
deleted file mode 100644
index 70cb006d268e..000000000000
--- a/sci-mathematics/p9m4/files/p9m4-v05-python2.6.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Nur p9m4-0.5/my_setup.py p9m4-0.5.new/my_setup.py
---- p9m4-0.5/my_setup.py 2008-01-14 23:30:55.000000000 +0000
-+++ p9m4-0.5.new/my_setup.py 2008-01-14 23:35:45.000000000 +0000
-@@ -158,7 +158,9 @@
- self.ed.SetStyle(start, end,
- wx.TextAttr('RED',
- wx.Colour(200,200,255)))
-- error_dialog('%s\n%s' % (message,error if error else ''))
-+ error_dialog('%s\n%s' % (message,error))
-+ else:
-+ error_dialog(message)
- else:
- frame = Text_frame(self, to_top(self).box_font,
- 'Error Output',
-diff -Nur p9m4-0.5/partition_input.py p9m4-0.5.new/partition_input.py
---- p9m4-0.5/partition_input.py 2008-01-14 23:30:55.000000000 +0000
-+++ p9m4-0.5.new/partition_input.py 2008-01-14 23:35:45.000000000 +0000
-@@ -63,14 +63,23 @@
- m2 = r2.search(str, m1.end())
- while m2 and in_span(m2.start(), comments):
- m2 = r2.search(str, m2.end())
-- match_end = m2.end() if m2 else len(str)
-+ if m2:
-+ match_end = m2.end()
-+ else:
-+ match_end = len(str)
- other += str[other_start:m1.start()]
- if remove_patterns:
- keep_start = m1.end()
-- keep_end = m2.start() if m2 else len(str)
-+ if m2:
-+ keep_end = m2.start()
-+ else:
-+ keep_end = len(str)
- else:
- keep_start = m1.start()
-- keep_end = m2.end() if m2 else len(str)
-+ if m2:
-+ keep_end = m2.end()
-+ else:
-+ keep_end = len(str)
- matched += str[keep_start:keep_end]
- next = other_start = match_end
- else:
diff --git a/sci-mathematics/p9m4/files/p9m4-v05-use-inst-paths.patch b/sci-mathematics/p9m4/files/p9m4-v05-use-inst-paths.patch
deleted file mode 100644
index 5b48b94b27bf..000000000000
--- a/sci-mathematics/p9m4/files/p9m4-v05-use-inst-paths.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -Nur p9m4-0.5/files.py p9m4-0.5.new/files.py
---- p9m4-0.5/files.py 2008-01-14 23:31:00.000000000 +0000
-+++ p9m4-0.5.new/files.py 2008-01-14 23:39:51.000000000 +0000
-@@ -51,6 +51,9 @@
- return sys.path[0]
- # return os.path.dirname(os.path.abspath(sys.argv[0]))
-
-+def data_dir():
-+ return '/usr/share/p9m4'
-+
- def bin():
- if Win32():
- return 'bin-win32'
-@@ -63,13 +66,13 @@
- return 'bin'
-
- def bin_dir():
-- return os.path.join(program_dir(), bin())
-+ return '/usr/bin'
-
- def image_dir():
-- return os.path.join(program_dir(), 'Images')
-+ return os.path.join(data_dir(), 'Images')
-
- def sample_dir():
-- return os.path.join(program_dir(), 'Samples')
-+ return os.path.join(data_dir(), 'Samples')
-
- def binary_ok(fullpath):
- if not fullpath:
-diff -Nur p9m4-0.5/prover9-mace4.py p9m4-0.5.new/prover9-mace4.py
---- p9m4-0.5/prover9-mace4.py 2007-12-07 16:27:13.000000000 +0000
-+++ p9m4-0.5.new/prover9-mace4.py 2008-02-10 22:45:45.000000000 +0000
-@@ -27,6 +27,8 @@
-
- # local imports
-
-+sys.path.append('/usr/share/p9m4/lib')
-+
- import partition_input
- import utilities
- from files import *