summaryrefslogtreecommitdiff
path: root/sci-mathematics/opensmt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-15 23:49:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-15 23:49:15 +0100
commitfddb33ccaadabe03f5571606f796b45965b38e9c (patch)
treedba6d179254abac3ee319d7bde5191bebf09a5c3 /sci-mathematics/opensmt
parent6fc112778f70ed827633ff345036db5b592ca1d0 (diff)
gentoo auto-resync : 15:04:2023 - 23:49:14
Diffstat (limited to 'sci-mathematics/opensmt')
-rw-r--r--sci-mathematics/opensmt/Manifest2
-rw-r--r--sci-mathematics/opensmt/opensmt-2.5.0.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/sci-mathematics/opensmt/Manifest b/sci-mathematics/opensmt/Manifest
index a3e66975ba07..4e21520c3adb 100644
--- a/sci-mathematics/opensmt/Manifest
+++ b/sci-mathematics/opensmt/Manifest
@@ -1,4 +1,6 @@
AUX opensmt-2.4.3-musl.patch 4317 BLAKE2B 7f1349452d31edac8e90ba322396fd4725399512481b035f6996b5ec4ad09cc1af3579668ee4da79deb198befdde2cd2fbb9fcc4159ec97b0aaedfce9e73a443 SHA512 09c2cea9928e89806136c5cae2403eb4168bf3984974f6212c0c1b9857affd3b1559bf6cb1bb5a0b8a3a6d9a340cca559446fe4d535b87b1f5b2cdc176f7b7ad
DIST opensmt-2.4.3.tar.gz 1912077 BLAKE2B d945d5b85d81b9b991f2f881f2d8f160dbefad8ce6484cf0d28c9a35c0fa64d18f45442a59cdd45bd29fcf526a09717d902d30376dfe2784de2d4df9627f803b SHA512 a2adbbdebb133d7e97428c0ac9bf4c2413c95bca61567c5475f889f550904fc33a385712536c9026b38a1645b73c943876fa36724b634db061cb7cc0932543f2
+DIST opensmt-2.5.0.tar.gz 1940493 BLAKE2B ee643815b9da8bdc4a3a074a438eacdfde778347f4090aa7403e34859a9d51a17db8992c38a0e9f7a808384b0413abfbe2aa7b360dda44181344528159666945 SHA512 d70972eae376b927694f893ff9b6e4bfba7d0cfffe63545b5a0d582b594c3538643c9ae0121e75cf85aec3876eb4a45df2766c3a7700d07da05d1d6081953f42
EBUILD opensmt-2.4.3-r2.ebuild 1532 BLAKE2B b0bf4ee05b5187d7d620c15082965367bcfce64d2822c2933a779cb11c011e91a8da37b6b8eb27c68474ae128f98740725bab197209f21d1827d3d8416eeb605 SHA512 93756020fc8889331007b4577e84de58af914bccbdce2a32b4ed9bc9c45d9514e3b031698ec79d08d69e983b857d48c582e3c5926afd2db993805249e6efdc7a
+EBUILD opensmt-2.5.0.ebuild 1541 BLAKE2B 44e686101a91b3c64297a7121afa8e9916c2a8f163e6d42adb5db551da837d2815d0457019548de86e12136ae19e9367d8a24f48ef0c7cec5ca85f057e6fcf89 SHA512 8594a6f32268774fb18567e8aac36ebb3aab0c91dec6fba09056f5d17ed0f753bfa681f696c3b572c6d7498242b2bba11989d5330d0de84179f3b4af7700e41c
MISC metadata.xml 798 BLAKE2B 173b47beab9c5ecc15caf32dd0514230f5dbefea8a9c75b33ab4f4cc51bc7e66e1a90240c3d0ba55f09959accf4203136c2b1ab400c2289e8329906cc0aabb56 SHA512 e3acadb473098ff0985b15ce2fb7ffcd8ef2f29fde2736a9c7e5d297a0857e358cdfa508b9f030add29f8bd808ce1594961e9a92768cbc8cff155a8195bd392e
diff --git a/sci-mathematics/opensmt/opensmt-2.5.0.ebuild b/sci-mathematics/opensmt/opensmt-2.5.0.ebuild
new file mode 100644
index 000000000000..479c6c7e252f
--- /dev/null
+++ b/sci-mathematics/opensmt/opensmt-2.5.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Compact and open-source SMT-solver written in C++"
+HOMEPAGE="http://verify.inf.usi.ch/opensmt/
+ https://github.com/usi-verification-and-security/opensmt/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/usi-verification-and-security/${PN}.git"
+else
+ SRC_URI="https://github.com/usi-verification-and-security/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="debug libedit +readline test"
+REQUIRED_USE="?? ( libedit readline )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/gmp:=[cxx]
+ readline? ( sys-libs/readline:= )
+ libedit? ( dev-libs/libedit:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ test? ( dev-cpp/gtest )
+"
+
+# PATCHES=( "${FILESDIR}"/${PN}-2.4.3-musl.patch )
+
+src_prepare() {
+ cmake_src_prepare
+
+ echo "add_subdirectory(unit)" > "${S}"/test/CMakeLists.txt || die
+}
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug ; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ local -a mycmakeargs=(
+ -DPACKAGE_TESTS=$(usex test)
+ -DUSE_READLINE=$(usex readline)
+ )
+ if use readline || use libedit ; then
+ mycmakeargs+=( -DENABLE_LINE_EDITING=ON )
+ fi
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ rm "${ED}"/usr/lib/libopensmt.a || die
+ dodir /usr/$(get_libdir)
+ mv "${ED}"/usr/lib/libopensmt.* "${ED}"/usr/$(get_libdir)/ || die
+}