summaryrefslogtreecommitdiff
path: root/sci-mathematics/opensmt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 23:50:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 23:50:08 +0000
commitea8740cede74808fe1546789e18738612217bb97 (patch)
tree50a16d926ab0d05dd840e745118ff229fcaf0b78 /sci-mathematics/opensmt
parent06bb974d894b86598af155dc76a6fbd76c4fa30c (diff)
gentoo auto-resync : 13:01:2023 - 23:50:08
Diffstat (limited to 'sci-mathematics/opensmt')
-rw-r--r--sci-mathematics/opensmt/Manifest3
-rw-r--r--sci-mathematics/opensmt/opensmt-2.4.3-r1.ebuild69
-rw-r--r--sci-mathematics/opensmt/opensmt-2.4.3.ebuild10
3 files changed, 80 insertions, 2 deletions
diff --git a/sci-mathematics/opensmt/Manifest b/sci-mathematics/opensmt/Manifest
index dff19713643c..8c9168b70006 100644
--- a/sci-mathematics/opensmt/Manifest
+++ b/sci-mathematics/opensmt/Manifest
@@ -1,3 +1,4 @@
DIST opensmt-2.4.3.tar.gz 1912077 BLAKE2B d945d5b85d81b9b991f2f881f2d8f160dbefad8ce6484cf0d28c9a35c0fa64d18f45442a59cdd45bd29fcf526a09717d902d30376dfe2784de2d4df9627f803b SHA512 a2adbbdebb133d7e97428c0ac9bf4c2413c95bca61567c5475f889f550904fc33a385712536c9026b38a1645b73c943876fa36724b634db061cb7cc0932543f2
-EBUILD opensmt-2.4.3.ebuild 1355 BLAKE2B bf93186fbee03e625ebc711cd27986ce70198ac3b58d644fcffea2e2e459d6baa86b5acbf68510496ecfca68c952c72185d5f3ba426944efea9c4f4ade346a28 SHA512 53b0152acbc429a9f09d03ee9a0385c10c92a0347b07567fcc67a662a0717675f3773b3e3fa336e95e3b3087fd88037c6e063c5e2d5a241b6ff6444f599f2944
+EBUILD opensmt-2.4.3-r1.ebuild 1484 BLAKE2B cc6abf84eda262a35389464c2de630ffca88c672509708712c822e033d2eea66ac673fdd65fc91069fd333cff83f1a257810629458874a3a9282137006694165 SHA512 9d97fb719d2e179b26d7e6bbf5b7abfb5e649a9358c5744b1a3aa5da1ae70270dcf47d87d1da0d32c874c50cf6f1c7819840a3815c3c7542e036989ab549efc2
+EBUILD opensmt-2.4.3.ebuild 1560 BLAKE2B 58b42d294098458926e79378b48aad42a75eebf4fa2feb532cfcbc91fbb653812596d8969eca973d2f66af29e7aca536874025c1aeb167ba8613a50a08d07864 SHA512 f77aa8dbe36c4f85119a3761e05d21837dfb750f3e9fe69c1ea60c91f75ffc500759105ecf6a78ed642a7d1533faa62e2ef386caeed472952e1b822759d1a974
MISC metadata.xml 798 BLAKE2B 173b47beab9c5ecc15caf32dd0514230f5dbefea8a9c75b33ab4f4cc51bc7e66e1a90240c3d0ba55f09959accf4203136c2b1ab400c2289e8329906cc0aabb56 SHA512 e3acadb473098ff0985b15ce2fb7ffcd8ef2f29fde2736a9c7e5d297a0857e358cdfa508b9f030add29f8bd808ce1594961e9a92768cbc8cff155a8195bd392e
diff --git a/sci-mathematics/opensmt/opensmt-2.4.3-r1.ebuild b/sci-mathematics/opensmt/opensmt-2.4.3-r1.ebuild
new file mode 100644
index 000000000000..b1e67e45cbad
--- /dev/null
+++ b/sci-mathematics/opensmt/opensmt-2.4.3-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Compact and open-source SMT-solver written in C++"
+HOMEPAGE="http://verify.inf.usi.ch/opensmt/
+ https://github.com/usi-verification-and-security/opensmt/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/usi-verification-and-security/${PN}.git"
+else
+ SRC_URI="https://github.com/usi-verification-and-security/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="debug libedit +readline test"
+REQUIRED_USE="?? ( libedit readline )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/gmp:=
+ readline? ( sys-libs/readline:= )
+ libedit? ( dev-libs/libedit:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ test? ( dev-cpp/gtest )
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ echo "add_subdirectory(unit)" > "${S}"/test/CMakeLists.txt || die
+}
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug ; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ local -a mycmakeargs=(
+ -DPACKAGE_TESTS=$(usex test)
+ -DUSE_READLINE=$(usex readline)
+ )
+ if use readline || use libedit ; then
+ mycmakeargs+=( -DENABLE_LINE_EDITING=ON )
+ fi
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ rm "${ED}"/usr/lib/libopensmt.a || die
+ dodir /usr/$(get_libdir)
+ mv "${ED}"/usr/lib/libopensmt.* "${ED}"/usr/$(get_libdir)/ || die
+}
diff --git a/sci-mathematics/opensmt/opensmt-2.4.3.ebuild b/sci-mathematics/opensmt/opensmt-2.4.3.ebuild
index 6e169efbf9ca..089f834988bc 100644
--- a/sci-mathematics/opensmt/opensmt-2.4.3.ebuild
+++ b/sci-mathematics/opensmt/opensmt-2.4.3.ebuild
@@ -36,6 +36,13 @@ BDEPEND="
test? ( dev-cpp/gtest )
"
+src_prepare() {
+ cmake_src_prepare
+
+ echo "add_subdirectory(unit)" > "${S}"/test/CMakeLists.txt || die
+ echo "add_subdirectory(unit)" > "${S}"/parallel-test/CMakeLists.txt || die
+}
+
src_configure() {
local CMAKE_BUILD_TYPE
if use debug ; then
@@ -57,6 +64,7 @@ src_configure() {
src_install() {
cmake_src_install
- mkdir -p "${ED}"/usr/$(get_libdir) || die
+ rm "${ED}"/usr/lib/libopensmt.a || die
+ dodir /usr/$(get_libdir)
mv "${ED}"/usr/lib/libopensmt.* "${ED}"/usr/$(get_libdir)/ || die
}