summaryrefslogtreecommitdiff
path: root/sci-mathematics/opensmt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 22:21:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 22:21:54 +0000
commit06dcf64674a43718324bffee383625d2cd050b75 (patch)
tree4de58e857f3f0718fef4fc386e42577c2f4c9478 /sci-mathematics/opensmt
parent198bd0cd3c1be97f7deb5283fa00048718482de4 (diff)
gentoo auto-resync : 07:11:2023 - 22:21:54
Diffstat (limited to 'sci-mathematics/opensmt')
-rw-r--r--sci-mathematics/opensmt/Manifest3
-rw-r--r--sci-mathematics/opensmt/files/opensmt-2.5.2-gcc-14.patch68
-rw-r--r--sci-mathematics/opensmt/opensmt-2.5.2.ebuild4
3 files changed, 73 insertions, 2 deletions
diff --git a/sci-mathematics/opensmt/Manifest b/sci-mathematics/opensmt/Manifest
index 8bcf183d7189..2e803701bcf7 100644
--- a/sci-mathematics/opensmt/Manifest
+++ b/sci-mathematics/opensmt/Manifest
@@ -1,3 +1,4 @@
+AUX opensmt-2.5.2-gcc-14.patch 2151 BLAKE2B 4432e4fc793823ef80d77f33538546e9be8f9d415babab84ca6eaba1a246520789f31eaa1ea5208cf32802408b73fe74e8b653a419e3cb606c74fb6399c9a07c SHA512 665e8dbfc7630ac6f7355b58ee3eb23df813f4b1f8117cbe8c6fec3c421495ba782bb5e0102eb233046e11c5f22271d64ab455b62ee52048d357aaf2adebcc80
DIST opensmt-2.5.2.tar.gz 1935650 BLAKE2B 85cd171d56591d2f1162a41ff8a425fc818238a2820aab0f75cc75ece8898c5e7de1478aeab93e8905a1aedad85a6df03062fefaad69bea043dce1f3f3d531f5 SHA512 c22d17d3aee33a3360f8ea552c82151eafdef7cc89e6750d34b4ff2a011675a5a5f04a7cb68ff984dd6a5332b2f180fb8abc529e64c3970aba6b7eb60408f198
-EBUILD opensmt-2.5.2.ebuild 1528 BLAKE2B 80e35f101980d464a7c28ed4be5bea57fd78236bf870013afe80c6a9707feca47f8883af1041753c7435238e6af3dd94d1c1f7bdcd75174f23a05707900ae60b SHA512 cd5a803bb256a73fb442f2048ac6f7f5b9e1e4c2e3ccd8b38216414745d0da878c234fe876771007e310a4be86a639a4c74478e6b93c39543690528d8a0856aa
+EBUILD opensmt-2.5.2.ebuild 1529 BLAKE2B 9b4e51680e1a89ab6a2bf8d34f4c42363953c9a989654a254581a3b2ccc60aa2361b19a7fe7be160cef4cb3c383c8842dd34ec58c4a7baa2362f9dcb62507cd4 SHA512 e2268ed478a1770be8a310156455a1306fb287ec56474ae4fcce96f6a300eb750357d7d3f28f60c285a5a7db4ca75f53136441a7595d6b3f3f70859677c5ce05
MISC metadata.xml 798 BLAKE2B 173b47beab9c5ecc15caf32dd0514230f5dbefea8a9c75b33ab4f4cc51bc7e66e1a90240c3d0ba55f09959accf4203136c2b1ab400c2289e8329906cc0aabb56 SHA512 e3acadb473098ff0985b15ce2fb7ffcd8ef2f29fde2736a9c7e5d297a0857e358cdfa508b9f030add29f8bd808ce1594961e9a92768cbc8cff155a8195bd392e
diff --git a/sci-mathematics/opensmt/files/opensmt-2.5.2-gcc-14.patch b/sci-mathematics/opensmt/files/opensmt-2.5.2-gcc-14.patch
new file mode 100644
index 000000000000..c5957641fff7
--- /dev/null
+++ b/sci-mathematics/opensmt/files/opensmt-2.5.2-gcc-14.patch
@@ -0,0 +1,68 @@
+From f30e983f876df3bd34571f9d554b3ebe226dd4bd Mon Sep 17 00:00:00 2001
+From: Kostadin Shishmanov <kocelfc@tutanota.com>
+Date: Tue, 7 Nov 2023 16:38:39 +0200
+Subject: [PATCH] Add include <algorithm> to fix building with gcc 14
+
+Gentoo bug:
+https://bugs.gentoo.org/916855
+
+Upstream PR:
+https://github.com/usi-verification-and-security/opensmt/pull/653
+
+Signed-off-by: Kostadin Shishmanov <kocelfc@tutanota.com>
+---
+ src/logics/Logic.cc | 1 +
+ src/pterms/PtStore.cc | 1 +
+ src/simplifiers/BoolRewriting.cc | 1 +
+ src/tsolvers/egraph/EnodeStore.cc | 2 ++
+ 4 files changed, 5 insertions(+)
+
+diff --git a/src/logics/Logic.cc b/src/logics/Logic.cc
+index 2619df1fd..84b04d515 100644
+--- a/src/logics/Logic.cc
++++ b/src/logics/Logic.cc
+@@ -21,6 +21,7 @@
+ #include <queue>
+ #include <set>
+ #include <sstream>
++#include <algorithm>
+
+ using namespace std;
+
+diff --git a/src/pterms/PtStore.cc b/src/pterms/PtStore.cc
+index 377642947..63c6f56f3 100644
+--- a/src/pterms/PtStore.cc
++++ b/src/pterms/PtStore.cc
+@@ -29,6 +29,7 @@ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+ #include "OsmtApiException.h"
+
+ #include <sstream>
++#include <algorithm>
+
+ const int PtStore::ptstore_vec_idx = 1;
+ const int PtStore::ptstore_buf_idx = 2;
+diff --git a/src/simplifiers/BoolRewriting.cc b/src/simplifiers/BoolRewriting.cc
+index e2aa52b2c..196a642c4 100644
+--- a/src/simplifiers/BoolRewriting.cc
++++ b/src/simplifiers/BoolRewriting.cc
+@@ -5,6 +5,7 @@
+ #include "BoolRewriting.h"
+ #include "Logic.h"
+ #include <unordered_set>
++#include <algorithm>
+
+ // Replace subtrees consisting only of ands / ors with a single and / or term.
+ // Search a maximal section of the tree consisting solely of ands / ors. The
+diff --git a/src/tsolvers/egraph/EnodeStore.cc b/src/tsolvers/egraph/EnodeStore.cc
+index 2bed3302b..de2216410 100644
+--- a/src/tsolvers/egraph/EnodeStore.cc
++++ b/src/tsolvers/egraph/EnodeStore.cc
+@@ -28,6 +28,8 @@ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+ #include "Symbol.h"
+ #include "Logic.h"
+
++#include <algorithm>
++
+ EnodeStore::EnodeStore(Logic& l)
+ : logic(l)
+ , ea(1024*1024)
diff --git a/sci-mathematics/opensmt/opensmt-2.5.2.ebuild b/sci-mathematics/opensmt/opensmt-2.5.2.ebuild
index 04e39c2ae269..73c64f7b50df 100644
--- a/sci-mathematics/opensmt/opensmt-2.5.2.ebuild
+++ b/sci-mathematics/opensmt/opensmt-2.5.2.ebuild
@@ -36,7 +36,9 @@ BDEPEND="
test? ( dev-cpp/gtest )
"
-# PATCHES=( "${FILESDIR}"/${PN}-2.4.3-musl.patch )
+PATCHES=(
+ "${FILESDIR}/${PN}-2.5.2-gcc-14.patch"
+)
src_prepare() {
cmake_src_prepare