summaryrefslogtreecommitdiff
path: root/sci-mathematics/num-utils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /sci-mathematics/num-utils/files
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'sci-mathematics/num-utils/files')
-rw-r--r--sci-mathematics/num-utils/files/num-utils-0.5-r2-Makefile.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/num-utils/files/num-utils-0.5-r2-Makefile.patch b/sci-mathematics/num-utils/files/num-utils-0.5-r2-Makefile.patch
new file mode 100644
index 000000000000..b0d331451aa3
--- /dev/null
+++ b/sci-mathematics/num-utils/files/num-utils-0.5-r2-Makefile.patch
@@ -0,0 +1,48 @@
+diff --git a/Makefile b/Makefile
+index 079b442..a6ade95 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,7 +22,7 @@ VERSION = $(shell cat VERSION)
+ PROJECT = num-utils
+ DIST = $(PROJECT)-$(VERSION)
+ FILES = $(shell cat MANIFEST)
+-UTILS = average bound interval normalize numgrep numprocess numsum random range round
++UTILS = numaverage numbound numinterval numnormalize numgrep numprocess numsum numrandom numrange numround
+ DOCS = template README GOALS WARNING
+ TESTS = file fractionalnums numbers numbers2 README zeros
+ # rpm --showrc is gettin to be hard to parse anymore.
+@@ -62,7 +62,7 @@ install:
+
+ install -m 0755 -o 0 -g 0 -d $(DESTDIR)/$(MANDIR)
+ for man in $(UTILS) ; do \
+- install -m 0644 -o 0 -g 0 $$man.1.gz $(DESTDIR)/$(MANDIR) ; done
++ install -m 0644 -o 0 -g 0 $$man.1 $(DESTDIR)/$(MANDIR) ; done
+
+ uninstall:
+ for util in $(UTILS) ; do \
+@@ -74,14 +74,12 @@ uninstall:
+ rmdir $(DESTDIR)/$(DOCDIR)
+
+ for man in $(UTILS) ; do \
+- rm -f $(DESTDIR)/$(MANDIR)/$$man.1.gz ; done
++ rm -f $(DESTDIR)/$(MANDIR)/$$man.1 ; done
+ rmdir $(DESTDIR)/$(MANDIR)
+
+ manpages:
+ for doc in $(UTILS) ; do \
+- pod2man $$doc > $$doc.1 ; \
+- gzip -9 $$doc.1 ; chmod 644 $$doc.1.gz \
+- ; done
++ pod2man $$doc > $$doc.1 ; done
+
+ rpminstall:
+ install -m 0755 -d $(BINDIR)
+@@ -94,7 +93,7 @@ rpminstall:
+
+ install -m 0755 -d $(MANDIR)
+ for man in $(UTILS) ; do \
+- install -m 0644 $$man.1.gz $(MANDIR) ; done
++ install -m 0644 $$man.1 $(MANDIR) ; done
+
+ clean:
+ rm -f $(PROJECT).spec