summaryrefslogtreecommitdiff
path: root/sci-mathematics/normaliz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-22 08:56:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-22 08:56:17 +0100
commit07a79a268edfbac4dba8c66eff20cbdc2aac0f6a (patch)
treebc6688a3cc8c802970aa5e29936310ae9b76ccda /sci-mathematics/normaliz
parent470949042cc90856adb62f2671e04e3165fc8063 (diff)
gentoo auto-resync : 22:05:2023 - 08:56:17
Diffstat (limited to 'sci-mathematics/normaliz')
-rw-r--r--sci-mathematics/normaliz/Manifest2
-rw-r--r--sci-mathematics/normaliz/normaliz-3.10.0.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-mathematics/normaliz/Manifest b/sci-mathematics/normaliz/Manifest
index ce8313e03fc6..4c86935b9e03 100644
--- a/sci-mathematics/normaliz/Manifest
+++ b/sci-mathematics/normaliz/Manifest
@@ -1,3 +1,5 @@
+DIST normaliz-3.10.0.tar.gz 5177794 BLAKE2B ef2ed089da0bf7b286f477837d8793466c1b030ea0f321cd74e910461a6bd28705f971d1b987ef59aa783311dc247e2838d5acf850cb1948e429c98e1ca440f0 SHA512 febc43f846607dcfca8bcf462e8ccf655e2e6e10dcb2741412c08489fc9b2e99410306dc4b078084bfe73e41113849b201e6f7f5a8e2ae07508ebf1c043f95a3
DIST normaliz-3.9.3.tar.gz 4946498 BLAKE2B 3faff64fda86216ee11b0f55ba1341d70988472f65eedafe5b52bf6b05abd817add2dbab45144de0a43d02c501caf3c4a89d66c2b2d621b81188a2a5100d158f SHA512 5d6866cc35835c196d22d6b4b0d5f0e3e2e00f772553115fbbabd8415b20388cf367cf9a282904a72c03c2ef482b804f7009d67e3334add4fc37f3bab675da6c
+EBUILD normaliz-3.10.0.ebuild 1681 BLAKE2B cb3d172f736136d5706ee0e3b9b8ff162c4e3ec4ad3dede67b2d275dd340ba0d361c47bb4bdda66d7fbfac01372fd4f6e79a029435d75e41a27f52e925216c61 SHA512 91ef2964ace54fdcf9fa9da2c63b11669cf3403dc08678b44ba64f75852fee6186ae95cd3682c8019e6a2b525398a20737140feeb7ebff7a189a0e3915a53ad2
EBUILD normaliz-3.9.3.ebuild 1599 BLAKE2B 7b87b54a8dc78b220f1bd46945d46165a2f37269d73c7f3ebea5bd43b0f5e74674eb532dd766e678bb3292c98422a47266198fc76fdef4320cb22f8b0ca5cfe8 SHA512 17dae30d1e232055b0e20dca7563978905a9560c978abe9e8a52f1c4498b17a6c5e180c2ca81128a74761b3277afd78744de173a494d62e621fadfbd03cdd88c
MISC metadata.xml 823 BLAKE2B e6ac647e395713b5589b2dd6655bdde020fdb4113067f83d503497e0e5ec916b04d2742227ea16f1dda4551c1275b2d0e684e3dab4cb331fc4d42597ea2bc004 SHA512 3f242ea780a29900dfda6b7a0372a87d38ebd11184e1eed976653bc3712e54c2cf5897f07c7f2d0aa50a1af6364fb797c2c4e78cb9c3fa4344370cab4dbe4abb
diff --git a/sci-mathematics/normaliz/normaliz-3.10.0.ebuild b/sci-mathematics/normaliz/normaliz-3.10.0.ebuild
new file mode 100644
index 000000000000..055e1f8973ca
--- /dev/null
+++ b/sci-mathematics/normaliz/normaliz-3.10.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Tool for computations in affine monoids and more"
+HOMEPAGE="https://www.normaliz.uni-osnabrueck.de/"
+SRC_URI="https://github.com/Normaliz/Normaliz/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc extras nauty openmp"
+
+RDEPEND="
+ dev-libs/gmp:=[cxx(+)]
+ nauty? ( sci-mathematics/nauty )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+# Only a boost header is needed -> not RDEPEND
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ # Fix C standard compliance.
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # flint (and arb, which doesn't make an appearance in ./configure --help)
+ # is somehow connected to e-antic, which we do not yet package. Likewise
+ # we have no packages for cocoalib or hashlibrary.
+ econf \
+ $(use_enable openmp) \
+ $(use_with nauty) \
+ --without-cocoalib \
+ --without-hashlibrary \
+ --without-flint \
+ --without-e-antic \
+ --disable-static
+}
+
+src_compile() {
+ # Clobber the default "AM_LDFLAGS = -Wl,-s" to avoid QA warnings
+ # about pre-stripped binaries.
+ emake AM_LDFLAGS=""
+}
+
+src_install() {
+ default
+
+ use doc && dodoc doc/Normaliz.pdf doc/NmzShortRef.pdf
+ if use extras; then
+ newdoc Singular/normaliz.pdf singular-normaliz.pdf
+ insinto /usr/share/${PN}
+ doins Singular/normaliz.lib
+ doins Macaulay2/Normaliz.m2
+ fi
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}