summaryrefslogtreecommitdiff
path: root/sci-mathematics/normaliz/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/normaliz/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/normaliz/files')
-rw-r--r--sci-mathematics/normaliz/files/normaliz-2.12.1-respect-flags.patch47
-rw-r--r--sci-mathematics/normaliz/files/normaliz-2.12.2-gcc49.patch11
-rw-r--r--sci-mathematics/normaliz/files/normaliz-3.0.0-respect-flags.patch47
3 files changed, 105 insertions, 0 deletions
diff --git a/sci-mathematics/normaliz/files/normaliz-2.12.1-respect-flags.patch b/sci-mathematics/normaliz/files/normaliz-2.12.1-respect-flags.patch
new file mode 100644
index 000000000000..d7d83ee79d91
--- /dev/null
+++ b/sci-mathematics/normaliz/files/normaliz-2.12.1-respect-flags.patch
@@ -0,0 +1,47 @@
+diff -U 3 -dHrN Normaliz2.12/source/Makefile Normaliz2.12.patched/source/Makefile
+--- Normaliz2.12/source/Makefile 2014-10-23 15:01:56.000000000 +0200
++++ Normaliz2.12.patched/source/Makefile 2014-10-25 14:56:39.426295174 +0200
+@@ -17,16 +17,16 @@
+ @$(MAKE) normaliz
+
+ normaliz.o: $(SOURCES) $(HEADERS) $(LIBHEADERS)
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) -c Normaliz.cpp -o normaliz.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -c Normaliz.cpp -o normaliz.o
+
+ normaliz: $(SOURCES) $(HEADERS) normaliz.o libnormaliz/libnormaliz.a
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) normaliz.o libnormaliz/libnormaliz.a $(GMPFLAGS) -o normaliz
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) normaliz.o libnormaliz/libnormaliz.a $(GMPFLAGS) -o normaliz
+
+ normaliz1: $(SOURCES) $(HEADERS) $(LIBHEADERS) $(LIBSOURCES)
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) Normaliz-impl.cpp $(GMPFLAGS) -o normaliz1
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) Normaliz-impl.cpp $(GMPFLAGS) -o normaliz1
+
+ normaliz-pg: $(SOURCES) $(HEADERS) $(LIBHEADERS) $(LIBSOURCES)
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) -pg Normaliz-impl.cpp $(GMPFLAGS) -o normaliz-pg
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -pg Normaliz-impl.cpp $(GMPFLAGS) -o normaliz-pg
+
+
+ #always go down the directory and let the make there check what has to be done
+diff -U 3 -dHrN Normaliz2.12/source/Makefile.configuration Normaliz2.12.patched/source/Makefile.configuration
+--- Normaliz2.12/source/Makefile.configuration 2014-10-23 15:01:56.000000000 +0200
++++ Normaliz2.12.patched/source/Makefile.configuration 2014-10-25 15:18:39.876313342 +0200
+@@ -1,11 +1,9 @@
+ ##
+ ## Makefile configuration for normaliz
+ ##
+-CXX = g++
+ #CXX = linux32 g++ -m32 -march=i686 #compile it for linux32
+ CXXFLAGS += -std=c++0x
+ CXXFLAGS += -Wall -pedantic
+-CXXFLAGS += -O3 -funroll-loops
+ #CXXFLAGS += -I /usr/local/boost_1_45_0
+ CXXFLAGS += -g ## debugging
+ #CXXFLAGS += -pg ## profiling
+@@ -19,7 +17,6 @@
+ endif
+
+ ## for distributing the executables link static (does not work for mac)
+-CXXFLAGS += -static
+ ## for almost static compilation on Mac use
+ #CXXFLAGS += -static-libgcc
+ ## make it compatible with older Mac versions
diff --git a/sci-mathematics/normaliz/files/normaliz-2.12.2-gcc49.patch b/sci-mathematics/normaliz/files/normaliz-2.12.2-gcc49.patch
new file mode 100644
index 000000000000..35a28c8cf2a3
--- /dev/null
+++ b/sci-mathematics/normaliz/files/normaliz-2.12.2-gcc49.patch
@@ -0,0 +1,11 @@
+diff -U 3 -dHrN Normaliz2.12/source/libnormaliz/general.h Normaliz2.12.patched/source/libnormaliz/general.h
+--- Normaliz2.12/source/libnormaliz/general.h 2014-10-23 15:01:56.000000000 +0200
++++ Normaliz2.12.patched/source/libnormaliz/general.h 2015-03-01 13:20:01.057017555 +0100
+@@ -27,6 +27,7 @@
+
+ #include <iostream>
+ #include <assert.h>
++#include <cstddef>
+
+ #ifdef _WIN32 //for 32 and 64 bit windows
+ #define NMZ_MPIR //always use MPIR
diff --git a/sci-mathematics/normaliz/files/normaliz-3.0.0-respect-flags.patch b/sci-mathematics/normaliz/files/normaliz-3.0.0-respect-flags.patch
new file mode 100644
index 000000000000..cfd91d2feaff
--- /dev/null
+++ b/sci-mathematics/normaliz/files/normaliz-3.0.0-respect-flags.patch
@@ -0,0 +1,47 @@
+diff -U 3 -dHrN Normaliz3.0.orig/source/Makefile Normaliz3.0/source/Makefile
+--- Normaliz3.0.orig/source/Makefile 2015-09-29 14:05:44.960631514 +0200
++++ Normaliz3.0/source/Makefile 2015-09-29 14:06:06.510346764 +0200
+@@ -19,16 +19,16 @@
+ @$(MAKE) normaliz
+
+ normaliz.o: $(SOURCES) $(HEADERS) $(LIBHEADERS)
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) -c Normaliz.cpp -o normaliz.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -c Normaliz.cpp -o normaliz.o
+
+ normaliz: $(SOURCES) $(HEADERS) normaliz.o libnormaliz/libnormaliz.a
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) normaliz.o libnormaliz/libnormaliz.a $(LINKFLAGS) -o normaliz
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) normaliz.o libnormaliz/libnormaliz.a $(LINKFLAGS) -o normaliz
+
+ normaliz1: $(SOURCES) $(HEADERS) $(LIBHEADERS) $(LIBSOURCES)
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) Normaliz-impl.cpp $(LINKFLAGS) -o normaliz1
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) Normaliz-impl.cpp $(LINKFLAGS) -o normaliz1
+
+ normaliz-pg: $(SOURCES) $(HEADERS) $(LIBHEADERS) $(LIBSOURCES)
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) -pg Normaliz-impl.cpp $(LINKFLAGS) -o normaliz-pg
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -pg Normaliz-impl.cpp $(LINKFLAGS) -o normaliz-pg
+
+
+ #always go down the directory and let the make there check what has to be done
+diff -U 3 -dHrN Normaliz3.0.orig/source/Makefile.configuration Normaliz3.0/source/Makefile.configuration
+--- Normaliz3.0.orig/source/Makefile.configuration 2015-09-29 14:05:44.960631514 +0200
++++ Normaliz3.0/source/Makefile.configuration 2015-09-29 14:07:16.419426513 +0200
+@@ -1,11 +1,9 @@
+ ##
+ ## Makefile configuration for normaliz
+ ##
+-CXX = g++
+ #CXX = linux32 g++ -m32 -march=i686 #compile it for linux32
+ CXXFLAGS += -std=c++0x
+ CXXFLAGS += -Wall -pedantic
+-CXXFLAGS += -O3 -funroll-loops
+ #CXXFLAGS += -I /usr/local/boost_1_45_0
+ #CXXFLAGS += -g ## debugging
+ #CXXFLAGS += -pg ## profiling
+@@ -21,7 +19,6 @@
+ endif
+
+ ## for distributing the executables link static (does not work for mac)
+-CXXFLAGS += -static
+ ## for almost static compilation on Mac use
+ #CXXFLAGS += -static-libgcc
+ ## make it compatible with older Mac versions