summaryrefslogtreecommitdiff
path: root/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild')
-rw-r--r--sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild b/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
new file mode 100644
index 000000000000..dda14ea4f26f
--- /dev/null
+++ b/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="A GiNaC-based library for symbolic expansion of certain transcendental functions"
+HOMEPAGE="http://wwwthep.physik.uni-mainz.de/~stefanw/nestedsums/"
+IUSE="doc"
+SRC_URI="http://wwwthep.physik.uni-mainz.de/~stefanw/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND=">=sci-mathematics/ginac-1.7"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ default
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen Doxyfile || die "generating documentation failed"
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -f "${D}"usr/lib/*.la
+ dodoc AUTHORS ChangeLog
+
+ if use doc; then
+ dohtml reference/html/*
+ fi
+}