summaryrefslogtreecommitdiff
path: root/sci-mathematics/metamath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-mathematics/metamath
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-mathematics/metamath')
-rw-r--r--sci-mathematics/metamath/Manifest4
-rw-r--r--sci-mathematics/metamath/files/metamath-configure.ac-dont_force_optimize.patch16
-rw-r--r--sci-mathematics/metamath/metadata.xml18
-rw-r--r--sci-mathematics/metamath/metamath-0.198.ebuild28
4 files changed, 66 insertions, 0 deletions
diff --git a/sci-mathematics/metamath/Manifest b/sci-mathematics/metamath/Manifest
new file mode 100644
index 000000000000..32ce99ca3096
--- /dev/null
+++ b/sci-mathematics/metamath/Manifest
@@ -0,0 +1,4 @@
+AUX metamath-configure.ac-dont_force_optimize.patch 490 BLAKE2B 5a7175a72b32ecb1991f01a481459543bf9fdc511ded4bbe1551d5991710f3176575b7ebbea50c6aff3cb4087370960249e78223b84df6337304c1eb7dfaf460 SHA512 882ebb713e6209af28d39fbe120aac223337602d3553e93bfe2649237f6f03cc5dc5ab610ae0f051054f24668ecea85293ce9a1bac6fb8b635a52f93e9cf806f
+DIST metamath-0.198.tar.gz 468593 BLAKE2B 030bc61f5d8f0c02d473fcd2802b3411c96eff04f7144b966f1f098aec3a65218137228f4d97ba96aaa190386802db00865b9e997b399ce06b19d421c335f2bf SHA512 607c0a8208b9414b36bf82a1fcb0b826e9bfa4cbcec0337be58f3e890b91473649b115403227f440b9774e5653434ffdf09f0ab82c2f5af59eac0d11b9d09942
+EBUILD metamath-0.198.ebuild 632 BLAKE2B f5df87080cce63d8410cd70d7979350582e40357fc9fbabe86bff8d8ba4434d6170a1d1ecfefe5f1d5ad5a3b7ca8f456f5eaecb406490631539a009d53d95677 SHA512 dea937a871e03eece4f72a81e6814013ddfc7266da2aa708394c1dc35a4584d565d42260b05b116290d8529ed909605fb8bc627e2015e44848fef6fc539b249c
+MISC metadata.xml 619 BLAKE2B fdeb72df964419f71e05af45685e81e9127e978b648d0386cbbad50485455a952fa380c5cf66706afb247a731b091fe7efbe076139d336132b3dc1ced69591bf SHA512 d7c4e4d33f5605a36480f62631c63d22724bb4f448aa102edce4d06898eecb6629f1cee59e16f13634359694d861b69317fa3d236a82ca3aa7252dd8159b3dc3
diff --git a/sci-mathematics/metamath/files/metamath-configure.ac-dont_force_optimize.patch b/sci-mathematics/metamath/files/metamath-configure.ac-dont_force_optimize.patch
new file mode 100644
index 000000000000..548b0042ecef
--- /dev/null
+++ b/sci-mathematics/metamath/files/metamath-configure.ac-dont_force_optimize.patch
@@ -0,0 +1,16 @@
+index 263d3d8..68a8fea 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -45,11 +45,9 @@ int f() {
+
+ # Try to optimize.
+ AC_MSG_CHECKING([[for optimization flags]])
+-new_CFLAGS="-O3 -funroll-loops -finline-functions -fomit-frame-pointer"
++new_CFLAGS=""
+ saved_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $new_CFLAGS"
+-# Remove any existing "-O2", or it will override what we're doing.
+-CFLAGS=$( printf "%s" "$CFLAGS" | sed -e 's/ -O2/ /' )
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([[
+ #include <stdio.h>
diff --git a/sci-mathematics/metamath/metadata.xml b/sci-mathematics/metamath/metadata.xml
new file mode 100644
index 000000000000..824d79b7b66d
--- /dev/null
+++ b/sci-mathematics/metamath/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ Metamath is a tiny language that can express theorems in abstract
+ mathematics, accompanied by proofs that can be verified by a computer
+ program.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/metamath/metamath-exe/issues</bugs-to>
+ <remote-id type="github">metamath/metamath-exe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/metamath/metamath-0.198.ebuild b/sci-mathematics/metamath/metamath-0.198.ebuild
new file mode 100644
index 000000000000..1f48ed968847
--- /dev/null
+++ b/sci-mathematics/metamath/metamath-0.198.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Proof verifier based on a minimalistic formalism"
+HOMEPAGE="http://us.metamath.org/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}-exe.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}-exe/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-exe-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-configure.ac-dont_force_optimize.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}