summaryrefslogtreecommitdiff
path: root/sci-mathematics/metamath-databases
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-mathematics/metamath-databases
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-mathematics/metamath-databases')
-rw-r--r--sci-mathematics/metamath-databases/Manifest3
-rw-r--r--sci-mathematics/metamath-databases/metadata.xml18
-rw-r--r--sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild45
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-mathematics/metamath-databases/Manifest b/sci-mathematics/metamath-databases/Manifest
new file mode 100644
index 000000000000..c43e2ca2ac6b
--- /dev/null
+++ b/sci-mathematics/metamath-databases/Manifest
@@ -0,0 +1,3 @@
+DIST metamath-databases-20220303.tar.gz 20538855 BLAKE2B 8aa3c505a16d1fac08de5d447eb55e4bc64f5fa53905c1147a17b6e65c87403f2baea9d30699da71f16cc34373f2d9c56c02f3b85327aa9db42af7c5c63db8df SHA512 5f2ca7e299ec3e8dda7739de057c69dcbdd4e23d5853826ac9d6ccabcaa0abf292990eb1925762ff2a5611b32628ed508b6fa4949121e090feaa0c986f3f67ac
+EBUILD metamath-databases-20220303.ebuild 853 BLAKE2B 522b476a701ab12125346e94246f25dc99fc5e22e10b9b33753def65e99af65d34b5112ca40d7d5078fc9550f83f6c6b5a597abe37a208d1e6af6d67b767a539 SHA512 d1eb8440eceb7b099ee40ac4cd8e414714088ddcc65b4a94f75535f6242e34dbab803947a7606b826d3bfb9d04ebd0a36ed8e8dccccd31c84c89783b34582e75
+MISC metadata.xml 633 BLAKE2B ab8c86cc84be54a40ef6210855d1d77abd58f4fc9a8433fb8005a1916ec720201feca35fcd7f9587b720612df8f0d278445661e93632a80194038fd32d85c128 SHA512 b7bdc15f1089359deaf7f323ba21330680977b7a314c796d632fec744bcef5981746a55a5e8663dd7a6b09ba726b4291e1f80b10c03a2a60538ea1b04d229e1b
diff --git a/sci-mathematics/metamath-databases/metadata.xml b/sci-mathematics/metamath-databases/metadata.xml
new file mode 100644
index 000000000000..aeb2ac517a10
--- /dev/null
+++ b/sci-mathematics/metamath-databases/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ This is a collection of rigorously verified Metamath databases that
+ specify mathematical axioms and formal proofs of theorems derived from
+ those axioms.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/metamath/set.mm/issues/</bugs-to>
+ <remote-id type="github">metamath/set.mm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild b/sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild
new file mode 100644
index 000000000000..32304b03acd4
--- /dev/null
+++ b/sci-mathematics/metamath-databases/metamath-databases-20220303.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=99d707bc3c600a9d6052a46a7c85f05b74c589a2
+
+DESCRIPTION="Sample databases for Metamath"
+HOMEPAGE="http://us.metamath.org/mpeuni/mmset.html"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/metamath/set.mm.git"
+else
+ SRC_URI="https://github.com/metamath/set.mm/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}"/set.mm-${H}
+fi
+
+LICENSE="CC0-1.0"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="sci-mathematics/metamath"
+
+DOCS=(
+ CONTRIBUTING.md README.md
+ discouraged iset-discouraged
+ mmnotes.txt
+ other-databases.md verifiers.md
+)
+
+src_install() {
+ insinto /usr/share/metamath
+ doins *.mm *.mmts
+
+ einstalldocs
+
+ if use doc ; then
+ docinto html
+ dodoc -r people
+ dodoc *.html *.svg
+ fi
+}