summaryrefslogtreecommitdiff
path: root/sci-mathematics/maxima
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-mathematics/maxima
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-mathematics/maxima')
-rw-r--r--sci-mathematics/maxima/Manifest3
-rw-r--r--sci-mathematics/maxima/maxima-5.44.0-r8.ebuild235
-rw-r--r--sci-mathematics/maxima/metadata.xml4
3 files changed, 240 insertions, 2 deletions
diff --git a/sci-mathematics/maxima/Manifest b/sci-mathematics/maxima/Manifest
index 1dbaad4eddca..b9adb1edc4be 100644
--- a/sci-mathematics/maxima/Manifest
+++ b/sci-mathematics/maxima/Manifest
@@ -16,4 +16,5 @@ DIST maxima-5.42.1.tar.gz 41865510 BLAKE2B d3b8a50594dc0cef0c354c42be1aee96df77a
DIST maxima-5.44.0.tar.gz 34976354 BLAKE2B d6870b6fb0581d9e60d6ed97c7daed8ce12b8b1ae49d0edb7b8d31dd723f9b879eb70440659ff958f53cee16d8d2a92f80dcaa3898d9f6dbabd79a5059073a65 SHA512 1e043bebb7c6d002c113d8de20a98d58d1a8e7bedfc9bcf52819e7c7554655991dc2f42f0333889706574249736db833a237b3e59b967e7e42ede28262e31f2f
EBUILD maxima-5.42.1.ebuild 4895 BLAKE2B dd388cfe14cef36137a91ff71912c23390e176d796ce02c36f59cbb1e8993a03b16ee32b4e6d792e59d95bad3bcd90e3e9ded23abb1e3c371f466bd53f44502c SHA512 64c8a759525fff99c99831be56ea268b213392c65b1ef2e9db133addfaefead39710264c6a599eee7c53262ef16f75fbdbb35a9516a7054f0934d6fd46303520
EBUILD maxima-5.44.0-r4.ebuild 6278 BLAKE2B 9da7f0e09a3b6f370b20ce11915e4d9e893c1e1ea499ebfcf22d81ee2a0c17053b1e38450551855ac62356e3d4b8201f9a067ff94e169a00eb6c5a42ed73d82d SHA512 03083941bd72b72341edd0d5b35501b309a62d14bde6be6555d670e6a21b85ed800c35810dec1a713d6ffc59e0b8279a4daa4fb85385676412d0bff877d94dd4
-MISC metadata.xml 1607 BLAKE2B 04e6a57fb68b1c61027a4cd5b1605347c48e989c246e6f5a8c3587d17778d7c55b6cb5a6ab81dee7c21d0597953d2e90211f6d16b565dae602cfe22021a8f89b SHA512 bab36eab986e0a8619e9409d63af9103bce52bb08d75bde6c6d7a92cf1c856ad7c4d462dcb65bbde141a4d62ee024414186533db1e0e5f0bebb62f0623de55e3
+EBUILD maxima-5.44.0-r8.ebuild 6352 BLAKE2B e74faa47dd0ba27775e386b81c04e57cc94e992a7b2d0aa78aa24002bfa8256f9baaab8aab6414971d035f57a1bdcc522240975b523fe45c00d588e48af46684 SHA512 5ef06927b60d9c4071cd0a696ab9e3c66ebfc4ea0e8f48ee53675345804de996385da1f65666df4f6583a523c90493705485aa4c809daa7db58b24bd7639f5e4
+MISC metadata.xml 1733 BLAKE2B 30e06c199d4c4919ea90aa5a0b3091b124b4b43fc7791d758afdb0d94069edfafe386ddd7ddbeb9aa2589a5ec3866ecabd9d71c1b41380db6212529ad376c846 SHA512 2a9ccad0ef037a65f7dae3ac3769ab0bdf54ac8789387d3bcab0e022f9dfb77b019d14dc03bd7777937076e822c837511c12fd8198e7b9bd7eb6e621e46c0be4
diff --git a/sci-mathematics/maxima/maxima-5.44.0-r8.ebuild b/sci-mathematics/maxima/maxima-5.44.0-r8.ebuild
new file mode 100644
index 000000000000..1ef1c4f672a8
--- /dev/null
+++ b/sci-mathematics/maxima/maxima-5.44.0-r8.ebuild
@@ -0,0 +1,235 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit autotools elisp-common flag-o-matic python-single-r1 xdg-utils
+
+DESCRIPTION="Free computer algebra environment based on Macsyma"
+HOMEPAGE="http://maxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="clisp clozurecl clozurecl64 cmucl ecls emacs gcl gui nls +sbcl unicode vtk X test"
+RESTRICT="!test? ( test )"
+
+# Languages
+LANGS="de es pt pt_BR"
+for lang in ${LANGS}; do
+ IUSE="${IUSE} l10n_${lang/_/-}"
+done
+
+LISP_DEPEND="
+ clisp? ( dev-lisp/clisp )
+ clozurecl? ( dev-lisp/clozurecl app-misc/rlwrap )
+ clozurecl64? ( dev-lisp/clozurecl app-misc/rlwrap )
+ cmucl? ( dev-lisp/cmucl app-misc/rlwrap )
+ ecls? ( dev-lisp/ecls app-misc/rlwrap )
+ gcl? ( dev-lisp/gcl[ansi,readline] )
+ sbcl? ( dev-lisp/sbcl app-misc/rlwrap )
+"
+
+# Python is used in e.g. doc/info/build_html.sh to build the docs.
+# LISP_DEPEND is included in both BDEPEND and DEPEND because the various
+# lisp engines are used to both compile and run maxima. It's possible
+# that they don't (all?) need to be listed in DEPEND; who knows.
+BDEPEND="
+ ${PYTHON_DEPS}
+ ${LISP_DEPEND}
+ test? ( sci-visualization/gnuplot )
+ sys-apps/texinfo
+"
+
+DEPEND="
+ ${LISP_DEPEND}
+ emacs? ( >=app-editors/emacs-23.1:* )
+ gui? ( dev-lang/tk:0 )
+"
+
+# texlive-latexrecommended needed by imaxima for breqn.sty
+#
+# VTK is an optional plotting backend that can be enabled by
+# running "draw_renderer: 'vtk;" within maxima.
+#
+# It's NON-optional for the scene() command, but that command is
+# currently useless since Tcl/Tk support was dropped in sci-libs/vtk.
+# Thus we include VTK only as an optional dependency.
+#
+# We require app-misc/rlwrap for any lisps that don't support readline
+# themselves.
+RDEPEND="
+ ${DEPEND}
+ X? (
+ x11-misc/xdg-utils
+ sci-visualization/gnuplot[gd]
+ vtk? (
+ ${PYTHON_DEPS}
+ sci-libs/vtk[python,rendering,${PYTHON_SINGLE_USEDEP}]
+ )
+ )
+ emacs? (
+ virtual/latex-base
+ app-emacs/auctex
+ app-text/ghostscript-gpl
+ dev-texlive/texlive-latexrecommended
+ )"
+
+# Maxima can make use of X features like plotting (and launching a PNG
+# viewer) from the console, but you can't use the xmaxima GUI without X.
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( clisp clozurecl clozurecl64 cmucl ecls gcl sbcl )
+ gui? ( X )"
+
+TEXMF="${EPREFIX}"/usr/share/texmf-site
+
+pkg_setup() {
+ # Set the PYTHON variable to whatever it should be.
+ python-single-r1_pkg_setup
+}
+
+PATCHES=(
+ "${FILESDIR}/support-new-vtk.patch"
+ "${FILESDIR}/dont-hardcode-python.patch"
+ "${FILESDIR}/xdg-utils-1.patch"
+ "${FILESDIR}/wish-2.patch"
+ "${FILESDIR}/rmaxima-0.patch"
+ "${FILESDIR}/emacs-0.patch"
+ "${FILESDIR}/clisp-1.patch"
+ "${FILESDIR}/clozurecl-3.patch"
+ "${FILESDIR}/ecls-4.patch"
+ "${FILESDIR}/cmucl-1.patch"
+ "${FILESDIR}/sbcl-2.patch"
+)
+
+src_prepare() {
+ default
+
+ # bug #343331
+ rm share/Makefile.in || die
+ rm src/Makefile.in || die
+ touch src/*.mk
+ touch src/Makefile.am
+
+ eautoreconf
+}
+
+src_configure() {
+ local CONFS=""
+
+ # enable existing translated doc
+ if use nls; then
+ for lang in ${LANGS}; do
+ if use "l10n_${lang/_/-}"; then
+ CONFS="${CONFS} --enable-lang-${lang}"
+ use unicode && CONFS="${CONFS} --enable-lang-${lang}-utf8"
+ fi
+ done
+ fi
+
+ # Using raw-ldflags fixes the error,
+ #
+ # x86_64-pc-linux-gnu/bin/ld: fatal error: -O1 -Wl: invalid option
+ # value (expected an integer): 1 -Wl
+ #
+ # when building the maxima.fas library for ECL. See upstream bugs:
+ #
+ # * https://sourceforge.net/p/maxima/bugs/3759/
+ # * https://gitlab.com/embeddable-common-lisp/ecl/-/issues/636
+ #
+ # The 32-bit and 64-bit version of the clozurecl executable
+ # are both called "ccl" on Gentoo, so we need the additional
+ # use_with for clozurecl64. See bugs 665364 and 715278....
+ #
+ # The usex works around https://sourceforge.net/p/maxima/bugs/3757/
+ #
+ econf ${CONFS} \
+ LDFLAGS="$(raw-ldflags)" \
+ $(use_enable clisp) \
+ $(use_enable clozurecl ccl) \
+ $(use_enable clozurecl64 ccl64) \
+ $(usex clozurecl64 "--with-ccl64=ccl" "") \
+ $(use_enable cmucl) \
+ $(use_enable ecls ecl) \
+ $(use_enable emacs) \
+ $(use_enable gcl) \
+ $(use_with gui wish) \
+ $(use_enable sbcl) \
+ --with-lispdir="${EPREFIX}/${SITELISP}/${PN}"
+}
+
+src_compile() {
+ # The variable PYTHONBIN is used in one place while building the
+ # German documentation. Some day that script should be converted
+ # to use the value of @PYTHON@ obtained during ./configure.
+ emake PYTHONBIN="${PYTHON}"
+ if use emacs; then
+ pushd interfaces/emacs/emaxima > /dev/null
+ elisp-compile *.el
+ popd > /dev/null
+ pushd interfaces/emacs/imaxima > /dev/null
+ BYTECOMPFLAGS="-L . -L ../emaxima"
+ elisp-compile *.el
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ docompress -x /usr/share/info
+ emake DESTDIR="${D}" emacsdir="${EPREFIX}/${SITELISP}/${PN}" install
+
+ # do not use dodoc because interfaces can't read compressed files
+ # read COPYING before attempt to remove it from dodoc
+ insinto /usr/share/${PN}/${PV}/doc
+ doins AUTHORS COPYING README README.lisps
+ dodir /usr/share/doc
+ dosym ../${PN}/${PV}/doc /usr/share/doc/${PF}
+
+ if use emacs; then
+ elisp-install ${PN} interfaces/emacs/{emaxima,imaxima}/*.{el,elc,lisp}
+ elisp-site-file-install "${FILESDIR}"/50maxima-gentoo-1.el
+
+ rm "${ED}"/${SITELISP}/${PN}/emaxima.sty || die
+ insinto ${TEXMF}/tex/latex/emaxima
+ doins interfaces/emacs/emaxima/emaxima.sty
+
+ insinto /usr/share/${PN}/${PV}/doc/imaxima
+ doins interfaces/emacs/imaxima/README
+ doins -r interfaces/emacs/imaxima/imath-example
+
+ if ! use gcl; then
+ # This emacs package is used to run gcl, maxima, gdb, etc.
+ # all at once and possibly in the same buffer. As such, it's
+ # no use without gcl (more to the point: it requires gcl.el).
+ find "${ED}" -name 'dbl.el' -type f -delete || die
+ fi
+ fi
+
+ if use ecls; then
+ # Use ECL to find the path where it expects to load packages from.
+ ECLLIB=$(ecl -eval "(princ (SI:GET-LIBRARY-PATHNAME))" -eval "(quit)")
+ insinto "${ECLLIB#${EPREFIX}}"
+ doins src/binary-ecl/maxima.fas
+ fi
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ if use emacs; then
+ elisp-site-regen
+ mktexlsr
+ fi
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ if use emacs; then
+ elisp-site-regen
+ mktexlsr
+ fi
+}
diff --git a/sci-mathematics/maxima/metadata.xml b/sci-mathematics/maxima/metadata.xml
index d87f8aea9f05..154d5891d70c 100644
--- a/sci-mathematics/maxima/metadata.xml
+++ b/sci-mathematics/maxima/metadata.xml
@@ -18,7 +18,9 @@
<use>
<flag name="clisp">Compile maxima with GNU CLISP
(<pkg>dev-lisp/clisp</pkg>)</flag>
- <flag name="clozurecl">Compile maxima with Clozure Common Lisp
+ <flag name="clozurecl">Compile maxima with 32-bit Clozure Common Lisp
+ (<pkg>dev-lisp/clozurecl</pkg>)</flag>
+ <flag name="clozurecl64">Compile maxima with 64-bit Clozure Common Lisp
(<pkg>dev-lisp/clozurecl</pkg>)</flag>
<flag name="cmucl">Compile maxima with CMU Common Lisp
(<pkg>dev-lisp/cmucl</pkg>)</flag>