summaryrefslogtreecommitdiff
path: root/sci-mathematics/mathmod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/mathmod
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/mathmod')
-rw-r--r--sci-mathematics/mathmod/Manifest4
-rw-r--r--sci-mathematics/mathmod/mathmod-4.1-r1.ebuild43
-rw-r--r--sci-mathematics/mathmod/metadata.xml22
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-mathematics/mathmod/Manifest b/sci-mathematics/mathmod/Manifest
new file mode 100644
index 000000000000..1400bc27edef
--- /dev/null
+++ b/sci-mathematics/mathmod/Manifest
@@ -0,0 +1,4 @@
+DIST mathmod-4.1.src.zip 974709 SHA256 fff57e82fc57b90af98b345f14219c01b1709b019735739b9244173bec626ad4 SHA512 e7a170f5b57384cca4e755a0bb3691ec3fe29e9b22027534f1e84ed656905495c70eea8c69262f31a937ca508c34177d33adc23f5a8a3c91db1eceb2aa283a6d WHIRLPOOL ee68e96744cd210e727111677c4f7b57221f4754cf60218be980b31d482c1e9a24adaed853e098ad4f2a14ce8a8e1523c07121285746d23fc39035de18650fd1
+EBUILD mathmod-4.1-r1.ebuild 1054 SHA256 1219d9c9037b4b5e3a7d6e55d32134ecfd086640d1b65511d831f2117e4ef684 SHA512 4b49f4b769888e93d334f4a6e5fac8b9d4351f78bd2584dccbe6809932d70c56bc66efd3ad8e01b373be25771bf134f47124bbd4026b2a9b008ee18373de9d9c WHIRLPOOL 9100b216d02cd796ec8cd9bf29aaebca3be5129ef552315d0d7689b39a8cc1650b8e8d0c8a80e42b6a7abe9059227096c8aed297552551755903d5c534751521
+MISC ChangeLog 502 SHA256 8966cd8ac194200df42ced136540f0c4cc583bf4138c503e6ec2b5ba4ca74e21 SHA512 6c29be6c3f7333290394d3f2fd7040559bc6b51f08f7ee4c6370a94da11e42f377de25a752964d160f08e87a1421635b4c7403efcd879829ac1802b053db072d WHIRLPOOL 8f8101be2617a8609cde1bb19093c7ea1f95e36df6b0ebf9cfebfe812a99e7fc3a1177de35bf284b8e08027d7d964b9a5d62fd1c5ed8f0e56d39844b38186b22
+MISC metadata.xml 788 SHA256 02c71d9dd807fb2abda67a561dcda291de42623f6081f97f09f342074ae22750 SHA512 86fb2e6a83ab651507e2089996e48961ce48f602b603b10dfd2e62f45d99a4bb6ec2c2d3e05a1928f4c13acf1404ea65fb37046f01ecfe8fdbd13d3e1c34fbd2 WHIRLPOOL 7710e01afe253e8755d677f5c60e830d0f14386aca931b328dad19d0041a55ab3860180b17c638e2aa33cb5cf03208a6dc7b742cd4ec0eb92b9c34e1f0732b4d
diff --git a/sci-mathematics/mathmod/mathmod-4.1-r1.ebuild b/sci-mathematics/mathmod/mathmod-4.1-r1.ebuild
new file mode 100644
index 000000000000..bdfb57706c69
--- /dev/null
+++ b/sci-mathematics/mathmod/mathmod-4.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnome2-utils qmake-utils fdo-mime
+
+DESCRIPTION="Plot parametric and implicit surfaces"
+HOMEPAGE="https://www.facebook.com/pages/MathMod/529510253833102"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.zip"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtwidgets:5 dev-qt/qtopengl:5"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-branches-274-trunk
+
+src_configure() {
+ eqmake5 MathMod.pro
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe MathMod
+ insinto /usr/share/${P}
+ doins mathmodconfig.js mathmodcollection.js advancedmodels.js
+ newicon -s 16 icon/catenoid_mini_16x16.png catenoid.png
+ newicon -s 32 icon/catenoid_mini_32x32.png catenoid.png
+ newicon -s 64 icon/catenoid_mini_64x64.png catenoid.png
+ make_desktop_entry MathMod MathMod catenoid
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-mathematics/mathmod/metadata.xml b/sci-mathematics/mathmod/metadata.xml
new file mode 100644
index 000000000000..1a5c54097fc1
--- /dev/null
+++ b/sci-mathematics/mathmod/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+</maintainer>
+<maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+</maintainer>
+<longdescription lang="en">
+ MathMod is a mathematical modeling software that visualize and animate
+ implicit and parametric surfaces.
+ MathMod supports: 3D and 4D plotting and animation, OBJ output file format,
+ Textue and pigmentation support, Noise and Turbulence effects support,
+ Large set of scripted examples.
+</longdescription>
+<upstream>
+ <remote-id type="sourceforge">mathmod</remote-id>
+</upstream>
+</pkgmetadata>