summaryrefslogtreecommitdiff
path: root/sci-mathematics/mathlib-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
commitf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (patch)
tree66ba5228853030737ae2dd9c9894b96266213246 /sci-mathematics/mathlib-tools
parent1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (diff)
gentoo auto-resync : 30:11:2022 - 01:22:10
Diffstat (limited to 'sci-mathematics/mathlib-tools')
-rw-r--r--sci-mathematics/mathlib-tools/Manifest2
-rw-r--r--sci-mathematics/mathlib-tools/mathlib-tools-1.3.1.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-mathematics/mathlib-tools/Manifest b/sci-mathematics/mathlib-tools/Manifest
index 24b7c66857e7..0ea907b132ac 100644
--- a/sci-mathematics/mathlib-tools/Manifest
+++ b/sci-mathematics/mathlib-tools/Manifest
@@ -1,5 +1,7 @@
DIST mathlib-tools-1.2.0.tar.gz 33995 BLAKE2B ce1125fa786daa6292556e35dd596dfc819eab739f1dac65de4eb966873d86ab779e61372694da281123d64c36b1978afa359e2bb154cbf39cfa0f1677b5f0f6 SHA512 3691ef89ec0325d223ab56f6b09d0fd729d006a3ce6aa338e814b1cb3d014e670da6c16a52233ceb1c1dbd6f027c769f1adedfe53cbccc4be73803abf4475ae0
DIST mathlib-tools-1.3.0.tar.gz 34918 BLAKE2B 4d54922cfe5de3d6671161081c49fe82568ad90795ece8ad43e9f62c75415204e62ff1822be213ab259371e82ea869ff63195056cc415a1f376fa0a4a438fb4f SHA512 250390e55170e5a7520f34dee27c9846351a64c4157e9f4a0ec1d0d9bf6b075b09187476375a90e7df2fdab6ce7b7b51ff03f1bf28007915242811f377ce3150
+DIST mathlib-tools-1.3.1.tar.gz 34918 BLAKE2B 4d54922cfe5de3d6671161081c49fe82568ad90795ece8ad43e9f62c75415204e62ff1822be213ab259371e82ea869ff63195056cc415a1f376fa0a4a438fb4f SHA512 250390e55170e5a7520f34dee27c9846351a64c4157e9f4a0ec1d0d9bf6b075b09187476375a90e7df2fdab6ce7b7b51ff03f1bf28007915242811f377ce3150
EBUILD mathlib-tools-1.2.0.ebuild 1270 BLAKE2B 7baf88ca36131a51da25ca82d1a65160c64ae828ac6c38a0d52e5005c71f6e3aaabd4ee66b5f8e419be2510651af2655072c435b55d120cafe54fe8f22f4b517 SHA512 012afcdbe313ae81fb9e03510efdd94356f1dc1ad2662b99532d19e4d7664cfe8922440eb2fca78a8faac5cd77bc03db1ac0b6327ee4c8fa41751e0140f495c1
EBUILD mathlib-tools-1.3.0.ebuild 1339 BLAKE2B 6f6b23cbed95fb121b31d75dcbdb9a54ccff0e1ba3f7ca3dee7927b4389920a6a99f453448539728f27b9c4674549cea60e09bb22fad03ed6dc9ed65093cf7db SHA512 15dbf572c6419de5571ec6089a2d2835cbe8354815ca1efd7d9f1333bba0339f1a79b04752459640c930f54d3351880feaae46ea53031bb36531026bfc8e90d1
+EBUILD mathlib-tools-1.3.1.ebuild 1339 BLAKE2B 6f6b23cbed95fb121b31d75dcbdb9a54ccff0e1ba3f7ca3dee7927b4389920a6a99f453448539728f27b9c4674549cea60e09bb22fad03ed6dc9ed65093cf7db SHA512 15dbf572c6419de5571ec6089a2d2835cbe8354815ca1efd7d9f1333bba0339f1a79b04752459640c930f54d3351880feaae46ea53031bb36531026bfc8e90d1
MISC metadata.xml 845 BLAKE2B 8d01442128f49f1c8c0c29cf4469d775936149cdde77d7e96a6825bc631119a4e83932bc67f9e60781128f0c179ef7e622edcc9836d7fb3f4240b356e92caf8b SHA512 8add0a2a70e219d5581ef7fdcd0125ab1375c65d631093df02559e462974b07cef0bf1fe75919707be026b91e77131b24d3b197a5c332961c6a573ddf899c939
diff --git a/sci-mathematics/mathlib-tools/mathlib-tools-1.3.1.ebuild b/sci-mathematics/mathlib-tools/mathlib-tools-1.3.1.ebuild
new file mode 100644
index 000000000000..b9439cb1bcca
--- /dev/null
+++ b/sci-mathematics/mathlib-tools/mathlib-tools-1.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Development tools for Lean's mathlib"
+HOMEPAGE="https://github.com/leanprover-community/mathlib-tools"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/${PN}.git"
+else
+ H=1ce2e7143b2456867f4a671a078a4e9af3c73c11
+ SRC_URI="https://github.com/leanprover-community/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${H}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="
+ >=dev-python/GitPython-2.1.11[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.0[${PYTHON_USEDEP}]
+ dev-python/PyGithub[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${BDEPEND}
+ sci-mathematics/lean:0/3
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Remove problematic tests (mainly issues with network)
+ rm ./tests/test_functional.py || die
+
+ distutils-r1_python_prepare_all
+}