summaryrefslogtreecommitdiff
path: root/sci-mathematics/mathlib-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-26 02:51:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-26 02:51:21 +0100
commitea6ec22f536553dcd417bc8b577418d3ebe5ce4c (patch)
tree318c03426d27d596f62898b46d48f5f6af2b070e /sci-mathematics/mathlib-tools
parent1ab3970274a99b42f555ca7959efe9ace063abd5 (diff)
gentoo auto-resync : 26:08:2022 - 02:51:21
Diffstat (limited to 'sci-mathematics/mathlib-tools')
-rw-r--r--sci-mathematics/mathlib-tools/Manifest2
-rw-r--r--sci-mathematics/mathlib-tools/mathlib-tools-1.1.2.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-mathematics/mathlib-tools/Manifest b/sci-mathematics/mathlib-tools/Manifest
index 49b13fc3a289..dc5eb1b20c3c 100644
--- a/sci-mathematics/mathlib-tools/Manifest
+++ b/sci-mathematics/mathlib-tools/Manifest
@@ -1,5 +1,7 @@
DIST mathlib-tools-1.1.0.tar.gz 32374 BLAKE2B f470927cae1dc66478efd44de6a5fd7c8df9656351ee342d14a1e75e8774383616cedf01b21ef1b92220fb03b1f1ccb326e3363dd0fec4fb5876f43c5ddb4010 SHA512 bc59d2e41c42ecc22c5768ac3adb209f0b170e2e97fe68483d8518b78a6b4fa163c1d46e4e3996c6f3e0aaa329c642fd111b3e16d850f40b6edc81c81215d03f
DIST mathlib-tools-1.1.1.tar.gz 32456 BLAKE2B 2cb81a6072aecc8a9c298c8bd0ac2edc7f44fecd290add5254a0c35b5e16fca4cfef32727acff883366d99101f7e62ad12709e59b317e34547fa49c404600366 SHA512 17e6105d48071ab41aaa436d3fd35774227b242e6026b30ac82fd0b4f7ea8310a9bc0abe6abe5eca3e77ec62d6a48e7584222381dc7071803215cc3189ce973b
+DIST mathlib-tools-1.1.2.tar.gz 32477 BLAKE2B d49d8b05974b70db52e55dea7fdd91f82b05266a6ab2db50e12963b1d9991500088d4aa897a65c391b82e0996d57f5cad5ade8cc85ae85fccb0a03ed63a2f2c8 SHA512 2c0d4faa7a7610f16eca539f1ee369a18ffb6b947bd0ac55983dee8b651c258b9d1819d066dafcfdaf23e612c6e9fb7a3239ccb0b6ca5e51dabcc761bf9b815a
EBUILD mathlib-tools-1.1.0-r1.ebuild 1245 BLAKE2B 543109635a01058d7b49271efcc17288d9502d77cafd2e3bda97f23b710fdd3adce018988e757ff63168df5fe6b11a062f7ffbb12ed6fec29f7f295b5b589717 SHA512 9cf8558b5c565dcc93c535ce91047eeafcb6a4ff24a1fda339721c7bb3afcf57b33a57dc27906afec12bab3af553d4fe73572c150e54d4f0b5332cd71a3a1c5f
EBUILD mathlib-tools-1.1.1.ebuild 1245 BLAKE2B 543109635a01058d7b49271efcc17288d9502d77cafd2e3bda97f23b710fdd3adce018988e757ff63168df5fe6b11a062f7ffbb12ed6fec29f7f295b5b589717 SHA512 9cf8558b5c565dcc93c535ce91047eeafcb6a4ff24a1fda339721c7bb3afcf57b33a57dc27906afec12bab3af553d4fe73572c150e54d4f0b5332cd71a3a1c5f
+EBUILD mathlib-tools-1.1.2.ebuild 1238 BLAKE2B 52929c990d2c29de6c0cf63b1025e5e4920d859b14d23d1a01d54da67c9588347f7091d1105f721fc35421acb2e50078a0157aa29b384c3e1b938b8d6e591ac3 SHA512 5e01752e58bd8db0751585262ea0f26489cd977186f58adcd9615c832ca07274a79d062fa02c3be4cb217c8207b4a4e798d3b24f73c8b0f976cca65a0bb5df6c
MISC metadata.xml 845 BLAKE2B 8d01442128f49f1c8c0c29cf4469d775936149cdde77d7e96a6825bc631119a4e83932bc67f9e60781128f0c179ef7e622edcc9836d7fb3f4240b356e92caf8b SHA512 8add0a2a70e219d5581ef7fdcd0125ab1375c65d631093df02559e462974b07cef0bf1fe75919707be026b91e77131b24d3b197a5c332961c6a573ddf899c939
diff --git a/sci-mathematics/mathlib-tools/mathlib-tools-1.1.2.ebuild b/sci-mathematics/mathlib-tools/mathlib-tools-1.1.2.ebuild
new file mode 100644
index 000000000000..bc7818d3db62
--- /dev/null
+++ b/sci-mathematics/mathlib-tools/mathlib-tools-1.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Development tools for Lean's mathlib"
+HOMEPAGE="https://github.com/leanprover-community/mathlib-tools"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/${PN}.git"
+else
+ SRC_URI="https://github.com/leanprover-community/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="
+ >=dev-python/GitPython-2.1.11[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.0[${PYTHON_USEDEP}]
+ dev-python/PyGithub[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${BDEPEND}
+ sci-mathematics/lean:0/3
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Remove problematic tests (mainly issues with network)
+ rm ./tests/test_functional.py || die
+
+ distutils-r1_python_prepare_all
+}