summaryrefslogtreecommitdiff
path: root/sci-mathematics/mathlib-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-mathematics/mathlib-tools
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-mathematics/mathlib-tools')
-rw-r--r--sci-mathematics/mathlib-tools/Manifest3
-rw-r--r--sci-mathematics/mathlib-tools/mathlib-tools-1.1.0.ebuild49
-rw-r--r--sci-mathematics/mathlib-tools/metadata.xml19
3 files changed, 71 insertions, 0 deletions
diff --git a/sci-mathematics/mathlib-tools/Manifest b/sci-mathematics/mathlib-tools/Manifest
new file mode 100644
index 000000000000..a8c5fe76b9bb
--- /dev/null
+++ b/sci-mathematics/mathlib-tools/Manifest
@@ -0,0 +1,3 @@
+DIST mathlib-tools-1.1.0.tar.gz 32374 BLAKE2B f470927cae1dc66478efd44de6a5fd7c8df9656351ee342d14a1e75e8774383616cedf01b21ef1b92220fb03b1f1ccb326e3363dd0fec4fb5876f43c5ddb4010 SHA512 bc59d2e41c42ecc22c5768ac3adb209f0b170e2e97fe68483d8518b78a6b4fa163c1d46e4e3996c6f3e0aaa329c642fd111b3e16d850f40b6edc81c81215d03f
+EBUILD mathlib-tools-1.1.0.ebuild 1241 BLAKE2B 7b636b9be79404b2f46e7d3a5eb0d501a0267cdd00e84963eafd1ccaf91c343aefc93b2ae17b1662cf3d3ccbabbcb2be38d6bbf823122238d4264e14aaba1f8b SHA512 b695d4886cb7b36c944c40153d1ae1bf8e80ece5aa6c0c8e70be0d1b421dc5dad144089991d239d6957c8f50dd2a746a588add440c15af1e74565399135a984c
+MISC metadata.xml 722 BLAKE2B eee8161a95d29fb43a6f3666206d16170f54238815d8caae3f451e6371282ac18900a7233dc0d82946b9ad0b207eb64293dd62f60ce1ac2f0883d237d43e3c73 SHA512 ffded3693ba0e928312e37a5572a5ddf8a4d61d5c4fb04a6ba0d7ec200e2aa05e7f317557eed958b422b51114470668fc5f3ab9b52605ce7f3b7de878f81b9a1
diff --git a/sci-mathematics/mathlib-tools/mathlib-tools-1.1.0.ebuild b/sci-mathematics/mathlib-tools/mathlib-tools-1.1.0.ebuild
new file mode 100644
index 000000000000..ce6f9c8adf9e
--- /dev/null
+++ b/sci-mathematics/mathlib-tools/mathlib-tools-1.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_{8,9})
+
+inherit distutils-r1
+
+DESCRIPTION="Development tools for Lean's mathlib"
+HOMEPAGE="https://github.com/leanprover-community/mathlib-tools"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/${PN}.git"
+else
+ SRC_URI="https://github.com/leanprover-community/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ >=dev-python/GitPython-2.1.11[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.0[${PYTHON_USEDEP}]
+ dev-python/PyGithub[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ sci-mathematics/lean:0/3
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Remove problematic tests (mainly issues with network)
+ rm ./tests/test_functional.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/sci-mathematics/mathlib-tools/metadata.xml b/sci-mathematics/mathlib-tools/metadata.xml
new file mode 100644
index 000000000000..f91e58a755f7
--- /dev/null
+++ b/sci-mathematics/mathlib-tools/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package contains leanproject, a supporting tool for Lean mathlib.
+ More info:
+ - https://leanprover-community.github.io/toolchain.html#handling-dependencies
+ - https://leanprover-community.github.io/leanproject.html
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/leanprover-community/mathlib-tools/issues</bugs-to>
+ <remote-id type="github">leanprover-community/mathlib-tools</remote-id>
+ </upstream>
+</pkgmetadata>