summaryrefslogtreecommitdiff
path: root/sci-mathematics/mathematica
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-17 04:04:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-17 04:04:27 +0100
commit8796aaedb3257bbe4d80b0033408b2210b2259d6 (patch)
tree1ffee2ca4a87bd5dba43077259c000f9086fbfc8 /sci-mathematics/mathematica
parent61a1cada8ceb208845fa604b982216b0a7b099cb (diff)
gentoo auto-resync : 17:10:2024 - 04:04:26
Diffstat (limited to 'sci-mathematics/mathematica')
-rw-r--r--sci-mathematics/mathematica/Manifest1
-rw-r--r--sci-mathematics/mathematica/mathematica-10.3.1-r2.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/sci-mathematics/mathematica/Manifest b/sci-mathematics/mathematica/Manifest
index 63594b61404d..38f127762382 100644
--- a/sci-mathematics/mathematica/Manifest
+++ b/sci-mathematics/mathematica/Manifest
@@ -12,6 +12,7 @@ DIST Mathematica_14.0.0_BNDL_LINUX.sh 6362499931 BLAKE2B d5c4df6e556c970103f0736
DIST Mathematica_14.0.0_LINUX.sh 2175783771 BLAKE2B ceb6e0d9ee8ef5c548c5dcf5d426ff1678c039a66da3936e69cadb91c24102163be253a63af528fedc37ce87f9fd2617958934479ed570955a14a2b2980d5a0e SHA512 83c02183e892a3a5a9b2b6db4010b763b50b30ac8d9417ceb1256b3dd7d78ecbad132b7fcd7c797a64536b64e5894f54341379c4c599420faff5857bd0f22390
DIST WLDocs_13.1.0_LINUX.sh 3546448755 BLAKE2B e5dbf6bf9cd60a313329df8591c281215039d7efa7c83a53f3b2d4e176765b62efae3ff04628ecf6905e76bbaf6867e87c96bd6188d13df2b981bea5a633335a SHA512 2107b37b30fc76974d040e746ca26ddb5df23bbacb9d8fabcd546a7cf789f1daaf70179c53890bed2385430665f601fbbc1f9829bf64f61068909ea8774f91d2
EBUILD mathematica-10.3.1-r1.ebuild 2821 BLAKE2B 958869840413f275d50272636693c776ac399cc14401d21d8709aab81ec23f396b0407618b787a4c04fe5a70327c604bef81735f6fcdeb8cbbaf6b74cf387172 SHA512 ac52970098b31e2e1a72d50dffc0db3cfe67c68eed8272b1d78febe5e47eb514b333c23a9c5f7030bb606f937106b5a237818d9ab829779533e33f5459d2aeb2
+EBUILD mathematica-10.3.1-r2.ebuild 2878 BLAKE2B ce97d8f961e2fa5084a9f672def094f7549095c556929a1304703ab53163373cafccb6e4537df6e6969bd5c18cdb2525d49a342eaa029e84146d4b76635a928a SHA512 e3d3c1264ad780e604894378fd3d1b552d6384c1c47384b88aef1ef065071a47991eed4cb2def79412a479f277038bfc654c3b282347aae93fdfd0ec07c2e20e
EBUILD mathematica-12.1.0.ebuild 3134 BLAKE2B 4a8f269cfb1d77dd941dfab8c56dc310306aea75fd6d676f2e79a1208420c25161afef7e253c101763d57a441480403580dbb62b31b420f6dbce3f7cfa786fc8 SHA512 cf14b8567a9dc6bd7f19447cb9d277c929084abf20bf073c4d9aa049e1795ddba0862f43340bfbb37d2633d84e7b5adfe4a3123554fd62bc55c018394177a2ee
EBUILD mathematica-12.1.1-r1.ebuild 3134 BLAKE2B 4a8f269cfb1d77dd941dfab8c56dc310306aea75fd6d676f2e79a1208420c25161afef7e253c101763d57a441480403580dbb62b31b420f6dbce3f7cfa786fc8 SHA512 cf14b8567a9dc6bd7f19447cb9d277c929084abf20bf073c4d9aa049e1795ddba0862f43340bfbb37d2633d84e7b5adfe4a3123554fd62bc55c018394177a2ee
EBUILD mathematica-12.2.0.ebuild 3135 BLAKE2B 782b070347eea963fc8e59799f2b971649014518947cbd0f0b8a602d7c2f7fad3aaf1b66ada9db3e20ff255a833cf8909a5a819912ddf6f7a72bc85440221089 SHA512 6e8348a8b7fdde48be0ee851ecf89445dffad1d63ece74485c04404c662384f72fad918278ffd88893e3b1ec5084c6a4072b6f9b1e8d71babe8abe59383ff480
diff --git a/sci-mathematics/mathematica/mathematica-10.3.1-r2.ebuild b/sci-mathematics/mathematica/mathematica-10.3.1-r2.ebuild
new file mode 100644
index 000000000000..510ff88f5a6e
--- /dev/null
+++ b/sci-mathematics/mathematica/mathematica-10.3.1-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop multilib xdg
+
+DESCRIPTION="Wolfram Mathematica"
+SRC_URI="Mathematica_${PV}_LINUX.sh"
+HOMEPAGE="https://www.wolfram.com/mathematica/"
+
+LICENSE="all-rights-reserved"
+KEYWORDS="-* ~amd64"
+SLOT="0"
+IUSE="+doc"
+
+RESTRICT="strip mirror bindist fetch"
+
+DEPEND=""
+
+# Mathematica comes with a lot of bundled stuff. We should place here only what we
+# explicitly override with LD_PRELOAD.
+RDEPEND="
+ media-libs/freetype
+ media-libs/harfbuzz
+"
+
+# we need this a few times
+MPN="Mathematica"
+MPV=$(ver_cut 1-2)
+M_BINARIES="MathKernel Mathematica MathematicaScript WolframKernel WolframScript math mathematica mcc wolfram"
+M_TARGET="opt/Wolfram/${MPN}/${MPV}"
+
+# we might as well list all files in all QA variables...
+QA_PREBUILT="opt/*"
+
+S=${WORKDIR}
+
+src_unpack() {
+ /bin/sh "${DISTDIR}/${A}" --nox11 --confirm -- -auto "-targetdir=${S}/${M_TARGET}" "-execdir=${S}/opt/bin" || die
+}
+
+src_install() {
+ local ARCH='-x86-64'
+
+ einfo 'Removing MacOS- and Windows-specific files'
+ find AddOns SystemFiles -type d -\( -name Windows -o -name Windows-x86-64 \
+ -o -name MacOSX -o -name MacOSX-x86-64 -\) -delete
+
+ if ! use doc; then
+ einfo "Removing documentation"
+ rm -r "${S}/${M_TARGET}/Documentation"
+ fi
+
+ # move all over
+ mv "${S}"/opt "${D}"/opt || die
+
+ # the autogenerated symlinks point into sandbox, remove
+ rm "${D}"/opt/bin/* || die
+
+ # install wrappers instead
+ for name in ${M_BINARIES} ; do
+ einfo "Generating wrapper for ${name}"
+ echo '#!/bin/sh' >> "${T}/${name}"
+ echo "LD_PRELOAD=/usr/$(get_libdir)/libharfbuzz.so.0:/usr/$(get_libdir)/libfreetype.so.6:/$(get_libdir)/libz.so.1 /${M_TARGET}/Executables/${name} \$*" \
+ >> "${T}/${name}"
+ dobin "${T}/${name}"
+ done
+ for name in ${M_BINARIES} ; do
+ einfo "Symlinking ${name} to /opt/bin"
+ dosym ../../usr/bin/${name} /opt/bin/${name}
+ done
+
+ # fix some embedded paths and install desktop files
+ for filename in $(find "${D}/${M_TARGET}/SystemFiles/Installation" -name "wolfram-mathematica.desktop") ; do
+ echo Fixing "${filename}"
+ sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}"
+ echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}"
+ domenu "${filename}"
+ done
+
+ # install mime types
+ insinto /usr/share/mime/application
+ for filename in $(find "${D}/${M_TARGET}/SystemFiles/Installation" -name "application-*.xml"); do
+ basefilename=$(basename "${filename}")
+ mv "${filename}" "${T}/${basefilename#application-}"
+ doins "${T}/${basefilename#application-}"
+ done
+}
+
+pkg_nofetch() {
+ einfo "Please place the Wolfram Mathematica installation file ${SRC_URI}"
+ einfo "in your \$\{DISTDIR\}."
+ einfo "Note that to actually run and use Mathematica you need a valid license."
+ einfo "Wolfram provides time-limited evaluation licenses at ${HOMEPAGE}"
+}