summaryrefslogtreecommitdiff
path: root/sci-mathematics/lrcalc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-mathematics/lrcalc
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-mathematics/lrcalc')
-rw-r--r--sci-mathematics/lrcalc/Manifest4
-rw-r--r--sci-mathematics/lrcalc/files/lrcalc-1.2-includes.patch90
-rw-r--r--sci-mathematics/lrcalc/lrcalc-1.2.ebuild25
-rw-r--r--sci-mathematics/lrcalc/metadata.xml24
4 files changed, 143 insertions, 0 deletions
diff --git a/sci-mathematics/lrcalc/Manifest b/sci-mathematics/lrcalc/Manifest
new file mode 100644
index 000000000000..91b9a29857bc
--- /dev/null
+++ b/sci-mathematics/lrcalc/Manifest
@@ -0,0 +1,4 @@
+AUX lrcalc-1.2-includes.patch 1939 BLAKE2B 37dc25d9219899cf9cd6268038715b927af294135f1acbebf5651fdfdcb50f7b041e53464c36f572201be411941d889b5ef7c1a20e31eda9915339ec378faf0b SHA512 d5ad549ddf23609870f6b15e389323bf26ea2c981c4af28c93dae7f70b4f7c96e242011213acb7c138ba9acc0ce0bc0c41d51d3fccf4cc5de331a12d965a46a6
+DIST lrcalc-1.2.tar.gz 363120 BLAKE2B d3f652abfe38e81331dcbac7068d087b198445bf02dc5ccb5bcbd76b9bbc329687209e6ccf40ecd09f166e7d2da054edd0e5c2b18503d8e4d961ae4ad91b5152 SHA512 699f4c2ddabe5879542d5c11f3df3979a4e009ad37741711a70fb48b4a0d4a7969e5bb110adb63d4473f3c2b61d1efdb7228a6b74c5dd7e1b5aea8cf1d170fab
+EBUILD lrcalc-1.2.ebuild 603 BLAKE2B 0e1121947537a15a4577228087eb5b91275afa58446ecb44a3aa37cc045a4e1d827f8aed3015803a9bb7f47e336e221030a272dc1c9585e35671fd9562562eea SHA512 06011d08163b707f3ac5d472fa58d713d97180542d0ab76683fc791d0f2774b4c9d559a2b909f16545886e5864a52d63bd6597a9e070b42fd576e5278e95201e
+MISC metadata.xml 834 BLAKE2B d230c80d9552789e93a2f2cc9e1a8eac968d4762ceeba6103f92676cb709d45bf39b2b6820e889d11ad30c60493aec84076d8ee3f5f038640038655f3e2c5a07 SHA512 f54cc63235625646117f0d569fb69c3b3b66b5508fb65a65a3fb92811ff44f72df7546d44728f5882d2db9b70520036ccfda05cb58d9cf9dd3164132dbebbc57
diff --git a/sci-mathematics/lrcalc/files/lrcalc-1.2-includes.patch b/sci-mathematics/lrcalc/files/lrcalc-1.2-includes.patch
new file mode 100644
index 000000000000..707da176a60f
--- /dev/null
+++ b/sci-mathematics/lrcalc/files/lrcalc-1.2-includes.patch
@@ -0,0 +1,90 @@
+From 4a5e1c8c3c11efdb1cbb4239825a6bf4bf1c52f8 Mon Sep 17 00:00:00 2001
+From: Anders Skovsted Buch <asbuch@math.rutgers.edu>
+Date: Sun, 29 Nov 2015 16:25:56 -0500
+Subject: [PATCH] Patch by Jeroen Demeyer to change include <vector.h> to
+ "vector.h", plus similar cases.
+
+---
+ src/lrcalc.c | 2 +-
+ src/maple.c | 4 ++--
+ src/schublib.h | 2 +-
+ src/symfcn.c | 6 +++---
+ src/symfcn.h | 4 ++--
+ 5 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/src/lrcalc.c b/src/lrcalc.c
+index aff3f75..60df49e 100644
+--- a/src/lrcalc.c
++++ b/src/lrcalc.c
+@@ -8,7 +8,7 @@
+ #include <stdlib.h>
+ extern char *optarg;
+
+-#include <vectarg.h>
++#include "vectarg.h"
+
+ #include "symfcn.h"
+ #include "maple.h"
+diff --git a/src/maple.c b/src/maple.c
+index fdc0768..a5f4d14 100644
+--- a/src/maple.c
++++ b/src/maple.c
+@@ -4,8 +4,8 @@
+ */
+
+ #include <stdio.h>
+-#include <vector.h>
+-#include <hashtab.h>
++#include "vector.h"
++#include "hashtab.h"
+ #include "maple.h"
+
+
+diff --git a/src/schublib.h b/src/schublib.h
+index a8e8511..864850c 100644
+--- a/src/schublib.h
++++ b/src/schublib.h
+@@ -1,7 +1,7 @@
+ #ifndef _SCHUBLIB_H
+ #define _SCHUBLIB_H
+
+-#include <hashtab.h>
++#include "hashtab.h"
+
+ hashtab *trans(vector *w, int vars, hashtab *res);
+ hashtab *monk(int i, hashtab *slc, int rank);
+diff --git a/src/symfcn.c b/src/symfcn.c
+index 4ffbe4b..fd5df5d 100644
+--- a/src/symfcn.c
++++ b/src/symfcn.c
+@@ -5,9 +5,9 @@
+
+ #include <stdio.h>
+
+-#include <alloc.h>
+-#include <vector.h>
+-#include <hashtab.h>
++#include "alloc.h"
++#include "vector.h"
++#include "hashtab.h"
+
+ #include "symfcn.h"
+
+diff --git a/src/symfcn.h b/src/symfcn.h
+index b8543b1..29bb00d 100644
+--- a/src/symfcn.h
++++ b/src/symfcn.h
+@@ -1,8 +1,8 @@
+ #ifndef _SYMFCN_H
+ #define _SYMFCN_H
+
+-#include <hashtab.h>
+-#include <vector.h>
++#include "hashtab.h"
++#include "vector.h"
+
+ int part_itr_sz(vector *part);
+ int part_itr_sub(vector *part, vector *outer);
+--
+2.1.1.1.g1fb337f
+
diff --git a/sci-mathematics/lrcalc/lrcalc-1.2.ebuild b/sci-mathematics/lrcalc/lrcalc-1.2.ebuild
new file mode 100644
index 000000000000..9039de904cd1
--- /dev/null
+++ b/sci-mathematics/lrcalc/lrcalc-1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Littlewood-Richardson Calculator"
+HOMEPAGE="https://sites.math.rutgers.edu/~asbuch/lrcalc/"
+SRC_URI="https://sites.math.rutgers.edu/~asbuch/lrcalc/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}/${PN}-1.2-includes.patch" )
+
+src_configure(){
+ econf $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-mathematics/lrcalc/metadata.xml b/sci-mathematics/lrcalc/metadata.xml
new file mode 100644
index 000000000000..c070753f1162
--- /dev/null
+++ b/sci-mathematics/lrcalc/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The "Littlewood-Richardson Calculator" is a package of C and Maple
+ programs for computing Littlewood-Richardson coefficients
+ </longdescription>
+</pkgmetadata>