summaryrefslogtreecommitdiff
path: root/sci-mathematics/lrcalc/lrcalc-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /sci-mathematics/lrcalc/lrcalc-2.1.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'sci-mathematics/lrcalc/lrcalc-2.1.ebuild')
-rw-r--r--sci-mathematics/lrcalc/lrcalc-2.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-mathematics/lrcalc/lrcalc-2.1.ebuild b/sci-mathematics/lrcalc/lrcalc-2.1.ebuild
new file mode 100644
index 000000000000..194251793e74
--- /dev/null
+++ b/sci-mathematics/lrcalc/lrcalc-2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Littlewood-Richardson Calculator"
+HOMEPAGE="https://sites.math.rutgers.edu/~asbuch/lrcalc/"
+SRC_URI="https://sites.math.rutgers.edu/~asbuch/lrcalc/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}