summaryrefslogtreecommitdiff
path: root/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild')
-rw-r--r--sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild b/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild
new file mode 100644
index 000000000000..dd828ca40d5a
--- /dev/null
+++ b/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="Mixed Integer Linear Programming (MILP) solver"
+HOMEPAGE="https://sourceforge.net/projects/lpsolve/"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="sci-libs/colamd"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_install() {
+ default
+ # required because it does not provide .pc file
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}