summaryrefslogtreecommitdiff
path: root/sci-mathematics/libpoly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 01:49:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 01:49:56 +0000
commit30be4d7d2806b014770312920fcda743d4dc67d0 (patch)
tree229c7337dfd56654c52009367273c078b016a25c /sci-mathematics/libpoly
parentf287ecad888abdeb38e617d0485de282cd6819db (diff)
gentoo auto-resync : 20:12:2022 - 01:49:56
Diffstat (limited to 'sci-mathematics/libpoly')
-rw-r--r--sci-mathematics/libpoly/Manifest2
-rw-r--r--sci-mathematics/libpoly/libpoly-0.1.11.ebuild8
2 files changed, 9 insertions, 1 deletions
diff --git a/sci-mathematics/libpoly/Manifest b/sci-mathematics/libpoly/Manifest
index 9ad5a5691b87..76d1fdeec31b 100644
--- a/sci-mathematics/libpoly/Manifest
+++ b/sci-mathematics/libpoly/Manifest
@@ -1,3 +1,3 @@
DIST libpoly-0.1.11.tar.gz 614216 BLAKE2B 42a2510a6a9f94e7170b5df97ec8f2b7b29cb9c95bd13c8c7abebc9e7db7fedcbeb7a928f22d173e154180acc199e081323d2f1cb23264bf31ac1bfc88494dc8 SHA512 df08a6bab33e27023316972e2496801cea4959faf403b5df8314fa45b4541cd1352583a44084bea130c1e3ca4ed86de032f7f96eeb915599f178e80976a68f7a
-EBUILD libpoly-0.1.11.ebuild 1240 BLAKE2B eb73ef53ad5ba372b2d03d6bfb8e8b98821444ada7f479d743f69c2d65bf0b039dc7615bea6a65a53a74421d590020954b1b3cf52113eb8cb9487c1660ff30ed SHA512 5a3dd9137eba45c30f803216d9fe3c5b7ef760ba1d9a00ac3326e0fa19a1fe1191213516c4244f33fd5cb4ac20d831a26a9acf6182b3edbcf3b2e3fefc09ae75
+EBUILD libpoly-0.1.11.ebuild 1421 BLAKE2B 56fa4866c26affeb27a3b4f913377b41358d4bfa4f75fca8069423da9497a3c4f70fb53fe4f79fb82ec19420b6fc006bab5932dac5b9e419a54f5b11124829d0 SHA512 309118568aca55b3f2b55c1c7342333e3b589a429f00150e973739bf704d6ac8d21352a01618300b0eb7d27a5c54152d43ed35b27551f53e2971c74aaf36bb8a
MISC metadata.xml 757 BLAKE2B baf8c7cb139dff0a4fd382eee7583f5f921209ffcddcac77a85086bb5214bc24bc875343f4f4f363e3e72e8077361e2864419c05c28338df4e9dd80b5dc4ce97 SHA512 0d9b28c2900d806f2b4df86eb69e9a3c1491a564559d80fdf78fa77673634a1735a391beb89599caea26f3af1a22880cb91e0611297e9fa811e85495eb12ff02
diff --git a/sci-mathematics/libpoly/libpoly-0.1.11.ebuild b/sci-mathematics/libpoly/libpoly-0.1.11.ebuild
index e3b8fb247367..09b57d07fe96 100644
--- a/sci-mathematics/libpoly/libpoly-0.1.11.ebuild
+++ b/sci-mathematics/libpoly/libpoly-0.1.11.ebuild
@@ -34,6 +34,14 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
}
+src_prepare() {
+ sed -i "s| -Werror||g" \
+ "${S}"/src/CMakeLists.txt \
+ "${S}"/test/polyxx/CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DLIBPOLY_BUILD_PYTHON_API=$(usex python)