summaryrefslogtreecommitdiff
path: root/sci-mathematics/lean
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /sci-mathematics/lean
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'sci-mathematics/lean')
-rw-r--r--sci-mathematics/lean/Manifest2
-rw-r--r--sci-mathematics/lean/lean-3.37.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-mathematics/lean/Manifest b/sci-mathematics/lean/Manifest
index a54e94d036a1..356a56321b13 100644
--- a/sci-mathematics/lean/Manifest
+++ b/sci-mathematics/lean/Manifest
@@ -1,5 +1,7 @@
AUX lean-CMakeLists-fix_flags.patch 1285 BLAKE2B 0507e553c1acf2a53c5267932127117d5ae5ba9015a08c88748b3d82c041f8d904d15cd033dd7934ac55c474fa75a5d4a46f680cc887fee37c05c3f5f3832839 SHA512 11a5918847e45aac7bf79e48d8f881ef5cd3e6b09dbb0979f3f0b88fd36458be21ebeb530158da801399a0cdc8fe382444ff338cd793cd9f1bfced90c5d5a71b
DIST lean-3.35.1.tar.gz 1872461 BLAKE2B 44635b05a7e8ea89522dfb44b8f097ec530419ab79a5413648292ca34019ca744ae3e327cf3a7c627cb7a7a682cfcb2ffc5e6802f2c5ad67e0a7abc303624a3c SHA512 24238cd9e920042f5bf7ba0a121da860e7e9c804d169c888bfabbc5e79e55f556a8920fab0c1a7e72b13501798c5f3fcb068f1705a0cf230f2b89abe1b3045ab
+DIST lean-3.37.0.tar.gz 1875569 BLAKE2B 26d2513da35f0fa7efa6a9bb7706884b95666079e1c0d4349f2745a5908417c0b3d01027901425bf6bc4affdb314a79235c52bac9395bd9e54d53930e6b0dbe0 SHA512 c28139cfff7b40785ab51a9591964adc473f28d7a9877d891a132737c165ce6649924e6c75905442632452b9447c095aae830df347492bae058215d3392a7c09
EBUILD lean-3.35.1-r2.ebuild 1773 BLAKE2B 15392079ec1e4d9eec5dfd9ee13fee05eca98fb2d7fe204a05b793b06588848c339dbb3b01c8c84f30fc45acc2ce8bb74be5841b9aa216a3d5f2d42d3158b7a6 SHA512 89f983bdb770e0fdbbcbd4db2a1bc8de25df33050ed936748788695e4926588471e8963289ef5bd397748abc41aae656f5614f3317b05b70f54dcd43189464d1
+EBUILD lean-3.37.0.ebuild 1773 BLAKE2B 6a332c70ff4fe6731391d180909c732976385466dc28add08014be98e84dd0c7a36a56349516099f6b16966bf70e03d3bf1b19633d9e54c054d2adbb4b9d12e8 SHA512 7601871b46ee585037c8c7600ebf3f4166004314cae3062b3a70838920f0199f5ba4570daa8f1b051a1aa7390e9a9986a0e553088e0a39b1ac45e884bc1ed18a
EBUILD lean-3.9999.ebuild 1773 BLAKE2B 15392079ec1e4d9eec5dfd9ee13fee05eca98fb2d7fe204a05b793b06588848c339dbb3b01c8c84f30fc45acc2ce8bb74be5841b9aa216a3d5f2d42d3158b7a6 SHA512 89f983bdb770e0fdbbcbd4db2a1bc8de25df33050ed936748788695e4926588471e8963289ef5bd397748abc41aae656f5614f3317b05b70f54dcd43189464d1
MISC metadata.xml 672 BLAKE2B 60612895864a164fce242ff1daa5390444c74fbb56fbc062c5448a2770ecab1048d67ce672ff543bab7b410eae118fa9fb087319e724a60437b4da2d8638e40d SHA512 2496062c9db3c2d1c9467b00fe20c0618df8cbdce2799dfdabd6c4fda4b5393bd49392c438fa81f07330fbf1aec3556b369f0fa88acff44e65b0c2cee8e94ea7
diff --git a/sci-mathematics/lean/lean-3.37.0.ebuild b/sci-mathematics/lean/lean-3.37.0.ebuild
new file mode 100644
index 000000000000..e47a48054580
--- /dev/null
+++ b/sci-mathematics/lean/lean-3.37.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR=$(ver_cut 1)
+CMAKE_IN_SOURCE_BUILD="ON"
+
+inherit cmake optfeature readme.gentoo-r1
+
+DESCRIPTION="The Lean Theorem Prover"
+HOMEPAGE="https://leanprover-community.github.io/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/lean.git"
+else
+ SRC_URI="https://github.com/leanprover-community/lean/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}/lean-${PV}/src"
+
+LICENSE="Apache-2.0"
+SLOT="0/${MAJOR}"
+IUSE="debug +json +threads"
+
+RDEPEND="dev-libs/gmp:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-CMakeLists-fix_flags.patch" )
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug; then
+ CMAKE_BUILD_TYPE="Debug"
+ else
+ CMAKE_BUILD_TYPE="Release"
+ fi
+
+ local mycmakeargs=(
+ -DALPHA=ON
+ -DAUTO_THREAD_FINALIZATION=ON
+ -DJSON=$(usex json)
+ -DLEAN_EXTRA_CXX_FLAGS="${CXXFLAGS}"
+ -DMULTI_THREAD=$(usex threads)
+ -DUSE_GITHASH=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # Disable problematic "style_check" cpplint test,
+ # this also removes the python test dependency
+ --exclude-regex style_check
+ )
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ local DISABLE_AUTOFORMATTING="yes"
+ local DOC_CONTENTS="You probably want to use lean with mathlib, you can either:
+ - Do not install mathlib globally and use local versions
+ - Use leanproject from sci-mathematics/mathlib-tools
+ $ leanproject global-install
+ - Use leanpkg and compile mathlib (which will take some time)
+ $ leanpkg install https://github.com/leanprover-community/mathlib"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}