summaryrefslogtreecommitdiff
path: root/sci-mathematics/lcalc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /sci-mathematics/lcalc
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'sci-mathematics/lcalc')
-rw-r--r--sci-mathematics/lcalc/Manifest3
-rw-r--r--sci-mathematics/lcalc/lcalc-2.0.1.ebuild31
-rw-r--r--sci-mathematics/lcalc/metadata.xml37
3 files changed, 71 insertions, 0 deletions
diff --git a/sci-mathematics/lcalc/Manifest b/sci-mathematics/lcalc/Manifest
new file mode 100644
index 000000000000..2b67c379bd2a
--- /dev/null
+++ b/sci-mathematics/lcalc/Manifest
@@ -0,0 +1,3 @@
+DIST lcalc-2.0.1.tar.xz 849260 BLAKE2B 141044939b50903f5aa631ee7ca76ed1ffc65fd0604701376b67172a8f70bcded2a9303ac3f653b20b8a05da44034f21f775dbe98f6efd38cd4097957f5f5466 SHA512 cf7210cd79dad416e3c4cdc08a6ed276d88483b8dfc425fe2ed4a1592b8a31f82ed5ec7cc7b6308ac80d44cf20e9a07484e2004bbfdeabbbabf843d24d15cc2a
+EBUILD lcalc-2.0.1.ebuild 925 BLAKE2B 3fe06e50cdd46a985d2c56ae5c98b2620a46c8fe8e546175b6d93b36ffcee179ea0dc54213e8cd93b480d8b850448b0756542dafbab5ac848712505c6c55bb40 SHA512 8069e85f186ee4d9e69e3255b206a4747acc327dc8dc432b467435243a021dcfdc96565083377ac76705613d2f11256be2689edf9ab4a837bd329de1b9bd4578
+MISC metadata.xml 1164 BLAKE2B 0b8bfe9b7d489fba6618a15f52b58a176247d656c36e985d37a67fbc53af2a3479e3b87a113e96c958235758ff88f1c1ed3905c45e74f093359fd70605b03ccf SHA512 424af9bcee1342d88f3b5ec6a4fca3bc4be9a2fda41db399526c805b73bf67896a0f0e12b876166cc72b0093b0add8764d325b387476b2bf61cb560d7b41fdce
diff --git a/sci-mathematics/lcalc/lcalc-2.0.1.ebuild b/sci-mathematics/lcalc/lcalc-2.0.1.ebuild
new file mode 100644
index 000000000000..31632d687e6c
--- /dev/null
+++ b/sci-mathematics/lcalc/lcalc-2.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command-line utility and library for L-function computations"
+HOMEPAGE="https://gitlab.com/sagemath/lcalc"
+SRC_URI="https://gitlab.com/sagemath/lcalc/uploads/01b46cdbbf3e67a322320dc0b2750d50/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+# The subslot is the libLfunction soname major version
+SLOT="0/1"
+KEYWORDS="~amd64"
+
+# Omit USE=mpfr for now because it's broken upstream:
+#
+# https://gitlab.com/sagemath/lcalc/-/issues/7
+#
+IUSE="+double double-double quad-double pari"
+REQUIRED_USE="^^ ( double double-double quad-double )"
+
+BDEPEND="dev-util/gengetopt"
+DEPEND="double-double? ( sci-libs/qd:= )
+ quad-double? ( sci-libs/qd:= )
+ pari? ( sci-mathematics/pari:= )"
+REPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with pari) \
+ --enable-precision="$(usev double)$(usev double-double)$(usev quad-double)"
+}
diff --git a/sci-mathematics/lcalc/metadata.xml b/sci-mathematics/lcalc/metadata.xml
new file mode 100644
index 000000000000..9a24558f38a7
--- /dev/null
+++ b/sci-mathematics/lcalc/metadata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="gitlab">sagemath/lcalc</remote-id>
+ </upstream>
+ <use>
+ <flag name="double">Use double precision (the upstream default)</flag>
+ <flag name="double-double">
+ Use <pkg>sci-libs/qd</pkg>for double-double precision
+ </flag>
+ <!-- Broken upstream: https://gitlab.com/sagemath/lcalc/-/issues/7
+ <flag name="multiple-precision">
+ Use <pkg>dev-libs/mpfr</pkg>for multiple precision
+ </flag>
+ -->
+ <flag name="pari">
+ Use <pkg>sci-mathematics/pari</pkg> for elliptic curve L-functions
+ </flag>
+ <flag name="quad-double">
+ Use <pkg>sci-libs/qd</pkg>for quad-double precision
+ </flag>
+ </use>
+</pkgmetadata>