summaryrefslogtreecommitdiff
path: root/sci-mathematics/lcalc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-mathematics/lcalc
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-mathematics/lcalc')
-rw-r--r--sci-mathematics/lcalc/Manifest2
-rw-r--r--sci-mathematics/lcalc/lcalc-2.0.4.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/sci-mathematics/lcalc/Manifest b/sci-mathematics/lcalc/Manifest
index 7806f02ead0b..94094fe4401c 100644
--- a/sci-mathematics/lcalc/Manifest
+++ b/sci-mathematics/lcalc/Manifest
@@ -1,3 +1,5 @@
DIST lcalc-2.0.3.tar.xz 825904 BLAKE2B c2daab62de1d5bfb024a8246a965d850480cf313efe4f0ddb7561c28d2cae2aa231fea5c07e073d21e04cfcf2b558f931472825f9100e6ab4585ac87d80b4d3a SHA512 33d7cff04d88b62775a69b5b38eea41c24bdb88592d5185fbf9c13ea0c62a7c07c041f7f4e5c06415a3983b0ba369f3c9766a556090a6282e1cd7003ad25ba46
+DIST lcalc-2.0.4.tar.xz 832620 BLAKE2B b37d9ebf2d1df88b04fba6c9834ebc977ed483ad399cdaccf5347e4aee2295e26615a0331f6386209fe87424a8444f198a9ec1173d88e741dd6f2b9246ae287c SHA512 760634a66184f4777b8849859322c4b31f4bdd9d6644a44a2129e47e2f691424b126953353273f7a57dba7236cffe4f35504bb9d03fdd152f74c7d1a48dc712c
EBUILD lcalc-2.0.3.ebuild 924 BLAKE2B 7207a3babebb5a8e47066634e85c4a9f6e03c466cd1cbf18edcdf5c022d8b387a989b9e3013e897bedaf6f553a98cce780d6daf971324ece5a8b79471b095e56 SHA512 f5d4dee6746b553ba89603659fa3581d670e7e089ff3c996718c0aa7fbfb7d3e171310fa0490a8aa55083dc50059830e2bec0e7d35d540b14f211550f12506ea
+EBUILD lcalc-2.0.4.ebuild 925 BLAKE2B ec5e4de013841a9f6d5021afab4b04ebf9db338bee06f3a43761d602883cf1d50dff493f3cfcf96575cb2f2eff95bff74d9be934478a13db609cb6e6ab37f607 SHA512 0c90b3fb1f5b782b6948af10939ca33f18d5b0ccfddd3f60ab6619abbfc750a3899c1cfc59bd62793d1e387f3019297424d38739fc66c4591c212b19ff948e34
MISC metadata.xml 1165 BLAKE2B 77544a05687fad32c18cb8d840d8de4291cae4135976bd741bbfd57a015956d5104026b99b1aec934d6a260501d89cd947e052a2ac85e35d2c93f7fc08224ac1 SHA512 cce822c8b50d97a7f8405634f565c3fbe147732db57bd66cccbaad2c2eda23076b76d0dfa442d462d55625a5dff06dde9bdf5e6ab4a9c9417d2f69972cc87add
diff --git a/sci-mathematics/lcalc/lcalc-2.0.4.ebuild b/sci-mathematics/lcalc/lcalc-2.0.4.ebuild
new file mode 100644
index 000000000000..26818c40aafb
--- /dev/null
+++ b/sci-mathematics/lcalc/lcalc-2.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command-line utility and library for L-function computations"
+HOMEPAGE="https://gitlab.com/sagemath/lcalc"
+SRC_URI="https://gitlab.com/sagemath/lcalc/uploads/4d84022aa5285414eb547121b783601a/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+# The subslot is the libLfunction soname major version
+SLOT="0/1"
+KEYWORDS="~amd64"
+
+# Omit USE=mpfr for now because it's broken upstream:
+#
+# https://gitlab.com/sagemath/lcalc/-/issues/7
+#
+IUSE="+double double-double quad-double pari"
+REQUIRED_USE="^^ ( double double-double quad-double )"
+
+BDEPEND="dev-util/gengetopt"
+DEPEND="double-double? ( sci-libs/qd:= )
+ quad-double? ( sci-libs/qd:= )
+ pari? ( sci-mathematics/pari:= )"
+REPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with pari) \
+ --enable-precision="$(usev double)$(usev double-double)$(usev quad-double)"
+}