summaryrefslogtreecommitdiff
path: root/sci-mathematics/lcalc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-mathematics/lcalc
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-mathematics/lcalc')
-rw-r--r--sci-mathematics/lcalc/Manifest1
-rw-r--r--sci-mathematics/lcalc/lcalc-2.0.5-r2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-mathematics/lcalc/Manifest b/sci-mathematics/lcalc/Manifest
index 1eb4c5ec373f..520e2692a609 100644
--- a/sci-mathematics/lcalc/Manifest
+++ b/sci-mathematics/lcalc/Manifest
@@ -1,3 +1,4 @@
DIST lcalc-2.0.5.tar.xz 830360 BLAKE2B 4a282de8548bc0b3d95fe079362ea98dd1397a1f0f7c4c61c6d2df8c5f95b9638aa628a25b138e6037520c69e56bfab635872115139caf3270d473e01276b980 SHA512 d3b7fa25dd3c2a8f88671076dfb5ab5e933be7feff24bbd160c92a476953f5553f9fb58f72c36b9c668929385084918fc3396e1a0bcc55de12ea8cb647c53929
EBUILD lcalc-2.0.5-r1.ebuild 925 BLAKE2B 98e8909c3bf87fe2446ced959d9a9f57d7ada72e81d40393d4b0e0488a5cf0ef6cbc0ae215ca61c0b5293bb309257cb7af682fe2013b99b17fa732bec5e6ae0e SHA512 10df01062ba4b5e27be0e69603350bc7361ca17f9a2468f3da8a550b81f8637afec065d2a9e42dc147afb562053c8b0c1eab57e269b6c88ebf928b8b9f5f7821
+EBUILD lcalc-2.0.5-r2.ebuild 1004 BLAKE2B 0031433a7ea5552239336d240347ca4b80a3ec1d2365ba8d784013bf768ee82ab7bfc9398c63bfd8e7246c49e9aa973995797568ae40b819dd0b31a5defb3cfb SHA512 32f6b8753a198006fe5165127c0e28de2212077f03ec8c66e93c76c10fea258b6f1cd693c7a05965f1a8097ce52a1be895b65f7bad374d6b33682948c593824e
MISC metadata.xml 1165 BLAKE2B 77544a05687fad32c18cb8d840d8de4291cae4135976bd741bbfd57a015956d5104026b99b1aec934d6a260501d89cd947e052a2ac85e35d2c93f7fc08224ac1 SHA512 cce822c8b50d97a7f8405634f565c3fbe147732db57bd66cccbaad2c2eda23076b76d0dfa442d462d55625a5dff06dde9bdf5e6ab4a9c9417d2f69972cc87add
diff --git a/sci-mathematics/lcalc/lcalc-2.0.5-r2.ebuild b/sci-mathematics/lcalc/lcalc-2.0.5-r2.ebuild
new file mode 100644
index 000000000000..640cc2e5b59b
--- /dev/null
+++ b/sci-mathematics/lcalc/lcalc-2.0.5-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command-line utility and library for L-function computations"
+HOMEPAGE="https://gitlab.com/sagemath/lcalc"
+SRC_URI="https://gitlab.com/sagemath/lcalc/uploads/25f029f3c02fcb6c3174972e0ac0e192/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+# The subslot is the libLfunction soname major version
+SLOT="0/1"
+KEYWORDS="~amd64"
+
+# Omit USE=mpfr for now because it's broken upstream:
+#
+# https://gitlab.com/sagemath/lcalc/-/issues/7
+#
+IUSE="+double double-double quad-double pari"
+REQUIRED_USE="^^ ( double double-double quad-double )"
+
+BDEPEND="dev-util/gengetopt"
+DEPEND="double-double? ( sci-libs/qd:= )
+ quad-double? ( sci-libs/qd:= )
+ pari? ( sci-mathematics/pari:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with pari) \
+ --enable-precision="$(usev double)$(usev double-double)$(usev quad-double)"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}