summaryrefslogtreecommitdiff
path: root/sci-mathematics/jags
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /sci-mathematics/jags
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'sci-mathematics/jags')
-rw-r--r--sci-mathematics/jags/Manifest2
-rw-r--r--sci-mathematics/jags/jags-4.3.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/sci-mathematics/jags/Manifest b/sci-mathematics/jags/Manifest
index 3f53973eef64..dcc5911956a0 100644
--- a/sci-mathematics/jags/Manifest
+++ b/sci-mathematics/jags/Manifest
@@ -1,3 +1,5 @@
DIST JAGS-4.2.0.tar.gz 1875538 BLAKE2B 039cefdb546ec28b905f22a4ec3dfe6d85c64064701283fe38be59f53da971b523d8bb5b7c5efe3e9da81a255b064cb8b66cac2fd4e844883b7fcf89cdabdbb1 SHA512 316483cd1a879c70c9b8ad6f23665196b95b9745da3924a47e14f4b0fd7c1abf9237575561cb31044623594360b6e991de68e1d9746baedeb285c65b77baada8
+DIST JAGS-4.3.0.tar.gz 2057409 BLAKE2B 5820c66dd10cc90343d53b901b7dbc1acf85dca0f5f80280864190882f0af865edad877eb2cfd421ec2035d3ae843373da1facee8a10b6735e2fc0387d452949 SHA512 d0564c73ff45484afad532ed788353f9c0945cd9667030eed5be674492bf97524d05903b22d4995c1de8a331dba7b04425d009e114d98a38b4bfce5214518b36
EBUILD jags-4.2.0.ebuild 894 BLAKE2B aba98ae327b60f41e48cdd755a8ad260d36e30ee443815b1de1bf46849305fa3e80f093323d358fe796f0def4c04c980a9ea4123c22ff51a779167ebd19cb38f SHA512 e0391a0dc0fd916ea0c82d722f7d989451866218a31ada58bc217cd5eb6d365ec75612e57664a977eb87240ee85229bf10676d9805b3688503a65b8f6bb93623
+EBUILD jags-4.3.0.ebuild 908 BLAKE2B e511db8f576b9c86b59e2a585518fef073093f82ae24a6c9e42e0ba23f5213867e28932f08cbb3d6d5d51150652837bb2cb600ef85b6bc8a780b48362ce325b2 SHA512 2467d5ebdd1a68111ed08a116b5118850dfaad10095de9a30e2c322e839a0f28edc389cf4f0d4f2356b9cf0f9d68eed47ec932ae8491477cac13a7f588cbb493
MISC metadata.xml 862 BLAKE2B 4e1fc4e399dfcdbfc828dc577661e28255c94004bb1f16734994d82b34279300b136217effbf545d1c0cdf3bfb9d1510b2549f1edcbe51f036924e7d4bab1416 SHA512 86f27a081286b51ba645006d3c65ec43d69aa4e15218bac97730295e2ebd1cab67c592f1c7fefdbdd9b959b68e54eaf358173f7d599cb1ab5ff13dea7eef3705
diff --git a/sci-mathematics/jags/jags-4.3.0.ebuild b/sci-mathematics/jags/jags-4.3.0.ebuild
new file mode 100644
index 000000000000..0a07a6aa6740
--- /dev/null
+++ b/sci-mathematics/jags/jags-4.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MYP="JAGS-${PV}"
+
+DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
+HOMEPAGE="https://mcmc-jags.sourceforge.io/"
+SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/4.x/Source/${MYP}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ econf \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+}
+
+src_compile() {
+ emake all $(usex doc docs "")
+}
+
+src_install() {
+ default
+ use doc && dodoc doc/manual/*.pdf
+ find "${ED}" -name '*.la' -delete || die
+}