summaryrefslogtreecommitdiff
path: root/sci-mathematics/gmm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/gmm
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/gmm')
-rw-r--r--sci-mathematics/gmm/Manifest5
-rw-r--r--sci-mathematics/gmm/gmm-5.1.ebuild22
-rw-r--r--sci-mathematics/gmm/metadata.xml17
3 files changed, 44 insertions, 0 deletions
diff --git a/sci-mathematics/gmm/Manifest b/sci-mathematics/gmm/Manifest
new file mode 100644
index 000000000000..d3e01cfbfeee
--- /dev/null
+++ b/sci-mathematics/gmm/Manifest
@@ -0,0 +1,5 @@
+DIST gmm-5.1.tar.gz 537290 SHA256 90e6bf309b81f496b401a375fe99826ad4b5c6ba99db6c92b37f9261db462636 SHA512 403074c2efedf2d9f63076a46faabb27c1bc19356284fac89aef58220ce0900d126b6f1a4f9bbef1641be1d609a8379729cad063695a570756ae0b2c470cedad WHIRLPOOL 6d152bb978b66cfdd70042ceab866365a377e76206867ee090b727f50fcc0f68796dae3754240a2fc6bb4c4de09fe0e45d2518a1098fa85a003f6bacaf62bbc9
+EBUILD gmm-5.1.ebuild 571 SHA256 c5ce4b6f78178a3e45bcefea2a931ac8c161d04e41cc220473cec7ca776c16fe SHA512 38e82747d1144b37b682b3599024af980e8d2e38a7f4bd078dcec3866c1709c0ec494fe95b271ca26df2ed3cf927d6465088a6bf9e9eea0742fcf7e8e4c7f78a WHIRLPOOL f528c8ed0042e307b0a28e10d4f5e0f8bdea6f92c3e18740b87bf3e8382aed1788e8be63b98ff78fb7c65a2d0a09b4bc9b4a29a7efe0ddbbbc3eb0166411e6bc
+MISC ChangeLog 3103 SHA256 a68d19600e1355dc0f5b695b0e91d4c2b86dd39145548d49ba35da8a3b447ad7 SHA512 569a33771bcb7b3a3d09e074ef209e88ba3e52cc8355d5018d357101170d73d1ac95ddc36b2e6e00394f4fd0836d80186458ef8c9899cdadbfecf25f73e8fdff WHIRLPOOL 55e12b2fdcdbc4b9adc4c439117ee24adf3ae8b963e80b45044620b5e96dee5f9c8be4a3826d9116ca9d019f05d90a5ae65f860fd9c2e793c6beec3d918f8ad6
+MISC ChangeLog-2015 4041 SHA256 e4af67d623d54b5d88f4af76b3c7575c0080e8a1461926577d9fe5ed91de2314 SHA512 9e772dcec1bd34ece1c2a826c0fa88efe316676f38ee40e038f6e9fec3d5ad839979bca97d91a15c040ba3e936d3a6eafb1369f2b40ae1e0ae27a6cb659ca5c0 WHIRLPOOL 626907aca614385570208643c2b05151e7dab1afb62ef6e31d4b2b448cddd02e0f1902b08f8ebfc82468048020693b1394c2dce791ee99c32b51ef74de9c6834
+MISC metadata.xml 747 SHA256 e94581878b7061b4ef22ed87c34b2f61b41c71ead737a31b8667b921b696b746 SHA512 10c681ecfb5f05c61b24badecdc640e92053c56b3d1c3a324a8664a6c4012823c08070f7fd7334007353b04203f5570ded69821779446ce209896301741b7415 WHIRLPOOL aa70e119e205c46bc38073b2a09a2ec12a9d1ab961d54d21f71bf9bbae2fc47a82b1f3fd35ae9123cbf4d18ed78cf818d2e17b54f36bb05171de4d430c07557e
diff --git a/sci-mathematics/gmm/gmm-5.1.ebuild b/sci-mathematics/gmm/gmm-5.1.ebuild
new file mode 100644
index 000000000000..afc103e6cc62
--- /dev/null
+++ b/sci-mathematics/gmm/gmm-5.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Generic C++ template library for sparse, dense and skyline matrices"
+SRC_URI="https://download.gna.org/getfem/stable/${P}.tar.gz"
+HOMEPAGE="https://www-gmm.insa-toulouse.fr/getfem/"
+
+LICENSE="|| ( LGPL-3 LGPL-3-with-linking-exception )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_configure() {
+ # required for tests, #612294
+ append-cxxflags -std=c++14
+
+ default
+}
diff --git a/sci-mathematics/gmm/metadata.xml b/sci-mathematics/gmm/metadata.xml
new file mode 100644
index 000000000000..ace95c48b19f
--- /dev/null
+++ b/sci-mathematics/gmm/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>amynka@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ Gmm++ is a generic C++ template library for sparse, dense and
+ skyline matrices. It is built as a set of generic algorithms (mult,
+ add, copy, sub-matrices, dense and sparse solvers ...) for any
+ interfaced vector type or matrix type. It can be view as a glue
+ library allowing cooperation between several vector and matrix
+ types. However, basic sparse, dense and skyline matrix/vector types
+ are built in Gmm++, hence it can be used as a standalone linear
+ algebra library.
+</longdescription>
+</pkgmetadata>