summaryrefslogtreecommitdiff
path: root/sci-mathematics/glpk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-10 19:03:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-10 19:03:44 +0000
commit6a4408b9bbd9fe61dc0966f587db94081fa5f52b (patch)
treeb169c2aac67648694c722324d81d57fd34c69d23 /sci-mathematics/glpk
parent8c8f1cfd2aa9e839aad7dad6fd43b370cfbc0a1e (diff)
gentoo auto-resync : 10:01:2024 - 19:03:44
Diffstat (limited to 'sci-mathematics/glpk')
-rw-r--r--sci-mathematics/glpk/Manifest1
-rw-r--r--sci-mathematics/glpk/glpk-5.0-r2.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/sci-mathematics/glpk/Manifest b/sci-mathematics/glpk/Manifest
index 31d076dbbbf2..01329fbf6a9f 100644
--- a/sci-mathematics/glpk/Manifest
+++ b/sci-mathematics/glpk/Manifest
@@ -2,4 +2,5 @@ AUX glpk-4.65-debundle-system-libs.patch 1930 BLAKE2B 0c265afe9338e75bb3d6536e9e
AUX glpk-4.65-fix-mysql-include-prefix.patch 1837 BLAKE2B ecd90024e07f29e8ebb6af80b520c8f192cfea21c90d8c247001389f2ccfcf24ad487981a0cc719d1ca99e266dd2a9d66f6416d4f2d5e7c80bdf807b9bb7b74e SHA512 c74281bf3e03e136d183b562b8f682a3e1957019a36ec0c6a048049f0d5f55361107a62e36eaa9e3306a1f13df10adf55c2f54f096b6e353108856e05d9ce799
DIST glpk-5.0.tar.gz 4132649 BLAKE2B f8204f66a97af950c13ee72ee9541f305745741d1231325670ede14663cb6c28ec6fbc44b3625973f1924ca078183d1d43f494ad43a7b48b45be131882b00001 SHA512 4e92195fa058c707146f2690f3a38b46c33add948c852f67659ca005a6aa980bbf97be96528b0f8391690facb880ac2126cd60198c6c175e7f3f06cca7e29f9d
EBUILD glpk-5.0-r1.ebuild 2337 BLAKE2B 659648006deea5911ea99aba53ac9cffc046fa32785198d59dab2bdc85ad8dadf9c84278dbf6066c0583748bbd82a0196d433e64e4756b8c0ff723be43d9192b SHA512 422961d5d98b8da9ae2c375f5deafa02fa3c4ab0ed12e73f9cd34be2b117892f3151f9ec52e917bae36be887267837bbe13f76c064d42900ee6cb2c3296063f8
+EBUILD glpk-5.0-r2.ebuild 2384 BLAKE2B a4d1511c697ed7ef6e61ad3a1018d57d5b0ebe8bbebbd5988a67dc0ad3f1087568b2803ac474a47c4cbfa56e24307dc9d1a0450c0cab1b9b98c6c81547351376 SHA512 02c77c1216cf611338ae2be5478fd3c955eea96b074c96e97daa5fa053f36e6156a90b5e0e50d064d0f4757c0db7eed785a61ff2a3a2d41cb28a44c94063c824
MISC metadata.xml 1104 BLAKE2B f22121178a0e7f3ab097558b05cb084a7dc787cc1530859d6182aea61abee220e135ad695f517419053bb805cecef9c3555fcdb2688d6b6d17cdd8b3ce2dbb21 SHA512 965c2c6c322c488736cb9743f1e076fdf2733976502b2b2668717534f7a1505f36b84f453f23f4ff5972f7a25883d253e345caef727bab8abed4c638f5a0dc5a
diff --git a/sci-mathematics/glpk/glpk-5.0-r2.ebuild b/sci-mathematics/glpk/glpk-5.0-r2.ebuild
new file mode 100644
index 000000000000..ccc0e863233f
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-5.0-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="GNU Linear Programming Kit"
+HOMEPAGE="https://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/40"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples gmp odbc mysql"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ sci-libs/amd:0=
+ sci-libs/colamd:=
+ sys-libs/zlib:0=
+ gmp? ( dev-libs/gmp:0= )
+ mysql? (
+ dev-db/mysql-connector-c
+ dev-libs/libltdl
+ )
+ odbc? (
+ || (
+ dev-db/libiodbc:0
+ dev-db/unixODBC:0
+ )
+ dev-libs/libltdl
+ )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.65-fix-mysql-include-prefix.patch
+ "${FILESDIR}"/${PN}-4.65-debundle-system-libs.patch
+)
+
+src_prepare() {
+ # TODO: the ODBC library is dlopen()ed, so we only want to append
+ # -I<foo> to the preprocessor flags, and not all of the CFLAGS that
+ # were used to build libiodbc. That fix and the pkg-config fallback
+ # should be sent upstream, and placed into CPPFLAGS rather than
+ # CFLAGS (as configure.ac does now).
+ use odbc && [[ -z $(type -P odbc_config) ]] && \
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags libiodbc)
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use mysql || use odbc; then
+ myconf="--enable-dl"
+ else
+ myconf="--disable-dl"
+ fi
+
+ econf ${myconf} \
+ --disable-static \
+ $(use_enable mysql) \
+ $(use_enable odbc) \
+ $(use_with gmp)
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ # The top-level Makefile descends into the "examples" directory
+ # unconditionally, building a program and excreting build
+ # artifacts that we don't want to install. Note: this still
+ # leaves the example program /usr/bin/glpsol installed. An
+ # additional "emake ... uninstall" could probably take care
+ # of that if desired.
+ emake -C examples clean
+
+ # Installing the Makefiles for the examples does the user no
+ # good without the top-level Makefile.
+ rm examples/Makefile{.in,.am,} \
+ || die "failed to remove example Makefiles"
+
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+
+ use doc && dodoc doc/*.pdf doc/notes/*.pdf doc/*.txt
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}