summaryrefslogtreecommitdiff
path: root/sci-mathematics/gimps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /sci-mathematics/gimps
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'sci-mathematics/gimps')
-rw-r--r--sci-mathematics/gimps/Manifest2
-rw-r--r--sci-mathematics/gimps/gimps-30.4.8.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/Manifest b/sci-mathematics/gimps/Manifest
index e152a3b9a2ec..11410f9d5ec8 100644
--- a/sci-mathematics/gimps/Manifest
+++ b/sci-mathematics/gimps/Manifest
@@ -5,5 +5,7 @@ AUX gimps.service 283 BLAKE2B db6c0c777d514aa0216c1af087418ead25561ffa950752e237
AUX gimps.tmpfiles 38 BLAKE2B c306d739ed0a0cc8bb4c80c7051ad93326cf0054d3f7fd61c4ed8a7d518356d521f7d3c3202d0b8b69723b8e7178457a34c65e92732eb15e8e64c3dff468ae2a SHA512 61c5eda13289175cdf55704442ceab4d5391d24cfa49f04155799fc2798e5ad5f1e624802e1c04b99685b1560f9898d1b0fc0c15c82251d1a765dd5de93024d8
DIST p95v303b6.linux32.tar.gz 5702312 BLAKE2B 728c8b8e7e2b5187dc8126bccc5e2c165fbfbc0900d6c35517cd21b78e5292df143641e3766cc0146918062039b1eecab568f9b278f64b1b9197ee2f775603b9 SHA512 3e06fb77be07334949ece3ae152bdf5491f0b7f8e33e0e8ed2af3c34332841975a9514d1993ed2355abfa4e09f93e42093d02f96dc30c3471ae9f974cc2de11a
DIST p95v303b6.linux64.tar.gz 7046127 BLAKE2B 9cde9c2670203071cfc463434a47c8123064cb232bfeb25d8767cad2c25ea75b395e2ec135b7b4a6dc9616e9d6b05ead371e1083274a82468f62a0e1de93c98f SHA512 6d6ded9a1724993d42adee28d400b0337835c52a4ce42271e62efb37134adfc6f017f55475860fbc1224e377a227ef8547b8852a35c082c37e996f4a1c1b570c
+DIST p95v304b8.linux64.tar.gz 7163830 BLAKE2B 248a2d5343e25fd9153294bf8e84a59253f28feb7ede8147b73d08077a107c63e0209adfd48845f64ce51e06cd32aec966e4a36ef20e1c30df4f0be0d4978d86 SHA512 b4f89c89714e738f468f085ac9902db0b62cad720a926f91cf8dbe25153e41a207e1c10a5d74136976994b9d1ca312653e6b91536ed3d57bc44760055143f4b3
EBUILD gimps-30.3.6.ebuild 1808 BLAKE2B 3483a73734d0b0008c992a946d36558f1e8ac93872a46bf80d79bb21ae65720c5614df1e1380fb15c2db2537559bc1969fc90dba0614afef1c2f8a6419ea996d SHA512 0dd32cf22373ec922a2716afc7f60ed5af2b0f76ba8f91b94eef891b1137b1dc597f0aca3609f76cb56b3f90b973953decd946d37e02cb6a1db1df1fd81c55a4
+EBUILD gimps-30.4.8.ebuild 1798 BLAKE2B b90eb57316e3cb619ecc84ea1e8a86e0f5ff1ca57f99a1a6bf7b603b3ce555335e5b13792b42347340bcc09c40e5f15ebd957e4c6b534f2dd2742c22330a61a4 SHA512 e9c7147cd7b9488273406c3f2085e34650e961cd29ac8f1f2314a6828edcaa9e2f70600b33aa3186f34f0d4acd21b62f440ebdfda79a4a6e713fd39b4104c88d
MISC metadata.xml 529 BLAKE2B a6e3550d128d6c4801029726feb868aa1cd1017b8a2f6f7ebbb3743a7b2190d40db06d22eb4f8ce94e35ab5e6b1f213afdf179fe7777501ad87457be43d9af44 SHA512 a7fb9bd05f987e1d48a04b70e78cbb3906927197793870435fee8b68dd9da623a68fc30ca96d0173952414d9741674ba2cc2c3f821dfd7b302f91f09e887a362
diff --git a/sci-mathematics/gimps/gimps-30.4.8.ebuild b/sci-mathematics/gimps/gimps-30.4.8.ebuild
new file mode 100644
index 000000000000..59980c5dd0c3
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-30.4.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils readme.gentoo-r1 systemd tmpfiles
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="https://www.mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(ver_rs 2 'b' )
+
+SRC_URI="
+ amd64? ( https://www.mersenne.org/ftp_root/gimps/p95v${MY_PV/./}.linux64.tar.gz )
+ "
+
+SLOT="0"
+LICENSE="GIMPS"
+RESTRICT="mirror bindist"
+KEYWORDS="-* ~amd64"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+OPTINSTALLDIR="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt whatsnew.txt undoc.txt )
+
+src_install() {
+ dodir ${OPTINSTALLDIR}
+ keepdir /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${OPTINSTALLDIR}" || die
+ fperms a-w "${OPTINSTALLDIR}/mprime"
+ fowners root:0 "${OPTINSTALLDIR}"
+ fowners root:0 "${OPTINSTALLDIR}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
+
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}