summaryrefslogtreecommitdiff
path: root/sci-mathematics/gfan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-mathematics/gfan
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-mathematics/gfan')
-rw-r--r--sci-mathematics/gfan/Manifest1
-rw-r--r--sci-mathematics/gfan/gfan-0.6.2-r1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-mathematics/gfan/Manifest b/sci-mathematics/gfan/Manifest
index 10ef992c17ad..b358f870e3ef 100644
--- a/sci-mathematics/gfan/Manifest
+++ b/sci-mathematics/gfan/Manifest
@@ -2,5 +2,6 @@ AUX gfan-0.6.2-Makefile.patch 6603 BLAKE2B 48f9b4280418aef41d502d770c070ec1dcef9
AUX gfan-0.6.2-testsuite.patch 3223 BLAKE2B ddb94775a13bd503df5c9563750a6b4b68c9e72e1a19aaa0415c5484e07765dfd28ba02b3a0fab65a0b9cd5c61afafbc6a3d862a1de68ece57ef9d8bb2835c16 SHA512 d62e765a39ee1a8cb149fcae8afb538b19a91206dd0b8cf0ac2b681b28569e44f492b770b9e61d7573f2d52f265ad4cf25671197c204238a89075709753a83e6
AUX gfan-0.6.2-xcode9.3_compat.patch 367 BLAKE2B fb7c685a4dd811fed83e2734a16507b1792e3a97c666d0e7de1d2ed53a7b9b43c5319517f9eef829f47147dc725f2c4ead38968fa3868baa1d16630a8b844636 SHA512 129d2c35777f82bf2a1581450ecb12dd6811fb72b583748b30665c0f9b20d39646233d9b40fb64a3c7790360514a51b30e49c53d83c34d259f664bf820ae1ce2
DIST gfan0.6.2.tar.gz 1321059 BLAKE2B 1ed61e1e084a1ceb65dd21848440bc3a90486c0ce4012b3b64c8029e89636696d2b0e5446ea156d2cf050b5db179c7c2f25c97e683cecf6e9616e8553d8513bf SHA512 5961820750af2522fdc1a86c0254742c3b003607a8707df5d6cd5f0bc6461e4d3db3b1d3cb537979d57eb9dff387974a58aeb91d0b5246d7c701cadc5a2cf4cf
+EBUILD gfan-0.6.2-r1.ebuild 1664 BLAKE2B 92b9e0f24b298aa32180a1406e0b5280c744a2a504a189b9836a13892d8d89226167335697605561be07350b09b0890b1e0939fbe87fb7b181f2916e1c7c5f2a SHA512 f76ceff1753b8dc00c161ecf824ea1f5751e52a357806b947a108ca05e9388c9f34349f738cf899d6d09fc8e6162842382a58d32a5f176269df1b24c5db4bfb3
EBUILD gfan-0.6.2.ebuild 1628 BLAKE2B 272e77ecdf1e7132bb3a703ed3871cea502d621d596ec47c3529459c120a44921028aa0c064936a49c6b727b6bf44f78971679ff3bf3f9450d3ae945a02193e0 SHA512 c4eaf7e2debfcca9d3a92e6f9abfc1e568c09747db8ebf7caa3ad34c3208de47b8841819d1c5ddd6866b127f9d9496e61616f2bda1cbeb1588c58b682cc0550c
MISC metadata.xml 1343 BLAKE2B 1e3385eaf888fa6a69e1e3f761bd5a1037e5a5308878664e604ba5efd096747f84a0a3343d8de7f6eb5dd3ce726d94bdb933e17b9eaf8e345b02fd071fbf821b SHA512 ca914de593af1279439f35fdcc812924b831c30bfa86366443f16cb720acd3e38267f25057f59e76a6b8ff1aa48a33ecfa72c093419aab95c92ed82c3308cd94
diff --git a/sci-mathematics/gfan/gfan-0.6.2-r1.ebuild b/sci-mathematics/gfan/gfan-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..01434747eede
--- /dev/null
+++ b/sci-mathematics/gfan/gfan-0.6.2-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Compute Groebner fans and tropical varieties"
+HOMEPAGE="https://users-math.au.dk/~jensen/software/gfan/gfan.html"
+SRC_URI="https://users-math.au.dk/~jensen/software/${PN}/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="doc? ( virtual/latex-base )"
+DEPEND="dev-libs/gmp:0=[cxx]
+ sci-libs/cddlib:0="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.2-xcode9.3_compat.patch"
+ "${FILESDIR}/${PN}-0.6.2-testsuite.patch"
+ "${FILESDIR}/${PN}-0.6.2-Makefile.patch"
+ )
+
+pkg_setup() {
+ tc-export CC CXX
+
+ # This should really go in cppflags, but that doesn't work with
+ # gfan's hand-written Makefile.
+ append-cxxflags -DNOCDDPREFIX -I"${EPREFIX}"/usr/include/cddlib
+}
+
+src_prepare() {
+ default
+
+ # This test hangs on x86, bug 717112.
+ rm -r testsuite/0602ResultantFanProjection || \
+ die "unable to disable test 0602ResultantFanProjection"
+}
+
+src_configure() {
+ # The upstream Makefile says that GCC produces bad code with -O3.
+ replace-flags "-O3" "-O2"
+ default
+}
+
+src_compile() {
+ default
+ if use doc; then
+ pushd doc > /dev/null || die
+ # The LaTeX build commands need to be repeated until the
+ # document "stops changing," which is not as easy as it
+ # sounds to detect. Running it twice seems to work here.
+ pdflatex manual.tex && bibtex manual && pdflatex manual.tex || die
+ popd > /dev/null || die
+ fi
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+ use doc && dodoc doc/manual.pdf
+}