summaryrefslogtreecommitdiff
path: root/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-25 02:03:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-25 02:03:50 +0000
commit426aa983e40197a69c600c42e0679b2161ca225c (patch)
tree0d279fe549a8f3cc4b684897eaf275d91c8411fe /sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild
parentec9f79e1d3358df31a704f16a76a269ccceae2b2 (diff)
gentoo auto-resync : 25:12:2022 - 02:03:49
Diffstat (limited to 'sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild')
-rw-r--r--sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild b/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild
new file mode 100644
index 000000000000..6bf57a25ef10
--- /dev/null
+++ b/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing
+
+DESCRIPTION="Allows the certificates Gappa generates to be imported by the Coq"
+HOMEPAGE="https://gappa.gitlabpages.inria.fr/
+ https://gitlab.inria.fr/gappa/coq/"
+SRC_URI="https://gappa.gitlabpages.inria.fr/releases/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=sci-mathematics/coq-8.12
+ sci-mathematics/flocq
+ sci-mathematics/gappa
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/findlib"
+
+# Do not complain about CFLAGS etc since ML projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+src_compile() {
+ ./remake --jobs=$(makeopts_jobs) || die
+}
+
+src_test() {
+ ./remake --jobs=$(makeopts_jobs) check || die
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die
+
+ dodoc AUTHORS INSTALL.md NEWS.md README.md
+}