summaryrefslogtreecommitdiff
path: root/sci-mathematics/gappa
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-25 02:03:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-25 02:03:50 +0000
commit426aa983e40197a69c600c42e0679b2161ca225c (patch)
tree0d279fe549a8f3cc4b684897eaf275d91c8411fe /sci-mathematics/gappa
parentec9f79e1d3358df31a704f16a76a269ccceae2b2 (diff)
gentoo auto-resync : 25:12:2022 - 02:03:49
Diffstat (limited to 'sci-mathematics/gappa')
-rw-r--r--sci-mathematics/gappa/Manifest3
-rw-r--r--sci-mathematics/gappa/gappa-1.4.1.ebuild43
-rw-r--r--sci-mathematics/gappa/metadata.xml18
3 files changed, 64 insertions, 0 deletions
diff --git a/sci-mathematics/gappa/Manifest b/sci-mathematics/gappa/Manifest
new file mode 100644
index 000000000000..cca8a6a88b2a
--- /dev/null
+++ b/sci-mathematics/gappa/Manifest
@@ -0,0 +1,3 @@
+DIST gappa-1.4.1.tar.gz 388314 BLAKE2B 08bc38745fd33a892ef288315bb4eac730c96ddb379ec4689385b63a9f1f74a662bc303f8323bf3941875b6d38e988fe4114e0db84994a7e7a5858b178cc0026 SHA512 bae9788fdce92b04b011b9de207a1234215cbb68c8bd0a60d925fa5fb5e1cad014d60ed8b45d84e8fabd6b54a870a70af6dd24dd68f4dbb2e129f83dcf88fa11
+EBUILD gappa-1.4.1.ebuild 815 BLAKE2B 3c1549f5e47b6a322aabb9176acb61720709a69e28536623fab8c4bea6ab6fa62d5f1d6971eb8998fc1eb920bd6591d195ed5a09867086b8ac4aff84a44fb551 SHA512 73f07724979bb6272384fb519ebc37b11b733605dcbba3ee9389c3532865e3256010ff6f8b83726408194ba8430da0fa47383de5a0e75c7aa015ea52f40d832c
+MISC metadata.xml 706 BLAKE2B 681b7e1a45b2b64fbcccf58bdb00ee058949ddc915fe056afa6e9aee12d6938b8740115c5431eb44415d0e46121d3543f7f8e8795b4112c64740e1ca806d079c SHA512 f93cc2afb547fd838215a22dc1dff148217927caef6f315716bdb0d7def9ddfa6026b1c7976d519ac4717ad0b70b58afcd8fbbfe42635c0bb1b2e608b5f95c62
diff --git a/sci-mathematics/gappa/gappa-1.4.1.ebuild b/sci-mathematics/gappa/gappa-1.4.1.ebuild
new file mode 100644
index 000000000000..ccbc7161da2a
--- /dev/null
+++ b/sci-mathematics/gappa/gappa-1.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER=doxygen
+DOCS_DIR=doc/doxygen
+
+inherit docs multiprocessing
+
+DESCRIPTION="Tool for verifying floating-point or fixed-point arithmetic"
+HOMEPAGE="https://gappa.gitlabpages.inria.fr/
+ https://gitlab.inria.fr/gappa/gappa/"
+SRC_URI="https://gappa.gitlabpages.inria.fr/releases/${P}.tar.gz"
+
+LICENSE="CeCILL-2 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS INSTALL.md NEWS.md README.md )
+
+src_compile() {
+ ./remake --jobs=$(makeopts_jobs) || die
+
+ docs_compile
+}
+
+src_test() {
+ ./remake --jobs=$(makeopts_jobs) check || die
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die
+
+ einstalldocs
+}
diff --git a/sci-mathematics/gappa/metadata.xml b/sci-mathematics/gappa/metadata.xml
new file mode 100644
index 000000000000..d91a4022ddfa
--- /dev/null
+++ b/sci-mathematics/gappa/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ Gappa (Génération Automatique de Preuves de Propriétés Arithmétiques --
+ automatic proof generation of arithmetic properties) is a tool intended to
+ help verifying and formally proving properties on numerical programs
+ dealing with floating-point or fixed-point arithmetic.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.inria.fr/gappa/gappa/-/issues/</bugs-to>
+ </upstream>
+</pkgmetadata>