summaryrefslogtreecommitdiff
path: root/sci-mathematics/gap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-05 17:43:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-05 17:43:10 +0000
commitc31f575f39c1e387f18f630fb01d3a89c2339fdf (patch)
treed6db6ce35cd0849abe99eccd07d0f86a1aa82025 /sci-mathematics/gap
parent34d05d15811bd789a5348824d4f4151a49f924c9 (diff)
gentoo auto-resync : 05:02:2024 - 17:43:10
Diffstat (limited to 'sci-mathematics/gap')
-rw-r--r--sci-mathematics/gap/Manifest3
-rw-r--r--sci-mathematics/gap/files/gap-4.12.2-cc-and-cxx-for-gac.patch42
-rw-r--r--sci-mathematics/gap/gap-4.12.2-r4.ebuild (renamed from sci-mathematics/gap/gap-4.12.2-r3.ebuild)2
3 files changed, 46 insertions, 1 deletions
diff --git a/sci-mathematics/gap/Manifest b/sci-mathematics/gap/Manifest
index 21b9346c0594..4959caba2d86 100644
--- a/sci-mathematics/gap/Manifest
+++ b/sci-mathematics/gap/Manifest
@@ -1,3 +1,4 @@
+AUX gap-4.12.2-cc-and-cxx-for-gac.patch 1677 BLAKE2B 4a6a4b0d8b62b7ffdb0da2ba683439dde1ed80d3a3e74f92f5a46098619a13f755bd5b7d024a14541d2cc0f65ccb3677f18719c14972741ea347a7ce35c9ac42 SHA512 f8a48975777db8e09d31350a2688eb621cd27869c61c52fd99b6b6991f7a695e3e43b80277ebb6b4466dbf6de7b0bc05b3dfa8497aaba114763b4315c5d99414
DIST gap-4.12.2-core.tar.gz 37671069 BLAKE2B 7e2c35f0bb232fc5478ff09e98b9c4d021ee5df775f2ff4934b27f871c18a3781386c24b94f1255517c4193c1eb9ff6396ea70e8d6cf72ccbb5480ca837ef8eb SHA512 d16af2648b0a655df7ce28cf8e2c6b3d0e33eda806674844a9813b4cb5068b137005225c02b8651a25b608e9b76a184f54f2e291a957a4675c38a7883ef83a38
-EBUILD gap-4.12.2-r3.ebuild 4237 BLAKE2B a5742d700d7aa5ac217e240160deb77323f0da79e4399b86cbe6cde3d9e2c040f040430947b647422bd9c0ce3ec8d9ae9bd70aec5331629dcc5a8a2c5484b340 SHA512 42a6f2ab3a0f2f833b8a2cb6efaef8a477d2ff40bf7781d4bbca3719461e366e250654b4ad865853d69d287791ac376ccae1fa1a4044ce8a947a911c05d1aa33
+EBUILD gap-4.12.2-r4.ebuild 4294 BLAKE2B 4e5783b052809638768188569f5236ec96832bba1dc009937a61a8b8c53fb16264079bf717a3ddcd6ae42ba4e4d09a9ad36a8ec80ef7f2c7526e96cef967da7a SHA512 0f593ff8c3bec90982048d879738bc6d08a833f938ac4cd4476bb193ebf68a8e07b752958e14d093b13225978a8e29bf164d98d16d58045cdc3daa818e352811
MISC metadata.xml 1582 BLAKE2B 9151244f139b0d675e327731c336c41d5d69c25856286c182944d57255fbb6d7b1f023195b3a01c829ff6f3ea1d5e6eb6edbcc796a30120deacde82b90b5f39c SHA512 f4490e9b13cee6604f14df39ea048d7578e080a8faa97b0bb22191a7dce56904416870ed64c289f91526087009f7488e8baed4e531c78f50a5b917e9e1684ce2
diff --git a/sci-mathematics/gap/files/gap-4.12.2-cc-and-cxx-for-gac.patch b/sci-mathematics/gap/files/gap-4.12.2-cc-and-cxx-for-gac.patch
new file mode 100644
index 000000000000..cfdfb4ac8a11
--- /dev/null
+++ b/sci-mathematics/gap/files/gap-4.12.2-cc-and-cxx-for-gac.patch
@@ -0,0 +1,42 @@
+From 2933af2d8a986430a4fcf2ab4d577e5bb049662a Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Fri, 2 Feb 2024 18:14:59 -0500
+Subject: [PATCH] cnf/gac.in: respect $CC and $CXX if they're non-null
+
+This allows the user to override the stored C and C++ compilers
+(typically obtained from sysinfo.gap) if desired. This is especially
+useful on rolling release and/or source-based distributions where the
+"current" compiler can change frequently and without user interaction.
+
+Closes: https://github.com/gap-system/gap/issues/5606
+---
+ cnf/gac.in | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+
+diff --git a/cnf/gac.in b/cnf/gac.in
+index 1faafba820..3a9fc6eb16 100644
+--- a/cnf/gac.in
++++ b/cnf/gac.in
+@@ -63,6 +63,22 @@ GAP_CFLAGS="${GAP_CFLAGS} ${GAC_CFLAGS}"
+ GAP_CXXFLAGS="${GAP_CXXFLAGS} ${GAC_CFLAGS}"
+ GAP_LDFLAGS="${GAP_LDFLAGS} ${GAC_LDFLAGS}"
+
++# Using the stored C/C++ compilers from sysinfo.gap is sometimes
++# undesirable. For example, if the compiler suite is upgraded or
++# downgraded, the particular executable used to build GAP itself may
++# no longer exist. The CC and CXX environment variables provide a
++# somewhat standard way for the user to indicate which compilers he
++# would like to use. So if those are set, we prefer them to the stored
++# values. This allows people who know what they are doing to override
++# the default behavior, while keeping the defaults safe for normal
++# people.
++if test -n "${CC}"; then
++ c_compiler="${CC}"
++ c_dyn_linker="${CC}"
++fi
++if test -n "${CXX}"; then
++ cxx_compiler="${CXX}"
++fi
+
+ # is output going to a terminal?
+ if test -t 1 && command -v tput >/dev/null 2>&1 ; then
diff --git a/sci-mathematics/gap/gap-4.12.2-r3.ebuild b/sci-mathematics/gap/gap-4.12.2-r4.ebuild
index d44da14dfd8a..f9f41bafaaab 100644
--- a/sci-mathematics/gap/gap-4.12.2-r3.ebuild
+++ b/sci-mathematics/gap/gap-4.12.2-r4.ebuild
@@ -62,6 +62,8 @@ RDEPEND="${DEPEND}"
# packages, use package.provided.
PDEPEND="${REQUIRED_PKGS} !minimal? ( ${AUTOLOADED_PKGS} )"
+PATCHES=( "${FILESDIR}/${P}-cc-and-cxx-for-gac.patch" )
+
pkg_setup() {
if use valgrind; then
elog "If you enable the use of valgrind during building"